Титул

Г.І.Манко

Основи Основи

комп'ютерно- комп'ютерно-

інтегрованого інтегрованого

управління управління


Терміни та визначення

1 Поняття комп'ютерно-інтегрованого управління

Почнемо з визначень, необхідних для розуміння подальших відомостей.

Інформація - відомості про навколишній світ (об'єкти, явища, події, процеси і т.п.), що зменшують наявний ступінь невизначеності, неповноти знань, відчужені від їхнього творця і такі, що стали повідомленнями. Ці відомості є вираженими визначеною мовою у вигляді знаків, у тому числі і записані на матеріальному носії. Їх можна відтворювати шляхом передачі людьми усним, письмовим чи іншим способом.

Інформаційна технологія - система методів і способів збору, передачі, накопичення, обробки, збереження, представлення і використання інформації.

Інформаційна система (ІС) - інформаційний контур, створений засобами збирання, передачі, обробки і збереження інформації, а також персоналом, що здійснює ці дії.

Призначення інформаційних систем, що використовуються в технологічних системах - це виробництво інформації для забезпечення ефективного керування всіма їх ресурсами, створення інформаційного і технологічного середовища для здійснення керування технологічною системою.

Інформаційна система управління підприємством (ІСУП) - це операційне середовище, що здатне надати менеджерам і фахівцям актуальну і достовірну інформацію про всі бізнеси-процеси підприємства, необхідну для планування операцій, їхнього виконання, реєстрації й аналізу. Іншими словами, ІСУП - це система, що несе в собі опис повного ринкового циклу - від планування бізнесу до аналізу результатів діяльності підприємства.

Звичайно в системах керування виділяють три рівні: стратегічний, тактичний і оперативний. На кожному з цих рівнів керування є свої задачі, при вирішенні яких виникає потреба у відповідних даних, одержати ці дані можна шляхом запитів в інформаційну систему. Інформаційні технології дозволяють обробити запити і, використовуючи наявну інформацію, сформувати відповідь на ці запити. Таким чином, на кожнім рівні керування з'являється інформація, що служить основою для прийняття відповідних рішень.

Функціонування ІСУП відбувається у так званому інтегрованому інформаційному середовищі (ІІС). ІІС визначається державними стандартами як сукупність розподілених баз даних, які містять відомості про вироби, виробниче середовище, ресурси і процеси підприємства, що забезпечує коректність, актуальність, схоронність і доступність даних тим суб'єктам виробничо-господарської діяльності, що беруть участь у здійсненні життєвого диклу виробу, кому це необхідно і дозволено. Усі відомості (дані) у ІІС зберігаються у вигляді інформаційних об'єктів.

Під комп'ютерно-інтегрованою системою розуміють автоматизовану систему (АС), у якій всі операції з інформаційними потоками автоматизовані на основі комп'ютерних технологій. Як відомо, АС поділяються на автоматизовані системи управління (АСУ), системи автоматизованого проектування конструкторського (САПР-К) і технологічного (САПР-Т) призначення, автоматизовані системи наукових досліджень (АСНД) та ін. В АСУ інтеграція окремих операцій керування в єдине ціле здійснюється на основі використання єдиного інформаційного простору. Відповідні системи називаються комп'ютерно-інтегрованими системами управління (КІСУ).

Комп'ютерно-інтегроване управління передбачає наступні характеристики:

  • мережевий зв'язок - для полегшення і керування передачею даних між підсистемами;
  • розподіленність системи - для запобігання зосередження аналізу й обробки даних в одному місці;
  • відкритість програмного забезпечення - для більш легкого і швидкого доповнення нових прикладних програм КІУ;
  • адаптованість до суміжних систем - для забезпечення можливості використання засобів автоматизованої підтримки прикладних програм інших систем.

    • Комп'ютерно-інтегроване виробництво (КІВ) - це виробнича система на рівні цеху або підприємства, в якій комплексно автоматизовані як процеси управління на всіх рівнях, так і облік матеріальних цінностей. При цьому матеріальні потоки можуть бути як автоматизовані так і не автоматизовані.

    Концепція комп'ютерно-інтегрованого виробництва виникла на початку 80-х років і пов'язана з інтеграцією виробництва і систем керування ним. КІВ з погляду систем керування і планування припускає інтеграцію всіх підсистем системи керування (керування постачанням, проектуванням і підготовкою виробництва; планування і виготовлення; керування виробничими ділянками і цехами; керування транспортно-складськими системами; керування забезпеченням устаткуванням, інструментом і оснащенням; систем забезпечення якості, збуту, а також фінансових підсистем).

    Сукупність усіх систем підготовки і керування утворює інтегровану систему автоматизації (ІСА) виробничої діяльності підприємства. На сучасному рівні автоматизації така система обов'язково включає елементи інтелектуалізації і визначається як інтелектуальна інтегрована система (ІІС).

    Сучасне підприємство у своїй діяльності зв'язано з багатьма іншими підприємствами: суміжниками, виготовлювачами і постачальниками комплектуючих виробів, замовниками й іншими. Узгодження між ними виробничих питань впливає на загальний час виконання замовлення, а його зменшення вимагає в першу чергу автоматизації загальних інформаційних потоків. Така сукупність організаційно самостійних підприємств, інформаційно зв'язаних між собою для виконання визначених замовлень являє собою віртуальне підприємство (ВП).

    Методи CALS (Computer-aided Acquisition and Logistics Support - комп'ютерна підтримка процесу постачань і логістики) виникли в 80-х роках у військовому відомстві США для підвищення ефективності керування і планування в процесі замовлення, розробки, організації виробництва, постачань і експлуатації військової техніки. CALS передбачає однократне введення даних, їхнє збереження в стандартних форматах, стандартизацію інтерфейсів і електронний обмін інформацією між всіма організаціями та їхніми підрозділами - учасниками проекту. Методи довели свою ефективність і переносяться в даний час на "цивільні" галузі промисловості. Нова концепція зберегла абревіатуру CALS з більш широким змістом (Continuous Acquisition and Life circle Support - підтримка безупинного життєвого циклу продукції). Проводиться стандартизація ряду аспектів CALS у міжнародній організації стандартизації ISO. CALS дозволяє керувати всім життєвим циклом продукції, включаючи маркетинг, керування комплексними проектами, обслуговуванням при експлуатації.

    Укрупнена структура типової CALS-системи показана на рис. 1.1.

    Рис. 1.1

    Системи ERP (Enterprise Resource Planning) призначені для керування фінансовою і господарською діяльністю підприємств. Це "верхній рівень" в ієрархії систем керування підприємством, що стосується ключових аспектів його виробничої і комерційної діяльності, таких як виробництво, планування, фінанси і бухгалтерія, матеріально-технічне постачання і збут, керування кадрами, керування запасами, ведення замовлень на виготовлення (постачання) продукції і надання послуг. Такі системи створюються для надання керівництву інформації для прийняття управлінських рішень, а також для створення інфраструктури електронного обміну даними підприємства з постачальниками і споживачами

    Контролінг - це інформаційно-аналітична підтримка прийняття рішень у менеджменті. Інформаційні системи керування є комп'ютерною підтримкою контроллинга. Контролінг, у свою чергу, є основним постачальником інформації для керування підприємством. Головна задача інформаційної підтримки контролінгу - забезпечити керівництво інформацією про поточний стан справ підприємства і спрогнозувати наслідки змін внутрішнього чи зовнішнього середовища. Мета контролінгу - правильна оцінка господарських ситуацій для прийняття вивірених управлінських рішень.


ТЕОРЕТИЧНІ ОСНОВИ

2 ТЕОРЕТИЧНІ ОСНОВИ КОМП'ЮТЕРНО-ІНТЕГРОВАНОГО УПРАВЛІННЯ

2.1 Сигнали

Сигнал - це матеріальний носій інформації. У відповідності з фізичною природою процесу, що використовується для передачі інформації, сигнали називають струмовими, частотними, фазовими і т.д.

Сигнали представляють у часовій або частотній області.

Часова область зручна при зображенні змін сигналу в часі. Ми усі знаємо, що таке синусоїда. Кожна синусоїда характеризується трьома параметрами: амплітудою, початковою фазою і частотою. Одна синусоїда має одну частоту. Частота - це параметр, що показує як часто сигнал повторює сам себе. Зворотним частоті є період. Він відповідає тривалості, що займає в часі один період періодичного сигналу. На графіках рис. 2.1 показані дві синусоїди з різними частотами і, отже, різними періодами.

Рис. 2.1

Частотна область зручна для зображення частотного складу сигналів. Кожна синусоїда, представлена на графіку, має одну частоту. Отже, у частотній області кожна синусоїда представляється тільки однією частотною складовою. Її амплітуда (на графіку - червона вертикальна риска) у частотній області пропорційна амплітуді синусоїди в тимчасовій області. Частота f1 відповідає частоті першої синусоїди, а f2 - другий. Чим вище частота синусоїди, тим далі по осі частот вона розташовується.

Серед характеристик сигналів будемо розглядати як головні часову та частотну характеристики. Обидві характеристики показують, як змінюється амплітуда сигналу: перша у часі, друга - в залежності від частоти. Частотну характеристику часто називають спектром сигналу.

Періодичні сигнали можуть бути описані періодичною функцією:

x(t)= x(t ± kT), (2.1)

де k=1,2,3...

Цей сигнал повторює свої значення через інтервал часу Т, який називається періодом. У більшості випадків періодичний сигнал будь-якої форми може бути представлений рядом Фур'є

(2.2)

де t = 2p t/T.

Таким чином, періодичний сигнал може бути представлений як сукупність синусоїдальних сигналів, які називаються гармоніками сигналу.

Процес розкладу періодичної функції на гармоніки носить назву гармонійного аналізу. Спектр періодичного сигналу є лінійчастим, кожній гармоніці відповідає своя лінія спектру. Такий спектр має назву дискретного (рис. 2.2).

Рис. 2.2 - Дискретний спектр

Неперервна лінія, що з'єднує кінці ліній спектра, називається лінією що огинає;.

Неперіодичний сигнал можна розглядати, як періодичний, у якого період Т наближається до нескінченності. Із збільшенням Т різниці частот сусідніх складових спектру зменьшуются до безкінечно малої величини d , а ряд Фур'є перетворюється у інтеграл Фур'є:

(2.3)

Кількість гармонік стає нескінченно великою, а відстань між ними зменшується до нуля. Таким чином, спектр неперіодичного сигналу перетворюється в неперервну функцію (рис. 2.3).

Рис. 2.3 - Неперервний спектр

Інтеграл Фур'є може бути представленим в комплексній формі

(2.4)

де

(2.5)

Формула (2.4) носить назву прямого, а формула (2.5) оберненого перетворення Фур'є. Формула (2.5) виражає комплексну спектральну характеристику сигналу x(t ). Модуль і аргумент спектральної характеристики являють собою спектр амплітуд і спектр фаз неперіодичного сигналу.

Отже, якщо ряд Фур'є представляє періодичну функцію як суму періодичних складових, то інтеграл Фур'є представляє неперіодичну функцію як суму періодичних складових. Спектр неперіодичної функції містить коливання усіх частот.

2.2 Математичні моделі сигналів

2.2.1 Елементарні сигнали

Найпростішим елементарним сигналом є постійний сигнал, незмінний у часі. Його математична модель:

x=const. (2.6)

Постійний сигнал має тільки один параметр х.

Часова та частотна характеристики постійного сигналу показані на рис. 2.4.

Рис. 2.4 - Характеристики постійного сигналу: а - часова; б - частотна
Другий елементарний сигнал - ідеальний одиничний імпульс, який описується дельта-функцією:
(2.7)
де tд - момент дії імпульсу.

Отже ідеальний одиничний імпульс має один параметр - момент його дії tд.

Однією з цікавих властивостей дельта-функції є те, що спектр її є рівномірним у межах -¥ < w < +¥

Інтеграл від добутку дельта-функції на будь-який сигнал x(t) дорівнює значенню цього сигналу в момент t=tд:

(2.8)

Це означає, що дельта функція має стробуючу дію. Ця властивість використовується для представлення дискретизованих сигналів.

Третій елементарний сигнал - синусоїдальний або гармонійний:
x = Xm sin(wt + j). (2.9)

Він визначається трьома параметрами: амплітудою Xm , частотою w або періодом T= 2p/w та початковою фазою j. Часова характеристика та спектр синусоїдального сигналу показані на рис. 2.1.

2.2.3 Випадкові сигнали та їх характеристики

Випадковим називають сигнал, який в ході його аналізу може приймати той або інший конкретний вигляд, при чому невідомо, який саме.

Конкретний вигляд, який приймає сигнал під час його дослідження, називається реалізацією випадкового сигналу, а її математичний опис - виборочною функцією. В результаті групи випробувань отримують сімейство реалізацій сигналу. Таке сімейство реалізацій прийнято називати ансамблем реалізацій. Якщо задати момент часу t1, однаковий для усіх реалізацій або виборочних функцій, то сукупність значень всіх таких значень виборочних функцій називається перерізом випадкового процесу (рис. 2.5)

Рис. 2.5

Переріз випадкового сигналу по ансамблю реалізацій є випадковою величиною. Чим більше реалізацій сигналу буде досліджено, тим точніше можна описати випадковий сигнал.

Параметрами випадкового сигналу є:

а) математичне очікування або момент першого порядку

(2.10)

де p(X) - щільність ймовірності випадкової величини Х;

б) дисперсія або момент другого порядку

(2.11)

в) кореляційна функція, що визначається для двох перерізів випадкового процесу t1 та t2=t1+t

(2.12)

або нормована кореляційна функція

(2.13)

Якщо закон розподілу випадкового сигналу не залежить від часу, то такий сигнал називається стационарним. Для багатьох стационарних сигналів статистичні характеристики, отримані для перерізу випадкового сигналу по ансамблю реалізацій, являются ідентичними характеристикам, які отримані на основі однієї реализації достатньої продовженості у часі. Такі сигнали називаються ергодичними.

Якщо статистичні характеристики сигналів отримують в загальному випадку осередненням по ансамблю реалізацій, такі ж характеристики ергодичних стационарних сигналів отримують осередненям у часі по наступним формулам:

а) середнє значення випадкового сигналу:

(2.14)

середнє значення стационарного сигналу є постійною величиною;

б) середнє значення квадрату випадкового сигналу:

(2.15)

в) автокореляційна функція:

(2.16)

Стационарні ергодичні сигнали характеризують двома складовими: постійною та змінною. Постійна дорівнює середньому значенню сигналу згідно (2.14). Змінна складова оцінюється дисперсією, яка характеризує розсів значень сигнала відносно до середнього значення і дорівнює середньому значенню квадрата відхилення сигналу від середнього значення:

(2.17)

бо середнє значення стационарного сигналу є постійна величина.

Випадковий сигнал, як і детермінований, можна розкласти у ряд Фур'є або застосувати до них перетворення Фур'є згідно виразам (2.4) і (2.5), тобто представити цей сигнал як сукупність кінечної або нескінченої кількості гармонік. Амплітуди гармонік будуть випадковими величинами. Дисперсія сигналу також буде розподілена по гармонікам. Деяким з частот відповітатимуть більші значення дисперсії, іншим - менші. Це можна графічно проілюструвати, як спектр дисперсій (рис. 2.6).

Рис. 2.6

При переході від ряду Фур'є до інтегралу Фур'є дискретний спектр замінюється неперервним. Для випадкового сигналу такий спектр можна розглядати, як графік щільності розподілу дисперсій по частотах. Кожному як завгодно малому інтервалу частот d відповідатиме елементарна дисперсія dD(w) (рис. 2.7). Загальна дисперсія дорівнює площі під кривою спектральної щільності.

Рис. 2.7

Спектральну щільність дисперсії знаходять застосуванням перетворення Фур'є до корреляційної функції:

(2.18)

2.3 Загальні поняття теорії інформації

2.3.1 Структура інформаційного каналу

Процес управління складається в отриманні інформації про об'єкт управління і вироблення на її основі керуючої інформації. Для передачі інформації використовуються сигнали. Виникає задача оцінки кількості інформації у сигналі і визначення втрат інформації в ході формування сигналів, а також під час передачі сигналів по каналах зв'язку.

Треба розрізняти поняття “інформація” і “повідомлення”. Під повідомленням зазвичай розуміють інформацію, яка виражена в певній формі і підлягає передачі. Повідомлення - це форма представлення інформації.

Класична теорія інформації була розроблена Робертом Шенноном для рішення задач передачі інформації з мінімальними втратами. Згідно Шеннону, модель системи зв'язку має вигляд, представлений на рис. 2.8.

Рис. 2.8 - Структура інформаційного каналу

Модель містить такі складові частини:

а) джерело інформації, яке виробляє повідомлення або послідовність повідомлень;

б) кодуючий пристрій, який перетворює повідомлення в сигнали, придатні для передачі по каналу зв'язку; цей пристрій називають також передавачем;

в) канал передачі інформації від передавача до приймача;

г) декодуючий пристрій, що виконує функції відновлення початкового повідомлення за отриманим сигналом; цей пристрій називають також приймачем;

д) об'єкт, якому призначається повідомлення (одержувач інформації);

е) джерело шуму (завад).

В теперешній час на основі класичної теорії інформації створена інформаційна теорія управління.

В системах управління джерелом інформації є об'єкт управління. Повідомленням виступає сигнал від датчика, яким оснащений об'єкт управління. Датчик - це кодуючий пристрій. Кодуючими пристроями є також і різноманітні перетворювачі, які використовуються в каналі управління.

Похибки, що притаманні датчикам і перетворювачам, розглядаються як завади. Тож канал передачі - це не тільки лінії зв'язку для передачі сигналів, він включає в себе майже усі технічні пристрої, що входять в канал управління. Тобто поділ на складові частини моделі інформаційного каналу (згідно рис. 2.8) здійснюється функціонально, а не апаратурно.

2.3.2 Поняття кількості інформації

Кількість інформації визначається як математична міра зменшення невизначеності знань про який-небудь об'єкт в процесі пізнання. Якщо Н1 - початкова (апріорна) невизначеність знання з даного питання, а Н2 - залишкова (апостеріорна) невизначеність, що характеризує стан знання після отримання повідомлення, то кількість інформації, що міститься в цьому повідомленні визначається різницею:

I = Н1 - Н2. (2.19)

Таким чином, повідомлення несе тим більше інформації, чим в більшому степені зменшується невизначеність про об'єкт, що досліджується.

Ґрунтуючись на ідеї, що інформація усуває деяку невизначеність, тобто незнання, опис будь-якої події або об'єкту формально можна розглядати як вказівку на те, в якому з можливих станів знаходиться описуваний об'єкт. Тоді протікання подій в часі є не що інше, як зміна станів, вибраних з деякою вірогідністю з числа всіх можливих станів. Чим вище рівень невизначеності вибору, тим потрібний більший об'єм інформації, і результат вибору має значний ступінь несподіванки. От чому кількість інформації є мірою зняття невизначеності однієї випадкової величини (наприклад, технологічного параметру) в результаті спостереження за іншою (наприклад, сигналом). Якщо ці величини незалежні, то кількість інформації є рівною нулю. В нашому прикладі, сигнал в цьому разі не несе інформації про відповідний технологічний параметр.

Для оцінки міри невизначеності знань використовуються поняття невпорядкованості і неорганізованості. Об'єкт, що досліджується, характеризується вектором Х змінних величин, що характеризують стан об'єкта. Невпорядкованістю [image] називається чисельна міра відхилення вектора Х' змінних, отриманих внаслідок дослідження об'єкта, від дійсного вектора Х. Як приклад такої міри може виступати модуль різниці реальних і експериментально отриманих імовірностей значень цих змінних.

Якщо невпорядкованість - величина змінна, що приймає різні значення в різних ситуаціях і в різні моменти часу, то не організованість - узагальнена за число ситуацій, що розглядаються, і часових інтервалів невпорядкованість

(2.20)

де [image] - символи узагальнення невпорядкованості за m інтервалів часу і n ситуацій; k - вага k-го інтервалу часу; Pj - імовірність j-тої ситуації.

Для практичних цілей як неорганізованість зручно використовувати узагальнену за число ситуацій, що розглядається, характеристику невпорядкованості, зважену, по-перше, по імовірності Pj j-тої ситуації, а по-друге, по істотності вияву невпорядкованості, яка може визначатися вибором деякої функції Y від параметра невпорядкованості [image] . Тоді неорганізованість визначаємо виразом

(2.21)

Найбільший інтерес представляє логарифмічна функція, яка забезпечує властивість адитивності міри неорганізованості:

. (2.22)

Якщо як параметр невпорядкованості використати апріорні імовірності Pj можливих результатів дослідження об'єкта, такі, що сума всіх імовірностей є рівною одиниці, то вираз для неорганізованості набуває вигляду:

(2.23)

Така міра невизначеності була введена Шенноном і отримала назву інформаційної ентропії. Інформаційна ентропія оцінює апріорну невизначеність знань про досліджуваний об'єкт.

При однаковому значенні всіх імовірностей результату дослідження кожна з них Pj = 1/N і ентропія стає рівною:

(2.24)

Якщо як параметр невпорядкованості використати апостеріорні імовірності Qj, тобто такі, якими їх вважає одержувач інформації, то для конкретизації виразу (2.22) доцільно застосовувати формулу невизначеності Бонгарда:

(2.25)

Вираз (2.25) характеризує степінь невизначеності знань про об'єкт, що характеризується розподілом імовірностей P={Pj} для спостерігача, що одержує результат досліджень з розподілом імовірностей Q={Qj}.

2.3.3 Ентропія неперервного сигналу

Для оцінки ентропії неперервного сигналу застосування формули (2.23) в загальному випадку неможливо. З цієї формули видно видно, що ентропія є сумою N доданків, які мають вигляд Hj=-PjlogPj. Якщо сигнал безперервний, то в будь-якому заданому діапазоні [Xmin, Xmax] він має нескінченне число значень. Сума нескінченного числа складових Hj приводить до ентропії, рівної нескінченності. Однак така постановка питання не має сенсу. Будь-яке вимірювання супроводиться погрішністю. Тому більш правильною буде така постановка задачі: визначити ентропію знання про значення неперервного сигналу, що підлягає вимірюванню з кінцевою похибкою D . Тоді діапазон значень сигналу можна розбити на N=(Xmax-Xmin)/ D дільниць. Якщо задана щільність імовірності р(Х) значень величини X, то імовірність того, що внаслідок вимірювання вийде j-е значення, приблизно дорівнює: р(Xj)×D = Pj (рис.2.9).

Рис. 2.9

Тоді ентропію можна знайти, підставляючи в її загальну формулу значення Pj (j=1,…,N).

. (2.26)

Переходячи від суми до інтеграла, отримуємо

(2.27)
оскільки D = const, a

Перший доданок в отриманому вираженні

. (2.28)

називається диференціальною ентропією. Вона повністю визначається щільністю імовірностей значень сигналу і не залежить від похибки розрізнення цих значень. Тому всі сигнали з однаковим законом розподілу характеризуються однією і тією ж диференціальною ентропією.

2.3.4 Методи визначення кількості інформації

Внаслідок одержання повідомлення апріорна невизначеність знання про джерело сигналу не може бути знижена до нуля, оскільки завжди є завади в каналі передачі.

Нехай сигнал несе інформацію про виміряне значення технологічного параметру. На рис. 2.10. показаний апріорний розподіл p(X) значень вимірюваної величини і апостеріорний p'(X), який отримуємо після вимірювання з похибкою ±D/2. Внаслідок вимірювання область невизначеності вужчає від [Xmin,Xmax] до інтервалу [Xк-D ,Xк+D] довжини D, розташованого симетрично відносно отриманого результату Хк.

Рис. 2.10

У дискретному випадку, сигнал може приймати тільки фіксовані значення, число яких в заданому діапазоні кінцеве, залишкова невизначеність оцінюється формулою (2.22), в яку підставляються апостеріорні значення ймовірностей сигналу. Визначимо через Р(i/j) апостеріорну імовірність того, що одержувач отримає j-е значення сигналу, в той час як дійсне значення i-е. Оцінимо залишкову невизначеність знання про джерело сигналу X, якщо отриманий результат Zк:

(2.29)

Величина [image] називається частковою умовною ентропією. Середня умовна ентропія

(2.30)

характеризує апостеріорну невизначенність досліджуваного об'єкта, стан якого визначається отриманим сигналом Z. Тоді , згідно (2.19), кількість інформації, що несе сигнал Z:

(2.31)

Найпростішим випадком є вибір альтернативи з двох подій. Тому за одиницю інформації доцільно прийняти кількість інформації, що міститься у виборі однієї з двох рівноімовірних подій. Ця одиниця називається двійковою одиницею, або бітом (binary digit, bit). Отже, при будь-якій невизначеності звуження області вибору удвічі дає одну одиницю інформації.

Апостеріорну невизначеність можна оцінювати формулою (2.25). В цьому випадку використовується формула корисної інформації Бонгарда:

(2.32)

Корисна інформація може приймати як позитивні, так і негативні значення. В останньому випадку повідомлення несе дезінформацію.

2.3.5 Пропускна спроможність каналу передачі

Якщо на відрізку часу Т передаються n повідомлень в моменти часу ti, для яких значення сигналу Xi статистично не залежать одне від одного (не корельовані), то загальна ентропія дорівнює сумі ентропій

(2.33)

Максимальна кількість інформації, що міститься в i-му повідомлені,

Ii = Hi(X). (2.34)

а загальна інформація, яка може бути отримана у n повідомлень

IТ = HТ(X) = nHi(X). (2.35)

Відношення

. (2.36)

що характеризує швидкість отримання інформації, називається продуктивністю джерела сигналу.

При малих завадах невизначеність значень сигналу знімається в момент вимірювання майже повністю. Потім невизначеність зростає, і через час Dt стає рівною Hi(X). Якщо повідомлення формуються через рівні проміжки часу Dt, то їх кількість за час Т:

. (2.37)

Тоді (2.36), з урахуванням (2.37), отримує вигляд:

. (2.38)

Таким чином, продуктивність джерела сигналу визначається швидкістю зростання ентропії.

Продуктивність джерела, як і ентропія, залежать від закону розподілу імовірностей сигналу.

Очевидно, що швидкісні характеристики каналу повинні відповідати продуктивності джерела сигналу. Середня швидкість створення інформації визначається виразом (2.36). Ця величина залежить від Т, тому як міра швидкості використовується межа [image].

Верхня границя швидкості може бути знайдена, якщо згадати властивість ентропії приймати максимальне значення, коли всі повідомлення рівноймовірні:

. (2.39)

Така швидкісна характеристика називається пропускною спроможність каналу.

Користуючись (2.36), інформацію, що отримується від джерела за час Т, можна виразити через його продуктивність

IТ = RT . (2.40)

Значення інформації, яке може бути отримане за час Т максимальне, якщо продуктивність джерела дорівнює його пропускній спроможності

IТmax = CT. (2.41)

Відношення

(2.42)

називається надмірністю джерела інформації

Якщо джерело інформації, продуктивність якого дорівнює пропускній спроможності каналу (R=С), у n0 повідомленях дає кількість інформації I, то джерело з надмірністю, для якого R<С, може забезпечити таку інформацію у n>n0 повідомленях, тобто треба створити n-n0 надмірних повідомлень. Тоді надмірність можна інакше визначити як

g = (n-n0)/n = 1- n0/n . (2.43)

Надмірність виникає не тільки при відхиленні закону розподілу сигналу p(Х) від оптимального, але і у випадку, якщо між значеннями сигналу Х в моменти створення ti існує статистична залежність, оскільки при цьому зменшується приріст ентропії Hi(X).


ТЕОРЕТИЧНІ ОСНОВИ - Фільтрація сигналів

2.4 Фільтрація сигналів

Аналоговим фільтром називається частотно-селективне коло, яке забезпечує пропущення сигналів в одних смугах частот і подавлення в інших. Область частот, в якій фільтр пропускає сигнал, називають смугою пропущення або смугою прозорості, а область частот, в якій послаблення сигналу велике – смугою затримування або смугою непрозорості. Частота, що лежить на межі цих смуг, називається частотою зрізу fз.

У залежності від розташування смуги прозорості на шкалі частот розрізнюють:

1) фільтри нижніх частот (ФНЧ), що пропускають без великого ослаблення коливання всіх частот нижче за частоту зрізу fз;

2) фільтри верхніх частот (ФВЧ), що пропускають без великого ослаблення коливання всіх частот вище за частоту зрізу fз;

3) смугові фільтри (СФ), що пропускають без великого ослаблення коливання смуги частот від частоти зрізу fз1 до частоти зрізу fз2.

4) загороджуючі або режекторні фільтри (РФ), що ослабляють коливання смуги частот від частоти зрізу fз1 до частоти зрізу fз2.

Ослаблення фільтром сигналу оцінюють відношенням напруги Uвх на вході фільтра до напруги Uвих на виході:

а = Uвх / Uвих.. (2.41)

Часто це відношення виражають в децибелах:

b = 20 lg (Uвх / Uвих). (2.42)

і називають загасанням фільтра. Залежність загасання фільтра від частоти називають частотною характеристикою загасання.

Застосовується також інша характеристика фільтра – коефіцієнт передачі.

Реальні фільтри з чітко вираженою частотою зрізу не існують. У реальних фільтрах є смуга частот, в якій коефіцієнт передачі змінюється від максимального до мінімального або навпаки. Амплітудно-частотна характеристика реального фільтра низьких частот показана на рис. 2.12.

Рис. 2.11

Параметрами фільтра є межі смуг пропущення w1 і затримування w2, загасання у смузі затримування Х2 і коефіцієнт передачі у смузі пропущення Х1.

Цифровим фільтром називається пристрій або програма, або змішана апаратно-програмна структура, яка використовується для цифрової обробки дискретних або кодових сигналів з метою отримання вихідних сигналів, що мають задані частотні характеристики.

При аналізі і проектуванні цифрових фільтрів використовуються їх характеристики у часовій і частотній областях і їх взаємне перетворення. Як відомо, для дискретизированого сигналу з періодом дискретизації Т спектральна характеристика визначається формулою прямого перетворення Фур’є:

(2.43)

Відновлення сигналу виконується по формулі зворотного дискретного перетворення Фур’є:

(2.44)

Вираз(2.44) називають імпульсною характеристикою фільтра.

По характеру імпульсної послідовності на виході фільтри поділяються на:

1) фільтри з кінцевою імпульсною характеристикою (KІХ), для яких число відліків n кінечне, тобто N1<n<N2;

2) фільтри з нескінченною імпульсною характеристикою (НІХ), для яких число відліків n нескінченне, тобто -¥<n<N2 або N1<n <¥.

Для будь-якої лінійної дискретної системи залежність значень вихідної величини Y від значень вхідної величини Х описується різносним рівнянням

(2.45)

Прийнявши bo=1, перетворюємо останнє співвідношення:

(2.46)

Згідно з цим виразом, для визначення Y(n) необхідно знати попередні значення Y(n-k). Функція (2.68) є рекурсивною, оскільки визначається через саму себе. Відповідно і фільтри, що реалізовують алгоритм (2.68), називаються рекурсивними фільтрами.

Якщо не брати до уваги попередні значення величини Y, то вираз (2.68) спрощується

(2.47)

Фільтри, що реалізовують алгоритм (2.47), називаються нерекурсивними.

Згідно (2.47), вихідний сигнал ЦФ можна представити у вигляді суми зсунутих у часі імпульсів, амплітуди яких відповідають амплітудам дискретних відліків сигналів на вході фільтра. Відповідно до цього цифровий фільтр можна створити, використовуючи набір пристроїв затримки сигналів у часі і суматор, на який вхідні сигнали подаються з вагою ao, a1,…,aм (рис. 2.12, а). Оскільки число пристроїв кінцеве, то такий фільтр є нерекурсивним КІХ-фільтром.

Рис. 2.12

На рис. 2.13, б) показана структурна схема рекурсивного HІХ-фільтр. Відліки вихідного сигналу формуються як сума затриманих відліків з вагою b1, b2,… і т.д., які через суматор знов подаються на пристрої затримки. Процес може тривати нескінченно, звідки і назва фільтра.


ТЕОРЕТИЧНІ ОСНОВИ - Квантування сигналів

2.5 Квантування сигналів

Якщо в аналогових пристроях сигнал Х може приймати будь-які значення в діапазоні [Xmin, Xmax], то цифрових пристроях нескінченій сукупності значень сигналу Х ставиться у відповідність кінечна й така що лікується сукупність можливих значень вихідних кодів N. Число можливих різних кодів визначається конструкцією квантувателя. При цьому повинна виконуватись умова:

(2.48)

де q – константа, яка називається номінальним ступенем квантування; X(Nmax) і X(Nmін) – значення сигналу, що відповідають максимальному Nmax і мінімальному Nmін можливим значенням вихідного коду квантувателя; M – число можливих різних кодів квантувателя (ціле число).

У процесі квантування сигнал, що змінюється лінійно

Y = ksX, (2.49)

замінюється ступінчастою кривою (рис. 2.13).

Рис. 2.13

Кожному з можливих значень Yi (i = 1, 2, …, M) відповідає незліченна сукупність [Xli,Xri] значень вхідного сигналу квантувателя, де Xli,Xri – ліва та права границя і-ї сукупності. Ступінчаста крива має розриви у точках Xli та Xri для всіх 1≤i<M. Ця крива повинна найкращим чином приближатися до прямої (2.42). Під найкращим приближенням розуміється таке положення ступенчастої кривої, за якого абсолютне відхилення її від прямої (2.49) буде мінімальним, тобто виконується умова:

якщо X Î[Xli,Xri], то або |X – Xli|, або |X - Xri| не повинні перевищувати 0,5 |Xli - Xri|, при чому q = |Xli - Xri|. Таким чином, значення неперервної величини Xi точно відповідає значенню квантованої величини Yi в середині інтервалу [Xli,Xri] .

Ступінчаста крива може бути описана формулою

Y = ksq Int[X/q +0,5SignX], (2.50)

де Int[A] – функція, що має назву “ціла частина А”; Sign A - функція, що має назву “знак числа А”. Остання функція може приймати такі значення:

Функція (2.50) співпадає з (2.49), коли q наближається до нуля.

Для спрощення подальших викладок приймемо ks=1. Тоді номінальна функція перетворення буде мати вигляд:

Y = X. (2.51)

Ступінчаста крива, яка найкращим чином приближується до прямої (2.51), виражається формулою:

Y = q Int[X/q +0,5SignX], (2.52)

Формула (2.52) називається функцією перетворення ідеального квантувателя. Оскільки вона не співпадає з (2.51) при q>0, можна зробити висновок, що навіть ідеальний квантуватель вносить похибку. Абсолютна похибка D идеального квантувателя дорівнює нулю в середині інтервалу [Xli,Xri] і досягає екстремальних значень на краях цього інтервалу (див. рис. 2.14)

Рис. 2.14

Як бачимо, похибка ідеального квантувателя є періодичною функцією. Похибка ця відноситься до систематичних, бо змінюється за відомим законом. Але врахувати її в результаті квантування неможливо через те, що для її обчислення треба знати істинне значення сигналу. Тому похибку квантувателя прийнято вважати випадковою величиною.

Для її визначення на i-му ступеню квантування використовують звичайні числові параметри випадкової величини:

а) математичне очікування

(2.53)

б) дисперсія

(2.54)

Тут xi – значення Х, що відповідає середині інтервала квантування [Xli,Xri], p(x) – закон розподілу сигналу.

У випадку великого числа ступенів квантування можно ввести допущення, що значення щільності ймовірності вимірюваної величини в даному і-му ступеню квантування є постійним і рівним p(xi), тобто своєму значенню при x=xi. Тоді

(2.55)

а дісперсія

(2.56)

Перейдемо тепер від і-го ступеня квантування на весь діапазон сигналу [0,Xmax].

(2.57)

Якщо квантування рівномірне, то qi=q=const, отже

(2.58)

Оскільки для усього діапазону [0,Xmax] справедливе співвідношення

то

(2.59)

Отже, дісперсія квантування у випадку достатньо великої кількості ступенів рівномірного квантування не залежить від закону розподілу ймовірностей вимірюваної величини.

Вираз (2.59) іноді називають потужністю шуму квантування.


ТЕОРЕТИЧНІ ОСНОВИ - Дискретизація сигналів

2.6 Дискретизація сигналів

Одночасно з квантуванням за рівнем у квантувателі відбувається і дискретизація сигналів у часі.

Дискретизація сигналів є перетворенням безперервного сигналу X(t) в послідовність миттєвих значень цього сигналу Хд(kTц), відповідних певним моментам часу kTц (де k = 1.2.3,…). Проміжок часу Тц між двома сусідніми моментами дискретизації називають кроком дискретизації.

Дискретизація неперервного у часі сигналу X(t) є лінійною операцією множення функції X(t) на функцію дискретизації у часі D*(t):

Хд(t) = X(t)· D*(t). (2.60)

Функція D*(t) є послідовністю одиничних імпульсів з періодом повторення Тц, тривалістю, рівною нулю і площею, рівною одиниці:

(2.61)

Ідеальний дискретизирований сигнал є послідовністю импульсів нульової тривалості, площі яких рівні ординатам сигналу X(t) в моменти kTц.:

(2.62)

Розкладемо функцію дискретизації в ряд Фур’є:

. (2.63)

Коефіцієнти ck визначаться з співідношення:

. (2.64)

Тоді дискретизований сигнал можна описати таким чином:

(2.65)

Вираз для спектральної щільності можна знайти, якщо застосувати до (2.65) інтегральне перетворення Фур’є:

(2.66)

де Х(w) – спектральна щільність недискретизованого сигналу X(t) . Таким чином, спектр дискретизованого сигналу є періодичним з періодом [image] .

У дискретизированому сигналі відсутні проміжні значення, які мав неперервний сигнал в моменти між точками дискретизації. Але для багатьох операцій управління принципово необхідний неперервний сигнал. Тому дискретизирований сигнал часто буває необхідно знов перетворити в неперервний, тобто відновити в ньому всі проміжні значення із заданою погрішністю.

Сигнал, що відновлюється, звичайно виражається сумою базисних функцій

(2.67)

де Ci(t) – деяка система базисних функцій, ai – коефіцієнти ряду.

Коефіцієнти ряду ai і базисні функції можуть вибиратися на основі різних критеріїв, наприклад, по мінімуму середньої квадратичної погрішності або за критерієм збігу значень неперервного відновленого сигналу з миттєвими значеннями дискретизованого сигналу.

У першому випадку коефіцієнти ряду визначаються як коефіцієнти відповідного ряду Фур’е:

(2.68)

Системою базисних функцій при цьому є ряд гармонік, які зручні для відтворення.

У другому випадку, коли коефіцієнти ряду і базисні функції вибираються по критерію збігу значень безперервного сигналу, що відновлюється з миттєвими значеннями дискретизованого сигналу, використовується ряд Котельникова,

(2.69)

який представляє неперервний сигнал сумою добутків миттєвих значень сигналу на деяку функцію часу, звану функцією відліків:

(2.70)

Властивості функції відліків:

а) функція відліків приймає значення 0 у точках відліку [image] , де i – ціле число, за винятком точки [image] , де функція відліку є рівною одиниці (рис. 2.15);

Рис. 2.15

б) функція відліків має прямокутний спекто амплітуд у смузі від –w c до +w c.

Ряд Котельникова можна використати для сигналів, що мають спектр з граничною частотою fc і дискретизовані з періодом [image] . Згідно теореми Котельникова, якщо спектр функції не містить складових з частотами вище fc, то ця функція повністю визначається послідовністю своїх значень в моменти часу, що знаходяться один від одного на відстані [image] . Таким чином, сигнал, спектр якого не має частот, вищих за fc, повністю визначається своїми миттєвими значеннями в дискретні моменти часу

(2.71)

і може бути точно відновлений за своїми відліковими значеннями з допомогою виразів (2.69) та (2.70).

Функція відліків являє собою реакцію ідеального фільтра нижніх частот на вхідний вплив у вигляді одиничної імпульсної функції. Отже, якщо дискретизований з кроком (2.71) сигнал подати на вхід ідеального фільтра з верхньою межею пропущення fc, то на виході отримаємо відновлений без похибок сигнал Х(t).


ТЕОРЕТИЧНІ ОСНОВИ - Кодування сигналів

2.7 Кодування сигналів

2.7.1 Поняття кодування

Хай даний алфавіт А={a1, …, am} послідовність символів якого утворюють всілякі повідомлення, тобто А – ансамбль елементарних сигналів на вході каналу передачі інформації. Хай ймовірності символів є рівними Р1, …, Рm. Кожному символу алфавіту А відповідно до деякого правила, званого коду, зіставимо кодове позначення – кодове слово Sk. Хай кожне кодове слово, у свою чергу, складене з символів деякого допоміжного алфавіту – кодового алфавіту, що містить D символів однакової тривалості. Припустимо, що ця тривалість рівна одиниці (це завжди можна зробити відповідним вибором одиниці вимірювання часу), так що тривалість кодового слова Sk рівна просто числу nk використовуваних в нім символів допоміжного алфавіту. Очевидно, що тривалість кодового слова при цьому є рівною

(2.72)

Виберемо значення nk так, щоб величина nср була мінімальною. Очевидно, в цьому випадку кількість символів початкового алфавіту, що передаються в одиницю часу, буде найбільшою і, відповідно, буде найбільшою швидкість передачі інформації. З виразу (2.72) видно, що для мінімізації nср необхідно, щоб тривалість nk, відповідна великим значенням Pk, була малою, тобто щоб часто використовувані слова були короткими, і навпаки, щоб велика тривалість відповідала словам, що рідко зустрічалися. Якщо як допоміжний алфавіт використовувати двійкові числа так, що символам основного алфавіту, що найбільш часто зустрічаються, відповідатимуть двійкові числа мінімальної довжини і навпаки, то можна показати, що середня кількість інформації на один символ початкового алфавіту англійської мови

(2.73)

Один двійковий символ може переносити не більш за один біт інформації, тому при якнайкращому способі кодування потрібні не менше 2,375 двійкових символів на один символ англійського алфавіту.

У загальному випадку кодування – це операція перекладу за певними правилами деякого формального об'єкта, вираженого сукупністю кодових символів одного алфавіту, в формальний об'єкт, виражений сукупністю кодових символів іншого алфавіту. При кодуванні як символи використовують букви алфавіту, цифри в певній системі числення і різні умовні знаки.

Зворотна операція називається декодуванням. У результаті кодування одержимо код, а при декодуванні – початкову інформацію

Числове кодування є відображенням формального об'єкта числами.

У КІСУ використовується кодове представлення результатів вимірювання технологічних параметрів для цифрової обробки і для передачі по каналах зв'язку. У процесі вимірювання визначається значення фізичної величини, що складається з її числового значення і одиниці вимірювання. Числове кодування у вимірюванні є операцією перекладу числового значення величини, що вимірюється, в ту або іншу систему числення.

2.7.2 Системи числення

Системою числення називається метод представлення кількісної інформації за допомогою символів деякого алфавіта, званих цифрами.

У непозиційній системі числення числове значення символа не залежить від його місця в числі. Прикладом непозиційної системи є одинична або унітарна, в якій цілі числа зображаються у вигляді сукупності одиниць, повторюваних відповідне число разів. Сигнали, що описуються одиничною системою, являють собою сукупність імпульсів, кількість яких пропорціональна величині, що вимірюється. Прикладами є сигнали від датчиків кількості розфасованої продукції, а також чутливих елементів лічильників витрати рідин і газів.

Для компактного представлення чисел використовуються позиційні системи числення, в яких використовуються декілька цифр, що мають певне числове значення або вагу, причому значення цифри залежить від положення цифри в числі.

У позиційній системі будь-яке число N виражається в наступній формі:

(2.74)

Символи ai (i=1…l) є цифрами даної системи числення, що стоять в i-тому розряді числа. Символ В означає основу системи і рівний числу символів або знаків в даній системі. Цифри в позиційній системі починаються з нуля, найбільше значення цифри рівно В-1. Символ l означає номер старшої позиції або кількістьі розрядів числа.

Найбільше число, яке може бути виражене в даній системі числення при кількості розрядів l:

Nн = Bl -1. (2.75)

Звідси необхідне число розрядів

l = logB(Nн+1). (2.76)

Збільшення основи системи числення дає більш компактне представлення числа, але вимагає більшої кількості цифр, що ускладнює системи передачі і обробки кодів.

За наявністю або відсутністю певної ваги у кожного символа коди діляться на зважені і незважені. У цифрових пристроях використовуються зважені коди, які поділяються за системою числення на одиничні, десяткові, двійкові, одинично-десяткові, двійково-десяткові (див. табл. 2.1).

Таблиця 2.1 - Представлення чисел у різних системах числення

N(10) | NO(1) | NБ(1) | N2 | N(2-10) | N(1-10)
0 |  | 00000000001 | 0000 | 00 0000 0000 | 001 00000000001 00000000001
1 | 1 | 00000000010 | 0001 | 00 0000 0001 | 001 00000000001 00000000010
2 | 11 | 00000000100 | 0010 | 00 0000 0010 | 001 00000000001 00000000100
3 | 111 | 00000001000 | 0011 | 00 0000 0011 | 001 00000000001 00000001000
4 | 1111 | 00000010000 | 0100 | 00 0000 0100 | 001 00000000001 00000010000
5 | 11111 | 00000100000 | 0101 | 00 0000 0101 | 001 00000000001 00000100000
6 | 111111 | 00001000000 | 0110 | 00 0000 0110 | 001 00000000001 00001000000
7 | 1111111 | 00010000000 | 0111 | 00 0000 0111 | 001 00000000001 00010000000
8 | 11111111 | 00100000000 | 1000 | 00 0000 1000 | 001 00000000001 00100000000
9 | 111111111 | 01000000000 | 1001 | 00 0000 1001 | 001 00000000001 01000000000
10 | 1111111111 | 10000000000 | 1010 | 00 0001 0000 | 001 00000000010 00000000001

Одиничний нормальний або одноканальний код [image] призначений для передачі інформації у вигляді набору імпульсів по одноканальній лінії зв'язку. Для представлення одиничного числа іншим кодом потрібен лічильник імпульсів.

Одиничний позиційний або багатоканальний код [image] використовує сукупність каналів передачі. Значення числа залежить від каналу, в якому присутній сигнал. Такі коди використовуються в статистичних аналізаторах, побудовувачах кривої розподілу, різноманітних матричних перетворювачах.

Недоліком одиничних кодів є незручність реєстрації та індикації.

Десятковий код N(10) застосовується для управління елементами відлікового пристрою і для цифрової реєстрації.

Двійковий код N(2) відрізняється простотою представлення в технічних пристроях, оскільки вимагає використання елементів з усього лише двома стійкими станами. Але числа, записані у двійковій системі, важкі для сприйняття людиною. Як компроміс використовується двійково-десяткова система N(2-10), в якій кожний десятковий розряд представлений чотирьохрозрядним двійковим числом.


ТЕОРЕТИЧНІ ОСНОВИ - Структура комп'ютерно-інтегрованої системи

2.8 Загальна структура комп'ютерно-інтегрованої системи

Загальна схема процесу перебігу інформації у комп'ютерно-інтегрованій системі показана на рис. 2.16.

Рис. 2.16 - Схема процесу перебігу інформації: 1 - генерація; 2 - сприйняття; 3 - перетворення; 4 - передача; 5 - приймання; 6 - оброблення; 7 - зберігання; 8 - подання; 9 - формування; 10 - передача; 11 - вплив

На об'єкт управління впливає зовнішнє середовище, у результаті чого об'єкт змінює свої властивості. Виявлення цих змін чи генерація інформації (1) є початком перебігу інформації в системі. Це виявлення треба сприйняти системою. При сприйнятті (2) формується повідомлення чи сигнал про зміну стану об'єкта. Під перетворенням (3) розуміють операції нормалізації, квантування, модуляції та інші, які роблять повідомлення більш завадостійким і зручним для передачі.

Передача (4) повідомлень полягає в перенесенні їх по каналу передачі на відстань за допомогою сигналів різної фізичної природи. На другому боці каналу відбувається приймання (5) повідомлень.

Одержані повідомлення обробляються (6) за певними алгоритмами у засобах керування. Проміжним станом обробки повідомлень може бути зберігання (7) його в пам'яті. Подання (8) інформації одержувачу може відбуватись, як безпосередньо після приймання, так і після операцій оброблення чи зберігання.

На підставі одержаних даних формується (9) керуючий сигнал, який передається (10) для впливу (11) на об'єкт управління.

Для реалізації цих операцій використовуються різні пристрої, прилади чи підсистеми. До них відносяться:

а) датчики - для генерації і сприйняття;

б) перетворювачі;

в) передавачі - для узгодження сигналів з лінією зв'язку;

г) приймачі - для приймання сигналів з лінії зв'язку;

д) пристрої оброблення інформації - регулятори, контролери та інщі керуючі обчислювальні пристрої;

е) запам'ятовуючі пристрої;

ж) пристрої відображення інформації для подання її одержувачу;

з) формувачі керуючих сигналів;

і) виконавчі пристрої для впливу на об'єкт.

На підставі вищевикладеного можна можна побудувати типову структуру комп'ютерно-інтегрованої системи (рис. 2.17).

Рис. 2.17 - Типова структура комп'ютерно-інтегрованої системи

Датчики Д сприймають зміни стану об'єкта управління і перетворюють їх в електричні сигнали, які надходять на вимірювачі В. Вимірювачі виконують операцію порівняння з мірою, квантування, кодування і т.п. Для зменшення кількості каналів передачі використовується комутатор К, який почергово під'єднує вимірювачі до перетворювача, що виконує операкцію узгодження сигналів між датчиками і каналом передачі КП. Можливий варіант, коли комутатор стоїть між датчиками та єдиним вимірювачем.

Канал передачі містить передавач ПРД, лінію зв'язку ЛЗ та приймач ПРМ. Повідомлення з каналу передачі надходять у пристрій обробки інформації, де обробляються за визначеним алгоритмом.. Одержані результати або запам'ятовуються у запам'ятовуючому пристрої ЗП, або подаються оператору через пристрій відображення інформації ПВІ, або на їх основі формується зворотний сигнал за допомогою формавача ФЗС.

Зворотний сигнал через канал передачі КП направляється для відпрацювання на об'єкт. Безпосередній вплив на стан об'єкта чинить виконуючий пристрій ВП. Перетворювач П буває необхідний для узгодження параметрів каналу передачі і виконуючого пристрою.

Всі складові структури комп'ютерно-інтегрованої системи можуть бути як аналоговими, так і цифровими. Чим більша доля цифрових приладів, пристрої і підсистем, тим вищий ступінь інтеграції системи.


ТЕОРЕТИЧНІ ОСНОВИ - Класіфікація і аналіз характеристик комп'ютерно-інтегрованих систем

2.9 Класіфікація і аналіз характеристик комп'ютерно-інтегрованих систем

Всі характеристики комп'ютерно-інтегрованої системи можна поділити на чотири класи (див. табл. 2.2).

Таблиця 2.2 - Класифікація характеристик комп'ютерно-інтегрованих систем

Найменування класу | Найменування характеристики
1 Функціональні | 1.1 Призначення
 | 1.2 Повнота можливостей
 | 1.3 Універсальність
2 Експлуатаційні | 2.1 Надійність
 | 2.2 Живучість
 | 2.3 Безпека
 | 2.4 Ергономічні характеристики
3 Економічні | 3.1 Вартість
 | 3.2 Окупність
 | 3.3 Рентабельність
4 Технічні | 4.1 Характеристики сигналів
 | 4.2 Завадостійкість
 | 4.3 Ефективність передачі інформації
 | 4.4 Швидкодія
 | 4.5 Енергопостачання
 | 4.6 Елементна база
 | 4.7 Умови, за яких система виконує свої функції

У призначенні системи вказуються:

а) тип об'єкта, яким має управляти система;

б) перелік режимів работи системи (автоматичний, ручний, контрольний тощо);

в) інтенсивність і склад інформаційних потоків;

г) характер роботи (неперервний, циклічний);

д) додаткові функції системи.

Під повнотою можливостей розуміється відношення обсягу автоматизації об'єктів, процесів, підсистем до загального обсягу об'єктів, процесів, підсистем.

Універсальність - це можливість використання однієї і тієї ж системи для управляння різними об'єктами при незначних доробках.

Надійність, живучість і безпека є системними властивостями. Для їх визначення застосовуються такі поняття, як справність, працездатність, відмова та ін., які характеризують стан системи.

Усі стани системи діляться на три множини (рис. 2.18):

SППС - множина повністю працездатних станів;

SЧПС - множина частково працездатних станів;

SНПС - множина непрацездатних станів.

Рис. 2.18 - Стани системи

Повність працездатний стан - такий стан системи, при якому ії основні параметри знаходяться в межах установлених нормативно-технічною документацією (НТД). При цьому другорядні параметри можуть бути або в межах норм, або ні.

У множині повністю працездатних станів виділяється підмножина SСС справних станів. Це такий стан системи, в якому як основні, так і другорядні параметри системи усім вимогам НТД, крім того, немає дефектів у резервній апаратурі.

Непрацездатний стан - стан, коли вимогам не відповідає хоча б один основний параметр, а другорядні параметри можуть бути або в межах норм, або ні.

У множині непрацездатних станів виділяється підмножина SАС аварійних станів,тобто таких, в яких система не може функціонувати, бо це може бути небезпечно для персоналу або навколишнього середовища.

Частково працездатний стан характеризується можливістю виконувати функції в деяких режимах (основних і допоміжних) При цьому деякі параметри відповідають вимогам НТД.

Технічний стан системи визначається сукупністю схильних до зміни параметрів. Межі зміни параметрів установлюються у НТД. Параметр може відповідати чи не відповідати вимогам НТД. Кожна така невідповідність являє собою дефект. Дефекти можуть бути наслідком природних процесів зношуваності та старіння, пошкодження, порушення правил і норм експлуатації, а також мають місце при розробці, виробництві і ремонті.

Параметри можуть бути основними і другорядними. Основні параметри визначають основні режими роботи системи, другорядні - роботу системи у допоміжних режимах.

Дамо визначення основним експлуатаційним характеристикам системи.

Надійність - властивість системи зберігати у часі та встановлених межах значення параметрів, які характеризують здатність виконувати потрібні функції в заданих режимах роботи та умовах експлуатації. Одним з важливих параметрів надійності є час напрацювання на відмову. Відмовою називається подія, яка полягає у втраті працездатності.

Живучість - властивість системи зберігати і автоматично відновлювати повністю або частково працездатний стан при виникненні відмов.

Безпека системи полягає в її здатності протистояти переходу у множину аварійних станів.

До ергономічних вимог відносяться

а) забезпечення фізіологічних зручностей для роботи обслуговуючого персоналу, тобто забезпечення взаємодії людини і апаратури у зручних і допустимих формі і темпі;

б) створення умов для психологічного комфорту персоналу, тобто доступність для розуміння інформації, наявність засобів навчання, тренування тощо.

Економічні характеристики розглядаються при вивченні дисципліни "Економіка".

З технічних характеристик дамо визначення наступним.

Завадостійкість - це здатність системи протистояти шкідливій дії завад, при якій прийнята інформація буде відрізнятись від переданої.

Швидкодія системи - це швидкість реакції системи на збурення, що діють на об'єкт управління. Її можна оцінювати часом від моменту виникнення збурення до моменту початку виконання керуючої дії.

Кожна з описаних характеристик не є ізольованою, всі вони взаємпов'язані. У реальних умовах їх треба аналізувати комплексно.


ТЕОРЕТИЧНІ ОСНОВИ - Ефективність комп’ютерно-інтегрованих систем

2.10 Ефективність комп’ютерно-інтегрованих систем

Існує багато визначень поняття ефективності технічних засобів і систем. Найбільш загальним може бути визначення ефективності як степеня пристосованості засобів чи систем до виконання поставлених перед ними задач. Стосовно до комп'ютерно-інтегрованих систем доцільно уточнити, що задачею є одержання інформації в необхідному обсязі при заданих витратах економічних, енергетичних чи інших ресурсів.

Для чисельної оцінки ефективності необхідний критерій ефективності (КЕ). Значення КЕ визначається процесом функціонування системи і може представлено у вигляді деякого функціонала

, (2.77)

де K – вектор параметрів, що визначають стан системи, V – вектор параметрів, що характеризують вплив зовнішнього середовища, X – вектор параметрів вимірюваних величин.

Ефективність комп'ютерно-інтегрованих систем має ряд складових, з них найбільш важливою є надійність. Надійність характеризує поводження технічного засобу в часі і є узагальненим поняттям, що включає в себе безвідмовність, довговічність, ремонтопридатність і зберігаємість.

Другою складовою ефективності є точність одержання інформації.

Крім того, на ефективність систем впливають помилки, допущені при їх проектуванні, якщо не враховуються реально існуюча неточність і неповнота апріорної інформації про фізико-хімічні властивості процесів, що мають місце об'єкті управління. У цьому випадку будемо говорити про надійність проектування.

Для обліку всіх аспектів ефективності системи необхідний узагальнюючий критерій, який можна отримати на основі системно-інформаційного аналізу ефективності керуючих систем. Уведемо наступні основні визначення.

Критерієм мети функціонування системи будемо називати кількісно визначену в просторі його станів область значень його величин, що характеризують, відповідному нормальному функціонуванню системи. Ціль буде вважатися досягнутої, якщо вектор параметрів критерію мети Х знаходиться в границях цієї області. Розташування границь може мати випадковий характер, наприклад, у випадку застосування інтервальних оцінок для параметрів критерію мети.

Для оцінки ступеня досягнення мети функціонування системи будемо застосовувати поняття невпорядкованості і неорганізованості.

Невпорядкованість функціонування [image] є чисельною мірою відмінності вектора Х стосовно еталона Хет, що наближається до нуля, якщо Х→Хэт. Невпорядкованість може бути співвіднесена до границі області досягнення мети ξ(Х)і в загальному випадку є функцією чотирьох аргументів: Х, Хэт, ξ(Х) і часу t. Неорганізованість будемо оцінювати формулою невизначенності Бонгарда (2.25).

У тому випадку, якщо критерій мети оцінюється інтервальною оцінкою, то існують тільки два варіанти: чи значення параметра мети накривається довірчим інтервалом Δ, чи ні. Причому імовірність першої ситуації оцінюється як β (довірча імовірність), імовірність другої – як (1-β). У цьому випадку

(2.78)

де α – апріорна (до одержання інтервальної оцінки) довірча імовірність; β – апостеріорна довірча імовірність. Для апріорної довірчої імовірності може бути обране значення, що звичайно застосовується в технічних розрахунках: α = 0,95.

Як уже було сказано вище, надійність є однієї зі складових ефективності системи. Міра неорганізованості дозволяє досить просто оцінювати вплив різних складових ефективності. Проілюструємо це прикладом урахування технічної надійності і надійності проектування. Нехай функція перетворення системи має вигляд [image] , де y – результат виміру, x – вимірювана величина, K – деякий невизначений параметр. Значення величини y знаходиться в довірчому інтервалі D y з імовірністю βy. Розглянемо дві події. Подія А полягає в тому, що довірчий інтервал не накриває значення величини y внаслідок наявності невизначеності K. Імовірність події P(A) = 1– βy . Подія В полягає в тому, що значення величини y не попадає в довірчий інтервал унаслідок технічної відмови системи. Імовірність такої події дорівнює імовірності відмови Pо. Розглянемо також третю результуючу подію R, що складається в тім, що y не знаходиться в довірчому інтервалі з кожної з причин, чи то внаслідок події А, чи то внаслідок події В. Подія R є диз'юнкція подій А та В. Відповідно ймовірність події R:

P(R) = P(AV B) = P(A) + P(B) + P(A)·P(B). (2.79)

При цьому довірча імовірність для довірчого інтервалу D y з урахуванням впливу обох факторів буде

β = 1 – P(R) = βy + βy ·Pо. (2.80)

Обчислене за допомогою (2.78) і (2.80) значення неорганізованості буде враховувати вплив характеристик технічної надійності і надійності проектування. Приведені викладення можна розширити і для інших складових ефективності комп'ютерно-інтегрованих систем.

Завдяки адитивным властивостям інформації загальний інформаційний критерій ефективності (з урахуванням усіх факторів, що впливають на ефективність) може бути отриманий як сума окремих складових, відповідних статистично незалежним джерелам неорганізованості, таким як неточність інформації, відмови технічних і програмних засобів, неточність і неповнота знань проектантів.

Методика розрахунку значень загального інформаційного критерію ефективності полягає в наступному.

Будемо використовувати топологічну модель системи у виді графа аналізу ефективності (ГАЕ), що відображає ієрархію цілей функціонування системи. Цілі функціонування зображуються вершинам графа, зв'язки між цілями - дугами. На верхньому рівні розташовується вершина, що відповідає глобальній меті функціонування системи, на більш низькому рівні - вершини підцілей, виконання яких є необхідним для виконання вищестоящої цілі і т.д. до найнижчіх "незалежних" вершин.

Рис. 2.17 - Приклад ГАЕ

Кожній вершині ГАЕ ставиться у відповідність значення неорганізованості функціонування [image] у відношенні даної мети. Крім таких основних вершин уводяться також додаткові вершини, що відповідають тим чи іншим джерелам неорганізованості. Далі розв’язується система рівнянь вершин графа

(2.81)

де індекс j відповідає подцелям i-тої мети функціонування, [image] – коефіцієнт передачі дуги, що зв'язує j -у вершину з i-тою. У найпростішому випадку коефіцієнти передачі дуг приймаються рівними одиниці.

У матричному виді система рівнянь вершин ГАЕ представляється в такий спосіб:

(2.82)

Тут [image] – квадратна матриця розмірності n´n, де – число «залежних» вершин ГАЕ, тобто вершин, що мають вхідні дуги. Елементи матриці [image] розраховуються в такий спосіб:

aij = – Kij при i¹j;

aij = – Kij + 1 при i=j,

де i – номер рядка, j – номер стовпця.

– стовпець розмірності n, елементи його визначаються виразами вигляду

(2.83)

де N – загальне число вершин графа; m – число основних вершин («залежних» і «незалежних» разом); m–n – число «незалежних» вершин, що не мають вхідних дуг; N–m – число додаткових вершин. .

Значення неорганізованості для «незалежних» вершин вважаються відомими і не залежними від функціонування даної системи. У найпростішому випадку їх можна вважати рівними нулю. Якщо ж треба враховувати зовнішні фактори, то повинні бути визначені значення неорганізованості відповідних «незалежних» вершин.

Неорганізованість додаткових вершин може бути розрахована, наприклад, за значеннями ймовірностей відмов за допомогою виразів типу (2.80).


3 Комп'ютерно-інтегроване управління в сучасних АСУ

3 Побудова ієрархічно-розподілених АСУ

3.1 Загальні відомості

Сучасні АСУ мають багаторівневу ієрархічну структуру. В залежності від задач, розв'язуваних системами керування, виділяються три рівні.

Перший рівень – оперативне управління процесом випуску продукції. Це може бути управління дільницею, робочим місцем, технологічним устаткуванням. Другий рівень – технічне або адміністративне управління на основі застосування методів моделювання. Це може бути управління цехом. На третьому рівні реалізується стратегічне управління, що є функцією вищого управлінського персоналу.

Кожен з рівнів може складатись з кількох підрівнів. Технічне оснащення рівнів та підрівнів, як правило, розподілене у просторі. Передача даних від одних технічних пристроїв до інших здійснюється через системи зв’язку, які мають різні назви: шини, мережі, інтерфейси. Всі ці назви часто вживаються як рівноправні, хоча кожна має свою специфіку. Так шиною (bus) називається середовище передачі сигналів, до якого може паралельно під’єднуватись декілька компонентів обчислювальної системи і через яку здійснюється обмін даними. Мережа (network) – система, створена терміналами (кінцевими пристроями), вузлами та лініями зв’язку. мережа являє собою множину ресурсів, що використовуються для встановлення зв’язку і комутації ліній між її вузлами і терміналами. Інтерфейсом називається сукупність технічних і програмних засобів, що забезпечують обмін інформацією між окремими технічними пристроями, а також між технічними пристроями і оперативним персоналом.

Розглянемо типову структурну схему сучасного виробництва (рис. 3.1).

Рис. 3.1 – Структура технічних засобів управління сучасним підприємством

Нижній рівень цієї схеми складають вимірювальні прилади і виконавчі механізми, що розміщуються на об’єкті управління і мають назву польових приладів. На сьогоднішній день, вони можуть бути аналоговими чи цифровими (інтелектуальними). Аналогові представляють вимірювану величину у вигляді рівня напруги чи струму. Цифрові ж мають убудовані логічні схеми і представляють вимірювану величину у вигляді цифрового сигналу. Для обміну інформацією з приладами першого типу, необхідно використовувати АЦП/ЦАП (Аналогово-цифрові/Цифро-аналогові перетворювачі). З приладами другого типу можна обмінюватися інформацією безпосередньо по мережі передачі даних, яка носить назву “польова мережа”.

Наступний рівень схеми – контролери. Вони виконують функцію автоматичного керування технологічним процесом. Їх задачею є видача сигналів на виконавчі механізми в результаті обробки даних про стан технологічних параметрів за визначеними алгоритмами.

Сервери технологічних даних забезпечують зберігання технологічної інформації та обмін інформацією між технологічними пристроями і мережею АСУ ТП. Вони підтримують протокол роботи з технологічними пристроями і протокол роботи з мережею АСУ ТП. Дані про поточні параметри технологічного процесу можуть бути використані:

а) для контролю стану технологічного процесу і керування ним з автоматизованих робочих місць операторів (АРМ);

б) для архівації історії зміни технологічних параметрів;

в) для формування сумарних звітних форм з метою надання інформації керівному персоналу.

На рівні управління цехом цехова мережа зв’язує між собою АРМи складів, лабораторій, диспетчера і начальника цеху. Інформація до цих АРМів надходить знизу з мережі АСУ ТП або зверху з мережі підприємства, що має назву корпоративної мережі. Ця мережа охоплює АРМи всіх служб підприємства.

На рівні управління підприємством використовується інформація як з нижчих рівнів управління, так і з баз даних, розміщених на сервері баз даних підприємства.

3.2 Вступ у технологію розподілених інформаційних мереж

3.2.1 Визначення розподіленої інформаційної системи

За особливостями територіального розміщення й організації взаємодії частин інформаційної системи розрізняють такі типи систем: зосереджені та розподілені.

Увесь комплекс устаткування зосереджених інформаційних систем розміщений в одному місці, а зв'язок між окремими пристроями забезпечується стандартними інтерфейсами без використання каналів зв'язку.

Загальна тенденція удосконалення автоматизованих систем управління — це децентралізація структури АСУ, яка ґрунтується на розподільній (децентралізованій) обробці інформації. Розподілені інформаційні системи (РІС) являють собою територіально розосереджені системи, що складаються із взаємодіючих між собою обчислювальних пристроїв і терміналів, зв`язаних між собою каналами передачі даних. Це дає змогу наблизити відповідне устаткування до місць виникнення і використання інформації, розподілити його за окремими функціональними сферами діяльності.

Принципово можливі чотири підходи до організації технології обробки даних в АСУ: централізоване зберігання й обробка інформації за умови централізованого управління економіко-виробничими об'єктами (традиційні АСУ); централізоване зберігання й обробка інформації за умови децентралізованих або незалежних систем управління (наприклад, обчислювальних центрів колективного використання); розподільне зберігання та обробка інформації при централізованому управлінні; розподільне зберігання й обробка інформації при децентралізованому управлінні.

Структурно розподілена обробка інформації реалізується у вигляді мереж обчислювальних машин.

3.2.2 Технології оброблення інформації в розподілених системах

Для оброблення інформації в розподілених системах використовують три основні технології:

а) “хазяїн-слуга” (master-slave);

б) “клієнт-сервер”;

в) рівнорангову (peer-to-peer).

У технології “хазяїн-слуга” головний процес оброблення інформації (“master”) ініціює і керує будь-яким діалогом з іншими підлеглими інформаційними процесами (“slave”). Підлеглі процеси відповідають на команди центрального процесу тільки на його запит. Процес “master” реалізується центральним комп`ютером, до якого через канали зв`язку під'єднуються периферійні пристрої, які реалізують процеси типу “slave”.

За технологією “клієнт-сервер” процес-клієнт виступає замовником деякого обслуговування. Це обслуговування забезпечує один чи кілька процесів, званих серверами. після закінчення обслуговування вони посилають відповідь клієнту. Такий режим називають режимом “запит-відповідь”. На відміну від технології “хазяїн-слуга” процеси клієнта і сервера рівноправні, але виконують різні функції.

У невеликих мережах кожен обчислювальний пристрій може бути конфігурований і як клієнт, і як сервер одночасно. Такий частковий випадок технології “клієнт-сервер” називають рівноранговою технологією. В рівнорангових мережах всі абоненти рівноправні і можуть виконувати однакові функції. Такі системі дешевші, але мають більш низьку продуктивність, яка різко падає зі збільшенням числа абонентів у мережі.

3.2.3 Еталонна модель взаємодії відкритих систем

Обмін інформацією потребує принаймі двох партнерів, що розуміють один одного. Такий обмін може відбутися тільки в тому разі, якщо партнери дотримуються деяких правил. З метою створення єдиної концепції обміну даними Міжнародна організація зі стандартизації ISO розробила еталонну модель взаємозв`язку відкритих систем OSI (Open Systems Syntrconnection), що має сім ієрархічних рівнів (рис. 3.2).

Рис. 3.2 – Структура еталонної моделі OSI

Набір правил організації взаємодії між сусідніми рівнями в цій моделі називається інтерфейсом, а правила взаємодії між однаковими рівнями в різних системах, що обмінюються інформацією, називаються протоколами.

Фізичний рівень стосується передавання бітів інформації по фізичних каналах зв'язку, таких, як, наприклад, телефонний чи радіоканал. На цьому рівні визначаються характеристики сигналів, типи конекторів і призначення кожного контакту конектора. Фізичний рівень забезпечує встановлення, підтримання і розрив фізичного з`єднання між двома комп`ютерними системами.

Канальний рівень керує передаванням даних по каналу зв'язку. Якщо на фізичному рівні просто передаються біти, то на канальному виконуються функції перевірки доступності передавального середовища, виявлення та коректування помилок. Для цього дані розбиваються на порції, звані кадрами (frames). Канальний рівень забезпечує коректність передавання кожного кадру, розміщуючи спеціальну послідовність бітів у початок і кінець кожного кадру для його відокремлення, обчислює контрольну суму і вставляє її в кадр. Контрольна сума – це сума всіх бітів або байтів даних кадру. Коли кадр отримує приймач інформації, він також обчислює контрольну суму та порівнює її з переданою контрольною сумою. Якщо вони не збігаються, фіксується помилка. Канальний рівень може виправляти помилки, повторюючи передавання ушкоджених кадрів.

Мережевий рівень забезпечує встановлення і підтримку зв'язку між двома конкретними абонентами у багатовузловій мережі. Також здійснюється маршрутизація даних. Щоб передати повідомлення від відправника до одержувача, потрібно пройти кілька транзитних вузлів, щоразу вибираючи оптимальний маршрут. Дані, що передаються на мережевому рівні, також поділяються на порції, звані пакетами, причому кожний пакет може передаватись по своєму маршруту.

На шляху від відправника до одержувача пакети можуть бути спотворені або загублені, іноді можуть з`являтись їх дублікати. Для керування потоком даних, запобігання втрати чи переповнення даних застосовується транспортний рівень.

Протоколи фізичного, канального, мережевого та транспортного рівнів зорієнтовані на передачу даних і називаються протоколами нижніх рівнів на відміну від протоколів трьох верхніх рівнів, які забезпечують зв`язок з прикладними задачами контролю чи керування.

Сеансовий рівень забезпечує встановлення, підтримання і закінчення сеансу зв`язку, а також поновлення перерваного сеансу через аварію.

Рівень подання даних визначає форму подання даних таким чином, щоб дані, передані прикладним рівнем одного абонента мережі були зрозумілими прикладному рівню іншого абонента. Крім того, на цьому рівні виконується шифрування та розшифрування даних, їх ущільнення для збільшення швидкості передачі і відповідна розпаковка на приймальній стороні.

Прикладний рівень забезпечує послуги для прикладних задач. У випадку АСК ТП це задачі контролю та керування. У корпоративних мережах та Інтернеті прикладними задачами є обмін файлами, електрона пошта і т.п. Прикладний рівень визначає доступність прикладних задач до зв`язку, синхронізує взаємодіючі прикладні задачі, загальне керування мережею. Одиницю даних, з якою керує прикладний рівень, називають повідомленням (message).

Отже, кожен рівень має взаємодіяти з аналогічним рівнем іншого абонента мережі і обслуговувати більш високий рівень свого абонента. Для того, щоб однакові рівні різних абонентів могли правильно взаємодіяти, перед даними додається керувальна інформація, звана заголовком, а в кінці даних – службова інформація, звана кінцевиком. Кожен рівень передавача додає свій заголовок і свій кінцевик. Коли повідомлення надходить до адресата, воно приймається його фізичним рівнем і переміщується вгору з рівня на рівень. Кожен рівень аналізує свої заголовок та кінцевик, виконує свої функції і, після видалення цих заголовка і кінцевика, передає дані на більш високий рівень.

3.3 Основні компоненти розподілених інформаційних систем

3.3.1 Устаткування розподілених інформаційних систем

Росподілені інформаційні системи містять такі основні компоненти:

а) кінцеве устаткування даних DTE (Data Terminal Equipment);

б) устаткування закінчення каналу даних DCE (Data Circuit-terminal Equipment);

в) устаткування комутації та маршрутизації даних DSE(Data Switchin Equipment);

г) передавальне середовище.

Кінцеве устаткування даних DTE – це узагальнене поняття, використовуване для опису системи кінцевого користувача. Таким може бути комп'ютер, контролер, робоча станція або будь-який пристрій введення-виведення інформації.

Основна функція DCE полягає в тому, щоб забезпечити доступ кінцевого устаткування до передавального середовища. Прикладом DCE є модем, що виконує перетворення цифрової інформації в аналогову форму для передачі по телефонних каналах.

Основна функція DSE – передавання даних, комутація та маршрутизація у мережі від джерела до одержувача. Прикладом такого устаткування є концентратор (рис. 3.3, а), що має n входів та один вихід. На входи надходять дані з декількох джерел, а на виході є канал, у який передається сумарний потік даних. Другий приклад – комутатор (рис. 3.3, б), що має n входів та m виходів і переспрямовує вхідні потоки даних по різних каналах залежно від адресата.

Рис. 3.3

DTE разом з DCE утворюють вузли мережі, а передавальне середовище разом з DSE називають мережею передавання даних.

3.3.2 Типи і характеристики передавальних середовищ

Основні типи передавальних середовищ, використовуваних в інформаційних мережах:

а) аналогові телефонні канали загального користування;

б) цифрові телефонні канали;

в) дротові кабельні канали;

г) наземні радіоканали і супутникові канали зв'язку;

д) волоконно-оптичні канали зв'язку.

Основні характеристики каналів зв'язку:

а) ширина смуги пропущення – різниця частот верхньої f2 і нижньої f1 границь смуги пропущення:

W = f2 – f1;

б) відношення сигнал-шум S/N у децибелах, де S – середня потужність сигналу, N – середня потужність шуму;

в) максимальна швидкість згідно формули Шеннона:

C = W log2(1+S/N);

г) середня ймовірність помилки.

Найбільше поширення в інформаційних мережах АСК ТП знайшли кабелі, які можна розділити на три великі групи:

  • кабелі на основі витих пар проводів (twisted pair), які діляться на екрановані (shielded twisted pair, STP) і неекрановані (unshielded twisted pair, UTP);
  • коаксіальні кабелі (coaxial cable);
  • оптоволоконные кабелі (fiber optic).

    • Кожен тип кабелю має свої переваги і недоліки, так що при виборі типу кабелю треба враховувати як особливості вирішуваної задачі, так і особливості конкретної мережі, у тому числі і використовувану топологію. В даний час діє стандарт на кабелі EIA/TIA 568 (Commercial Building Telecommunications Cabling Standard), що прийнятий в 1995 році і замінив всі фірмові стандарти, що діяли раніше.

    Виті пари проводів використовуються в найдешевших і на сьогоднішній день, мабуть, найпопулярніших кабелях. Кабель на основі витих пар є декількома парами скручених ізольованих мідних проводів в єдиній діелектричній (пластиковою) оболонці. Він досить гнучкий і зручний для прокладки.

    Зазвичай в кабель входить дві виті пари (рис. 3.4) або чотири виті пари.

    Рис. 3.4 - Кабель з витими парами

    Неекрановані виті пари характеризуються слабкою захищеністю від зовнішніх електромагнітних завад, а також слабкою захищеністю від підслуховування з метою, наприклад, промислового шпигунства. Перехоплення передаваної інформації можливе як за допомогою контактного методу (за допомогою двох голочок, увіткнених в кабель), так і за допомогою безконтактного методу, що зводиться до радіоперехоплення випромінюваних кабелем електромагнітних полів. Для усунення цих недоліків застосовується екранування.

    Зазвичай провід у витій парі має діаметр 0,6 мм, загасання 40 дБ/км на частоті 10 МГц та опір 100 Ом на частоті 1 Мгц.

    У разі екранованої витої пари STP кожна з витих пар поміщюється в металеву оплетку-екран для зменшення випромінювань кабелю, захисту від зовнішніх електромагнітних перешкод і зниження взаємного впливу пар проводів один на одного (crosstalk - перехресні наведення). Природно, екранована вита пара набагато дорожча, ніж неекранована, а при її використанні необхідно застосовувати і спеціальні екрановані конектори, тому зустрічається вона значно рідше, ніж неекранована вита пара.

    Основні достоїнства неекранованих витих пар - простота монтажу конекторів на кінцях кабелю, а також простота ремонту будь-яких пошкоджень в порівнянні з іншими типами кабелю. Решта всіх характеристик у них гірша, ніж у інших кабелів. Наприклад, при заданій швидкості передачі загасання сигналу (зменшення його рівня у міру проходження по кабелю) у них більше, ніж у коаксіальних кабелів. Якщо врахувати ще низьку перешкодозахисну, то стає зрозумілим, чому лінії зв'язку на основі витих пар, як правило, досить короткі (зазвичай в межах 100 метрів). В даний час вита пара використовується для передачі інформації на швидкостях до 100 Мбит/с і ведуться роботи по підвищенню швидкості передачі до 1000 Мбит/с.

    Коаксіальний кабель складається з центрального дроту і металевої оплетки, розділених між собою шаром діелектрика (внутрішній ізоляції) і поміщених в загальну зовнішню оболонку (рис. 3.5).

    Рис. 3.5 - Коаксіальний кабель

    Коаксіальний кабель до недавнього часу був поширений найширше, що пов'язане з його високою завадозахищеністю (завдяки металевій оплетці), а також вищими, ніж у разі витої пари, допустимими швидкостями передачі даних (до 500 Мбит/с) і великими допустимими відстанями передачі (до кілометра і вище). До нього важче механічно підключитися для несанкціонованого прослуховування мережі, він також дає помітно менше електромагнітних випромінювань зовні. Проте монтаж і ремонт коаксіального кабелю істотно складніші, ніж витої пари, а вартість його вища (він дорожче приблизно в 1,5-3 рази в порівнянні з кабелем на основі витих пар). Складніше і установка конекторів на кінцях кабелю. Тому його зараз застосовують рідше, ніж виту пару.

    Основне застосування коаксіальний кабель знаходить в мережах з топологією типу "шина". Рідше коаксіальні кабелі застосовуються в мережах з топологією "зірка".

    Існує два основні типи коаксіального кабелю:

  • тонкий (thin) кабель, що має діаметр близько 0,5 см, гнучкіший;
  • товстий (thick) кабель, що має діаметр близько 1 см, значно жорсткіший. Він є класичним варіантом коаксіального кабелю, який вже майже повністю витиснений сучаснішим тонким кабелем.

    • Тонкий кабель використовується для передачі на менші відстані, чим товстий, оскільки в нім сигнал затухає сильніше. Зате з тонким кабелем набагато зручніше працювати: його можна оперативно прокласти до кожного комп'ютера, а товстий вимагає жорсткої фіксації на стіні приміщення. Підключення до тонкого кабелю (за допомогою конекторів BNC байонетного типу) простіше і не вимагає додаткового устаткування, а для підключення до товстого кабелю треба використовувати спеціальні досить дорогі пристрої, оболонки, що проколюють його, і що встановлюють контакт як з центральною жилою, так і з екраном. Товстий кабель приблизно удвічі дорожче, ніж тонкий. Тому тонкий кабель застосовується набагато частіше.

    В даний час вважається, що коаксіальний кабель застарілий, в більшості випадків його цілком може замінити вита пара або оптоволоконний кабель. Нові стандарти на кабельні системи вже не включають його в перелік типів кабелів.

    Оптоволоконний (він же волоконно-оптичний) кабель - це принципово інший тип кабелю в порівнянні з розглянутими двома типами електричного або мідного кабелю. Інформація по ньому передається не електричним сигналом, а світловим. Головний його елемент - це прозоре скловолокно, по якому світло проходить на величезні відстані (до десятків кілометрів) з незначним ослабленням.

    Структура оптоволоконного кабелю дуже проста і схожа на структуру коаксіального електричного кабелю (рис. 3.6), тільки замість центрального мідного дроту тут використовується тонке (діаметром близько 1-10 мкм) скловолокно, а замість внутрішньої ізоляції - скляна або пластикова оболонка, що не дозволяє світлу виходити за межі скловолокна. В даному випадку ми маємо справу з режимом так званого повного внутрішнього віддзеркалення світла від межі двох речовин з різними коефіцієнтами заломлення (у скляної оболонки коефіцієнт заломлення значно нижчий, ніж у центрального волокна). Металева оплетка кабелю зазвичай відсутня, оскільки екранування від зовнішніх електромагнітних перешкод тут не потрібне, проте іноді її все-таки застосовують для механічного захисту від навколишнього середовища (такий кабель іноді називають броньовим, він може об'єднувати під однією оболонкою декілька оптоволоконних кабелів).

    Рис. 3.6 - Структура оптоволоконного кабелю

    Оптоволоконний кабель володіє винятковими характеристиками по завадозахищеності і секретності передаваної інформації. Ніякі зовнішні електромагнітні перешкоди в принципі не здатні спотворити світловий сигнал, а сам цей сигнал принципово не породжує зовнішніх електромагнітних випромінювань. Підключитися до цього типу кабелю для несанкціонованого прослуховування мережі практично неможливо, оскільки це вимагає порушення цілісності кабелю. Теоретично можлива смуга пропускання такого кабелю досягає величини 1012 Гц, що незрівнянно вище, ніж у будь-яких електричних кабелів. Вартість оптоволоконного кабелю постійно знижується і зараз приблизно є рівною вартості тонкого коаксіального кабелю. Проте в даному випадку необхідне застосування спеціальних оптичних приймачів і передавачів, що перетворюють світлові сигнали в електричні і навпаки, що деколи істотно збільшує вартість мережі в цілому.

    Застосовують оптоволоконный кабель тільки в мережах з топологією "зірка" і "кільце".

    В майбутньому цей тип кабелю, ймовірно, витіснить електричні кабелі всіх типів або, в усякому разі, сильно потіснить їх. Запаси міді на планеті виснажуються, а сировини для виробництва скла більш ніж достатньо.

    Проте оптоволоконный кабель має і деякі недоліки.

    Найголовніший з них - висока складність монтажу (при установці конекторів необхідна мікронна точність, від точності скола скловолокна і ступеня його поліровки сильно залежить загасання в конекторі). Для установки конекторів застосовують зварку або склеювання за допомогою спеціального гелю, що має такий же коефіцієнт заломлення світла, що і скловолокно. У будь-якому випадку для цього потрібна висока кваліфікація персоналу і спеціальні інструменти. Тому найчастіше оптоволоконний кабель продається у вигляді наперед нарізаних шматків різної довжини, на обох кінцях яких вже встановлені конектори потрібного типу.

    Хоча оптоволоконные кабелі і допускають розгалуження сигналів (для цього випускаються спеціальні розгалужувачі на 2-8 каналів), як правило, їх використовують для передачі даних тільки в одному напрямі, між одним передавачем і одним приймачем. Адже будь-яке розгалуження неминуче сильно ослабляє світловий сигнал, і якщо розгалужень буде багато, то світло може просто не дійти до кінця мережі.

    Оптоволоконний кабель менш міцний, чим електричний, і менш гнучкий (типова величина допустимого радіусу вигину складає близько 10-20 см). Чутливий він і до іонізуючих випромінювань, із-за яких знижується прозорість скловолокна, тобто збільшується загасання сигналу. Чутливий він також до різких перепадів температури, в результаті яких скловолокно може тріснути.

    Оптоволоконні кабелі чутливі також до механічних дій (удари, ультразвук) - так званий мікрофонний ефект. Для його зменшення використовують м'які звукопоглинальні оболонки.

    Існують два різні типи оптоволоконних кабелів:

  • багатомодовий, або мультимодовый, кабель, дешевший, але менш якісніший;
  • одномодовий кабель більш дорогий, але має кращі характеристики.

    • Основні відмінності між цими типами пов'язані з різним режимам проходження світлових променів в кабелі.

    У одномодовому кабелі практично всі промені проходять один і той же шлях, внаслідок чого всі вони досягають приймача одночасно, і форма сигналу практично не спотворюється. Одномодовий кабель має діаметр центрального волокна близько 1,3 мкм і передає світло тільки з такою ж довжиною хвилі (1,3 мкм). Дисперсія і втрати сигналу при цьому дуже незначні, що дозволяє передавати сигнали на значно більшу відстань, чим у разі застосування багатомодового кабелю. Для одномодового кабелю застосовуються лазерні приймачі-передавачі, що використовують світло виключно з необхідною довжиною хвилі. Такі приймачі-передавачі поки що порівняно дорогі і не дуже довговічні. Проте в перспективі одномодовий кабель повинен стати основним завдяки своїм прекрасним характеристикам.

    У багатомодовому кабелі траєкторії світлових променів мають помітний розкид, внаслідок чого форма сигналу на приймальному кінці кабелю спотворюється. Центральне волокно має діаметр 62,5 мкм, а діаметр зовнішньої оболонки - 125 мкм (це іноді позначається як 62,5/125). Для передачі використовується звичайний (не лазерний) світлодіод, що знижує вартість і збільшує термін служби приймачів-передавачів в порівнянні з одномодовим кабелем. Довжина хвилі світла в багатомодовому кабелі рівна 0,85 мкм. Допустима довжина кабелю досягає 2-5 км. В даний час багатомодовий кабель - основний тип оптоволоконного кабелю, оскільки він дешевший і доступніший.

    Волоконно-оптичні канали, незважаючи на їх підвищену вартість порівняно з іншими видами зв`язку, набувають дедалі більшого поширення завдяки високій якості зв`язку.

    Окрім кабельних, в комп'ютерних мережах іноді використовуються також безкабельні канали.

    Радіоканал використовує передачу інформації по радіохвилях, тому може забезпечити зв'язок на сотні і навіть тисячі кілометрів. Швидкість передачі може досягати десятків мегабіт в секунду (тут багато що залежить від вибраної довжини хвилі і способу кодування). Проте в локальних мережах радіоканал не набув широкого поширення із-за досить високої вартості передавальних і приймальних пристроїв, низької перешкодозахисної, повної відсутності секретності передаваної інформації і низької надійності зв'язку. А ось для глобальних мереж радіоканал часто є єдино можливим рішенням, оскільки дозволяє за допомогою супутників-ретрансляторів порівняно просто забезпечити зв'язок зі всім світом. Використовують радіоканал і для зв'язку двох локальних мереж, що знаходяться далеко одна від одної, в єдину мережу.

    Існує декілька стандартних типів радіопередачі інформації. Зупинимося на двох з них.

  • Передача у вузькому спектрі (або одночастотна передача) розрахована на обхват площі до 46 500 м2. Радіосигнал в даному випадку не проникає через металеві і залізобетонні перешкоди, тому навіть в межах однієї будівлі можуть бути серйозні проблеми із зв'язком. Зв'язок в даному випадку відносно повільний (близько 4,8 Мбіт/с).
  • Передача в розсіяному спектрі для подолання недоліків одночастотної передачі припускає використання деякої смуги частот, розділеної на канали. Всі абоненти мережі через певний часовий інтервал синхронно переходять на наступний канал. Для підвищення секретності використовується спеціальне кодування інформації. Швидкість передачі при цьому невисока - не більше 2 Мбіт/с, відстань між абонентами - не більше 3,2 км на відкритому просторі і не більше 120 м усередині будівлі.

    • Окрім вказаних типів, існують і інші радіоканали, наприклад стільникові мережі, що будуються за тими ж принципами, що і стільникові телефонні мережі (вони використовують рівномірно розподілені за площею ретранслятори), а також мікрохвильові мережі, що застосовують вузьконаправлену передачу між наземними об'єктами або між супутником і наземною станцією.

    Інфрачервоний канал також не вимагає сполучних проводів, оскільки використовує для зв'язку інфрачервоне випромінювання. Головна його перевага в порівнянні з радіоканалом - нечутливість до електромагнітних перешкод, що дозволяє застосовувати його, наприклад, у виробничих умовах. Правда, в даному випадку потрібна досить висока потужність передачі, щоб не впливали ніякі інші джерела теплового (інфрачервоного) випромінювання. Погано працює інфрачервоний зв'язок і в умовах сильної запиленості повітря.

    Граничні швидкості передачі інформації по інфрачервоному каналу не перевищують 5-10 Мбіт/с. Секретність передаваної інформації, як і для радіоканалу, також не досягається. Як і у разі радіоканалу потрібні порівняно дорогі приймачі і передавачі. Все це призводить до того, що застосовують інфрачервоні канали досить рідко.

    Інфрачервоні канали діляться на дві групи:

  • Канали прямої видимості, в яких зв'язок здійснюється на променях, що йдуть безпосередньо від передавача до приймача. При цьому зв'язок можливий тільки за відсутності перепон між комп'ютерами мережі. Протяжність каналу прямої видимості може досягати декількох кілометрів.
  • Канали на розсіяному випромінюванні, які працюють на сигналах, відбитих від стін, стелі, підлоги і інших перепон. Перепони в даному випадку не страшні, але зв'язок може здійснюватися тільки в межах одного приміщення.

    • Супутникові канали зв'язку є оптимальним, а іноді і єдиним засобом для вирішення багатьох завдань.

    Всі сучасні мережі супутникового зв'язку із значним об'ємом трафіку реалізуються на сучасних геостаціонарних супутниках, розташованих в різних екваторіальних позиціях. Щоб уникнути інтерференції вони розташовуються на відстані в 2о один від одного (всього 180 місць). Для впорядкування процесу були прийняті ряд міжнародних угод з питання використання ділянок орбіт і частотних діапазонів. При цьому використовуються також малі наземні станції типа VSAT (Very Small Aperture Terminal) без системи наведення антени на супутник.

    Відмітними особливостями мереж на основі супутникових каналів зв'язку є великий час проходження сигналу в каналі (250-300 мс проти 3 мкс/км в оптоволоконне), ефект Доплера, що виявляється із-за руху супутника по орбіті, і висока якість каналу. Вони знаходяться поза конкуренцією у важкопрохідній місцевості і там, де необхідне широкомовлення.

    Можливе створення різних конфігурацій супутникових мереж і застосування різних протоколів інформаційних потоків.

    Новий виток у використанні супутників наступив з реалізації проекту створення мережі низькоорбітальних супутників типа Iridium. Суть цього і йому подібних проектів полягає в спробі покрити поверхню землі множиною осередків від точкових променів низькоорбітальних супутників (у проекті Iridium 66 супутників повинні в сукупності забезпечити 1628 осередків), що дозволить надати універсальні послуги в будь-якій точці земної кулі.

    3.3.3 Методи передачі даних на фізичному рівні

    Коли ми хочемо передати дані, використовуючи аналогові телефонні лінії, ми повинні конвертувати електричні сигнали, витікаючі від DTE, у форму прийнятну для суспільних телефонних мереж. Оскільки спочатку телефонні мережі призначалися тільки для мовних комунікацій і їх смуга пропускання була встановлена від 400 до 3400 Гц

    Внаслідок цього по телефонних лініях неможливо передавати ступінчасті сигнали 0 і 1. Необхідно перетворити початковий сигнал на сигнал з допустимого діапазону. Така операція називається модуляцією. Операція відновлення початкового сигналу з модульованого називається демодуляцією. Пристрій, який виконує операцію модуляції і демодуляції на обох сторонах каналу, називається модем. Існує декілька основних типів модуляції, а також їх комбінації.

    3.3.3.1 Амплітудна модуляція (Amplitude-shift-keying, ASK)
    При амплітудній модуляції сигнал однієї частоти (аудіо) перемикається між двома рівнями з швидкістю, визначуваною швидкістю сигналу передачі сигналу. Несуча частота вибирається в межах смуги частот телефонної мережі. Ширина використовуваної смуги визначається швидкістю передачі даних: чим вище швидкість, тим ширше смуга.

    Математично операція модуляції еквівалентна множенню сигналу несучої частоти на сигнал даних. Сигнал несе представлений однією частотою, тобто

    ,

    де wc -несуча частота в радіанах в секунду.

    3.3.3.2 Частотна модуляція (Frequency-shift-keying, FSK)

    Частотна модуляція використовується у всіх низькошвидкісних модемах. Для розрізнення двох рівнів амплітуд сигналу в FSK використовують два несучі сигнали з фіксованою амплітудою, один - для 0, інший - для 1. Різниця між двома частотами називається частотним зсувом. Операція модуляції еквівалентна підсумовуванню виходів двох різних ASK модуляторів: одні на оригінальному сигналі і першій несучій, інший - на сигналі, додатковому до оригінального і що другій несучій.

    3.3.3.3 Фазова модуляція (Phase-shift-keying, PSK)

    При PSK частота і амплітуда несучого сигналу залишаються постійними, а відбувається зсув по фазі кожного разу, коли передається біт даних. У одних PSK схемах зрушення проводитися кожного разу на 1800, в інших - на 900 при передачі нуля і на 2700 при передачі одиниці.

    3.3.3.4 Імпульсно-кодова модуляція

    Разом з аналоговими використовують також імпульсні методи модуляції, які засновані на процесі дискретизації передаваного аналогового сигналу, тобто використанні послідовності вибірок аналогового сигналу, узятих періодично з частотою дискретизації . Вона вибирається з умови можливості подальшого відновлення аналогового сигналу без спотворень з дискретизованного за допомогою фільтру нижніх частот. Наступним кроком є квантування амплітуд імпульсних вибірок - процес визначення для кожної вибірки еквівалентного їй чисельного (цифрового) значення. Разом ці два процеси і складають імпульсний-кодову модуляцію.

    Чисельне значення кожної вибірки може бути закодоване у вигляді 7 або 8 бітового двійкового коду. Таке кодування (кодифікування) дає можливість передати 128 або 256 дискретних рівнів амплітуди мовного сигналу, забезпечуючи якісну передачу мові формально з динамічним діапазоном близько 42 або 48 дБ. Враховуючи, що вибірки передаються послідовно, отримуємо двійковий цифровий потік із швидкістю 56 кбіт/с (8кГц*7 біт) у разі 7 бітового кодування або 64 кбіт/с (8 кГц*8 біт) у разі 8 бітового кодування

    3.4 Інформаційні мережі

    3.4.1 Типи інформаційних мереж

    Інформаційні мережі поділяються на локальні та глобальні.

    Локальні мережі (Local Area Network, LAN) зазвичай встановлюються в межах одного підприємства. Як передавальне середовище використовуються коаксіальний кабель, вита пара або волоконно-оптичний кабель.

    Невеликі відстані між вузлами, передавальне середовище, що забезпечує малу ймовірність помилок, дозволяють підтримувати високі швидкості обміну (від 1 Мбіт/с до 1 Гбіт/с).

    Польова шина (fieldbus) являє собою локальну мережу для приладів, використовуваних в автоматичному керуванні технологічним процесом і розміщених в умовах промислового виробництва.

    Глобальні мережі (Wide Area Network, WAN), на відміну від локальних, охоплюють значно більші території і навіть більшість регіонів земної кулі. Як передавальне середовище використовуються аналогові та цифрові дротові канали, а також супутникові канали зв'язку. Відповідно є характерними обмежена швидкість передавання і відносно низька надійність, що вимагає використання на нижчих рівнях ефективних протоколів виявлення і виправлення помилок. Це істотно знижує швидкість обміну даними у глобальних мережах порівняно з локальними. Основні стандарти в глобальних мережах – протоколи мережі Інтернет.

    3.4.2 Технічна організація мереж

    Схема, за якою вузли мережі з`єднуються між собою, називається топологією мережі (від грецького “топос” – місце і “логія” – наука).

    Використовуються такі найбільш поширені схеми з`єднання:

    а) з'єднання "точка-точка", коли мережа складається лише з двох вузлів, безпосередньо з'єднаних між собою (рис. 3.7, а);

    Рис. 3.7

    б) шинна топологія, коли всі вузли мережі под’єднуються до одного незамкнутого каналу, званого шиною (рис. 3.7, б);

    в) зіркоподібна, коли всі вузли мережі під`єднуються до одного центрального вузла, званого хостом (host) (рис. 3.7, в);

    г)кільцева, коли всі вузли мережі під`єднуються до одного замкнутого кільцевого каналу (рис. 3.7, г).

    Мережі можуть бути також змішаної топології, коли окремі частини мають різну топологію. Наприклад, основні вузли під’єднуються до одного замкнутого кільцевого каналу, а до них за зіркоподібною технологією – інші вузли.

    Топологія "шина" (bus) або, як її ще називають, "загальна шина", самою своєю структурою припускає ідентичність мережевого устаткування комп'ютерів, а також рівноправ'я всіх абонентів. При такому з'єднанні комп'ютери можуть передавати тільки по черзі, оскільки лінія зв'язку єдина. Інакше передавана інформація спотворюватиметься в результаті накладення (конфлікту, колізії). Таким чином, в шині реалізується режим напівдуплексного (half duplex) обміну (у обох напрямах, але по черзі, а не одночасно).

    У топології "шина" відсутній центральний вузол, через якого передається вся інформація, що збільшує її надійність. Додавання нових вузлів в шину досить просто і зазвичай можливо навіть під час роботи мережі. В більшості випадків при використанні шини потрібна мінімальна кількість сполучного кабелю в порівнянні з іншими топологиями.

    Оскільки вирішення можливих конфліктів в даному випадку лягає на мережеве устаткування кожного окремого вузла, апаратура мережевого адаптера при топології "шина" виходить складніше, ніж при інших топологиях. Проте із-за широкого розповсюдження мереж з топологією "шина" (Ethernet, Arcnet) вартість мережевого устаткування виходить не дуже високою.

    Шині не страшні відмови окремих комп'ютерів, оскільки решта всіх комп'ютерів мережі може нормально продовжувати обмін. Може здатися, що шині не страшний і обрив кабелю, оскільки в цьому випадку ми отримаємо дві цілком працездатні шини. Проте із-за особливостей розповсюдження електричних сигналів по довгих лініях зв'язку необхідно передбачати включення на кінцях шини спеціальних пристроїв, що погоджують, - термінаторів, показаних на рис. 3.7 у вигляді прямокутників. Без включення термінаторів сигнал відбивається від кінця лінії і спотворюється так, що зв'язок по мережі стає неможливим. Отже при розриві або пошкодженні кабелю порушується узгодження лінії зв'язку, і припиняється обмін навіть між тими комп'ютерами, які залишилися сполученими між собою. Коротке замикання в будь-якій точці кабелю шини виводить з ладу всю мережу. Будь-яку відмову мережевого устаткування в шині дуже важко локалізувати, оскільки всі адаптери включені паралельно, і зрозуміти, який з них вийшов з ладу, не так-то просто.

    При проходженні по лінії зв'язку мережі з топологією "шина" інформаційні сигнали ослабляються і ніяк не відновлюються, що накладає жорсткі обмеження на сумарну довжину ліній зв'язку, крім того, кожен вузол може отримувати з мережі сигнали різного рівня залежно від відстані до вузла, що передає. Це пред'являє додаткові вимоги до приймальних вузлів мережевого устаткування. Для збільшення довжини мережі з топологією "шина" часто використовують декілька сегментів (кожний з яких є шиною), сполучених між собою за допомогою спеціальних відновників сигналів - репітерів, або повторювачів.

    Проте таке нарощування довжини мережі не може продовжуватися нескінченно, оскільки існують ще і обмеження, пов'язані з кінцевою швидкістю розповсюдження сигналів по лініях зв'язку.

    "Зірка" (star) - це топологія з явно виділеним центром, до якого підключається решта всіх вузлів. Весь обмін інформацією йде виключно через центральний комп'ютер, на який таким чином лягає дуже велике навантаження, тому нічим іншим, окрім мережі, він займатися не може. Зрозуміло, що мережеве устаткування центрального вузола повинне бути істотно складнішим, ніж устаткування периферійних вузлів. Про рівноправ'я вузлів в даному випадку говорити не доводиться. Як правило, саме центральний комп'ютер є наймогутнішим, і саме на нього покладаються всі функції по управлінню обміном. Ніякі конфлікти в мережі з топологією "зірка" в принципі неможливі, оскільки управління повністю централізоване, конфліктувати нічому.

    Якщо говорити про стійкість зірки до відмов комп'ютерів, то вихід з ладу периферійного комп'ютера ніяк не відбивається на функціонуванні частини мережі, що залишилася, зате будь-яку відмову центрального комп'ютера робить мережу повністю непрацездатною. Обрив будь-якого кабелю або коротке замикання в нім при топології "зірка" порушує обмін тільки з одним комп'ютером, а решта всіх комп'ютерів може нормально продовжувати роботу.

    На відміну від шини, в зірці на кожній лінії зв'язку знаходяться тільки два вузли: центральний і один з периферійних. Найчастіше для їх з'єднання використовується дві лінії зв'язку, кожна з яких передає інформацію тільки в одному напрямі. Таким чином, на кожній лінії зв'язку є тільки один приймач і один передавач. Все це істотно спрощує мережеве устаткування в порівнянні з шиною і позбавляє від необхідності застосування додаткових зовнішніх термінаторів. Проблема загасання сигналів в лінії зв'язку також вирішується в "зірці" простіше, ніж в "шині", адже кожен приймач завжди отримує сигнал одного рівня.

    Серйозний недолік топології "зірка" полягає в жорсткому обмеженні кількості вузлів. Зазвичай центральний вузол може обслуговувати не більше 8-16 периферійних вузлів. Якщо в цих межах підключення нових вузлів досить просте, то при їх перевищенні воно просто неможливе. Правда, іноді в зірці передбачається можливість нарощування, тобто підключення замість одного з периферійних вузлів ще одного центрального вузла (в результаті виходить топологія з декількох сполучених між собою зірок).

    Зірка, показана на мал. 1.2, носить назву активної, або істинної, зірки. Існує також топологія, звана пасивною зіркою. У центрі мережі з даною топологією поміщається не комп'ютер, а концентратор, або хаб (hub), що виконує ту ж функцію, що і репітер. Він відновлює сигнали, що приходять, і пересилає їх в інші лінії зв'язку. Хоча схема прокладки кабелів подібна до дійсної або активної зірки, фактично ми маємо справу з шинною топологією, оскільки інформація від кожного комп'ютера одночасно передається до решти всіх комп'ютерів, а центрального вузла не існує. Природно, пасивна зірка виходить дорожче за звичайну шину, оскільки в цьому випадку обов'язково потрібний ще і концентратор. Проте вона надає цілий ряд додаткових можливостей, пов'язаних з перевагами зірки. Саме тому останнім часом пасивна зірка все більше витісняє дійсну шину, яка вважається малоперспективною топологією.

    Велика перевага зірки (як активною, так і пасивною) полягає в тому, що всі точки підключення зібрані в одному місці. Це дозволяє легко контролювати роботу мережі, локалізувати несправності мережі шляхом простого відключення від центру тих або інших вузлів (що неможливе, наприклад, у разі шини), а також обмежувати доступ сторонніх осіб до життєво важливих для мережі точок підключення. До кожного периферійного вузла у разі зірки може підходити як один кабель (по якому йде передача в обох напрямах), так і два кабелі (кожний з них передає в одному напрямі), причому друга ситуація зустрічається частіше.

    Загальним недоліком для всіх топологий типу "зірка" є значно більша, ніж при інших топологиях, витрата кабелю. Наприклад, якщо комп'ютери розташовані в одну лінію, то при виборі топології "зірка" знадобиться у декілька разів більше кабелю, чим при топології "шина". Це може істотно вплинути на вартість всієї мережі в цілому.

    "Кільце" (ring) - це топологія, в якій кожен комп'ютер сполучений лініями зв'язку тільки з двома іншими: від одного він тільки отримує інформацію, а іншому тільки передає. На кожній лінії зв'язку, як і у разі зірки, працює тільки один передавач і один приймач. Це дозволяє відмовитися від застосування зовнішніх термінаторів. Важлива особливість кільця полягає в тому, що кожен комп'ютер ретранслює (відновлює) сигнал, що приходить до нього, тобто виступає в ролі репітера, тому загасання сигналу у всьому кільці не має ніякого значення, важливе тільки загасання між сусідніми комп'ютерами кільця. Чітко виділеного центру в даному випадку немає, всі комп'ютери можуть бути однаковими. Проте досить часто в кільці виділяється спеціальний абонент, який управляє обміном або контролює обмін. Зрозуміло, що наявність такого абонента, що управляє, знижує надійність мережі, оскільки вихід його з ладу відразу ж паралізує весь обмін. Підключення нових абонентів в "кільце" зазвичай абсолютно безболісно, хоч і вимагає обов'язкової зупинки роботи всієї мережі на час підключення. Як і у разі топології "шина", максимальна кількість абонентів в кільці може бути досить велика (до тисячі і більше). Кільцева топологія зазвичай є найстійкішою до перевантажень, вона забезпечує упевнену роботу з найбільшими потоками передаваної по мережі інформації, оскільки в ній, як правило, немає конфліктів (на відміну від шини), а також відсутній центральний абонент (на відміну від зірки). Оскільки сигнал в кільці проходить через всі комп'ютери мережі, вихід з ладу хоч би одного з них (або ж його мережевого устаткування) порушує роботу всієї мережі в цілому. Так само будь-який обрив або коротке замикання в будь-якому з кабелів кільця робить роботу всієї мережі неможливої. Кільце найуразливіше до пошкоджень кабелю, тому в цій топології зазвичай передбачають прокладку двох (або більш) паралельних ліній зв'язку, одна з яких знаходиться в резерві. В той же час крупна перевага кільця полягає в тому, що ретрансляція сигналів кожним абонентом дозволяє істотно збільшити розміри всієї мережі в цілому (деколи до декількох десятків кілометрів). Кільце в цьому відношенні істотно перевершує будь-які інші топології.

    У шинних та кільцевих мережах всі вузли можуть бути рівноправними. В цьому випадку кажуть, що мережа має однорангову архітектуру. Зіркоподібна мережа характеризується наявністю центрального вузла комутації – мережевого сервера, через який надсилаються всі повідомлення. Відповідно мережа має назву серверної. Устаткування інших вузлів називається робочими станціями. На мережевий сервер можуть бути покладені додаткові функції з узгодження швидкостей робочіх станцій і перетворення протоколів обміну, що дозволяє об’єднувати в одній мережі різнотипні робочі станції.

    Останнім часом великого поширення набули локальні мережі деревоподібной технології (рис. 3.8).

    У ролі вузлів комутації тут виступають високошвидкісні концентратори (хаби1). Порівняно з шинними і кільцевими мережами деревоподібні мають вищу живучість. Вихід з ладу однієї з ліній не впливає на роботу тієї частини, що залишилась.

    Рис. 3.8

    3.4.3 Технологія клієнт-сервер

    Технологія клієнт-сервер – це особливий спосіб взаємодії комп’ютерів у мережі, коли один з вузлів (сервер) віддає свої ресурси іншому вузлу (клієнту). Ресурсами можуть бути пам’ять, зовнішні пристрої (друк, накопичувачі інформації і т.п.) або обчислювальні потужності процесора.

    При одноранговій архітектурі кожна робоча станція може виконувати функції клієнта і сервера. У цому випадку робоча станція виділяє частину своїх ресурсів у спільне користування всім робочим станціям мережі.

    У серверних мережах здійснюється чіткий розподіл функцій між устаткуванням. Мережевий сервер є спеціалізований комп’ютер, орієнтований на виконання основного обсягу функцій керування мережею. Цей сервер працює під керуванням мережевої операційної системи. Файловий сервер має основною функцією зберігання і передачу файлів даних. Він не опрацьовує і не змінює файлів які зберігаються чи передаються. Усі зміни у файлах даних здійснюються з клієнтських робочих станцій. Прінт-сервер – це друкувальний пристрій, який підключається до передавального середовища і обслуговує заявки на друк від усіх серверів і робочих станцій. Існують також поштові сервери для опрацювання повідомлень електронної пошти і Web-сервери для взаємодії з мережею Інтернет. Сервер баз даних зберігає та накопичує дані.

    3.4.4 Розгалужені мережеві топології

    Для створення великих мереж використовуються додаткові мережеві пристрої, що дозволяють збільшити протяжність мережі і реалізувати складну мережеву топологію.

    Повторювачем (репітером) називається пристрій, що застосовується для об’єднання окремих сегментів мережі як з однаковими, так і різними характеристиками фізичного середовища передачі даних. Повторювач виконує відновлення значень сигналів, що загасають на кінцях кабелів, а також забезпечує узгодження параметрів кабелів різних типів.

    Концентратор (хаб) – пристрій, який забезпечує радіальне підключення мережевих вузлів. Концентратори бувають пассивні та активні. Пасивним концентратором є розподільний пристрій, що. Пасивний концентратор не посилює сигналів, тому він дозволяє під’єднати до одного кабелю два-три мережевих вузла і використовується на невеликих відстанях. Активний концентратор відновлює форму і рівень сигналів, що передаються. Існують також інтелектуальні концентратори, які аналізують потік інформації й управляють ним. Внутрішня логічна структура концентратора може мати шинну або кільцеву топологію. В першому випадку інформація одночасно видається на всі виходи, в другому випадку концентратор послідовно опитує вузли мережі на предмет наявності маркера.

    Пристрої типу репітер та хаб використовується для об'єднання компонентів локальних обчислювальних мереж на фізичному рівні еталонної моделі OSI:

    Міст (брідж) – пристрій для об’єднання різнорідних мереж. Характериною особливістю моста є спроможність здійснювати фільтрацію, тобто вибіркову трансляцію блоків даних з однієй мережі в іншу. За допомогою моста можна поділити мережу на два сегменти. Коли моста немає, навантаження на канал дорівнює сумі всіх інформаційних потоків. Міст дозволяє розділити інформаційні потоки так, що в кожній підмережі буде своє інформаційне навантаження, менше за сумарне. Мости також застосовуються для об’єднання мереж з різною швидкістю, оскільки вони можуть здійснювати проміжне запам’ятовування інформації. що передається від більш швидкої мережі до більш повільної.

    Пристрій типу міст використовується для об'єднання компонентів локальних обчислювальних мереж канальному рівні еталонної моделі OSI:

    Маршрутизатори (роутери) призначені для вибору оптимального напрямку передачі інформації у розгалужених мережах. Маршрутизатор має кілька входів і виходів, з’єднаних з різними вузлами, а також містить таблицю шляхів між вузлами і може вибирати оптимальний маршрут передачі даних.

    Пристрій типу маршрутизатор використовується для об'єднання компонентів локальних обчислювальних мереж мережевому рівні еталонної моделі OSI:

    На прикладному рівні функцію об'єднання обчислювальних мереж виконує пристрій типу шлюз:

    На відміну від пристроїв, які були описані вище, шлюзи реалізуються тільки програмним способом.

    3.5 Інтерфейси і протоколи

    3.5.1 Загальна характеристика інтерфейсів та протоколів нижнього рівня

    На фізичному рівні стандартизуються електричні сигнали і режими передавання.

    Канал передавання даних може працювати в одному з трьох режимів:

    а) симплексному (передаванні даних тільки в одному напрямі);

    б) півдуплексному (передавання в обох напрямах, але по черзі);

    в) дуплексному (одночасне передавання в обох напрямках).

    Для передачі можуть використовуватись двопроводні та чотирипроводні канали. У чотирипроводному каналі одну пару проводів використовують для передачі в одному напрямі, другу – у зворотному.

    Дані можуть передаватись у синхронному або асинхронному режимах. У разі синхронного передавання використовують додаткові канали синхронізації для того, щоб забезпечити одночасну синхронну роботу передавача і приймача. Такий режим забезпечує більш високі швидкості, але вимагає складного апаратурного оформлення.

    В асинхронному режимі передавач може починати передачу в будь-який момент часу. Для того, щоб приймач підготувався для приймання інформації, кожному байту інформації передують стартові імпульси, в кінець даних додаються стопові імпульси. Після одержання стопових імпульсів приймач припиняє приймання до наступного стартового імпульсу.

    На канальному рівні стандартизуються розміри і формати кадрів, що передаються по каналу, а також процедури оброблення помилок.

    Протоколи та інтерфейси фізичного і канального рівнів істотно залежать від використовуваного передавального середовища.

    На мережевому рівні визначаються методи керування потоком даних між вузлами, а також методи комутації. Використовуються три технології комутації.

    Комутація каналів дозволяє за допомогою комутаторів установити пряме з`єднання між вузлами мережі.

    У випадку комутації повідомлень комутаторами виступають комп’ютери, які збирають повідомлення і розсилають їх відповідно до заданої системи маршрутизації.

    За пакетної комутації дані розбиваються на менші порції – пакети, причому кожний пакет передається незалежно.

    На транспортному рівні визначається організація обміну даними між прикладними процесами в різних вузлах. Забезпечуються перевірка отриманих даних щодо помилок і правильне збирання даних з різних пакетів, переданих на мережевому рівні, зокрема, повторне передавання загублених пакетів.

    З стандартних інтерфейсів загального призначення найбільш широке застосування знайшов інтерфейс RS-232. Цей інтерфейс був розроблений в 1969 році як стандарт для з'єднання комп'ютерів і різних периферійних пристроїв. Йому відповідає вітчизняний аналог ІРПС (інтерфейс радіальний послідовний), введений ГОСТ 18145-81.

    Інтерфейс RS-232 має обмеження на довжину з'єднувального кабелю (до 15 м при швидкості передачі 20 Кбіт/с. Високошвидкісну передачу на великих відстанях забезпечують більш нові стандарти, наприклад, RS-422 та RS485.

    3.5.2 Інтерфейс RS485

    Інтерфейс RS-485 є промисловим стандартом, що найбільш широко використовується. Він підтримує багатоточкові з'єднання, забезпечуючи створення мереж з кількістю вузлів до 32 і передачу на відстань до 1200 м при швидкості передачі 10 Мбіт/с. Використання повторювачів RS-485 дозволяє збільшити відстань передачі ще на 1200 м або додати ще 32 вузли. Для передачі і прийому даних досить однієї скрученої пари провідників, в той час як кабель RS-232 містить 9 проводів.

    Незважаючи на те, що RS-485 може успішно здійснювати передачу з використанням різних типів передавальної середовища, він повинний використовуватися з проводкою, звичайно називаної "кручена пари".

    Використання передавача, що відповідає вимогам специфікації RS-485, з кабелем на основі крученої пари, зменшує два головних джерела проблем для проектувальників швидкодіючих територіально розподілених мереж, а саме випромінювані електромагнітні завади і индуковані електромагнітні завади (наведення). Передача корисного сигналу здійснюється зміною напрямку протікання струму (1 - у прямому напрямку, 0 - у зворотному).

    Часова діаграма передачі байта інтерфейсом RS485 показана на рис. 3.9

    Рис. 3.9

    При реалізації інтерфейсу RS485 існує головний пристрій, іменований хостом і пристрої, якими він керує - клієнти. Кожному клієнту привласнюється унікальна адреса. Клієнти постійно знаходяться в стані приймання. Хост посилає в мережу команду, на початку якої вказується адреса клієнта, якому команда призначається. Команда виконується тільки тим клієнтом, для якого збігається адреса з адресою, зазначеною в команді. Інші пристрої знаходяться в пасивному стані.

    Стандарт RS485 визначає тільки електричні і фізичні характеристики інтерфейсу. Програмна ж реалізація визначається конкретним застосуванням.

    Передача корисного сигналу здійснюється зміною напряму протікання струму (1 - в прямому напрямі, 0 - в зворотному). У неактивному стані передавач переводиться в третій стан з високим імпендансом. Зазвичай вхід приймача і вихід передавача об'єднані разом і зв'язок здійснюється по двох проводах (витій парі). Крім того, прокладається і третій провід, так званий дренажний провідник, який приєднується до сигнальних земель кожного пристрою (рис. 3.10). Допускається безпосереднє приєднання сигнальної землі до точок з нульовим потенціалом (корпусна земля) на пристрої, але тільки у разі гарантованої рівності потенціалів землі в місцях розміщення устаткування системи.

    Рис. 3.10

    Для більшої завадозахищенності проводи рекомендується помістити в екран. Не слід використовувати екран як дренажний провід.

    Можливе збільшення дальності передачі числа пристроїв до 256 при застосуванні півторювачів.

    3.5.3 HART-протокол

    Стандарт передачі аналогових сигналів значеннями струму в діапазоні 4-20 мА широко використовується при створенні АСУ ТП у багатьох галузях промисловості. Однак при створенні нового покоління інтелектуальних приладів і датчиків з’явилась потреба поряд з передачею аналогової інформації передавати і цифрові дані.

    HART – це гібридний протокол обміну даними, що передбачає одночасне використання цифрового сигналу, в основному для передачі службової інформації, і аналогового сигналу 4–20 мА. Обидва сигнали – аналоговий і цифровий – можуть одночасно передаватися по тому самому проводу.

    Протокол HART використовується в двох режимах підключення. Один являє собою з'єднання “точка”-“точка”, і застосовується в системах з одним веденим пристроєм і максимум двома ведучими (основним і вторинним) пристроями. Ведучим пристроєм може бути пристрій зв'язку з об'єктом або програмований логічний контролер. У якості вторинного – або HART-термінал або будь-який інший пристрій з HART-модемом (рис.3.10, а). Передача інформації може здійснюватися в обох напрямках, причому передача аналогової інформації з цього ж каналу не переривається.

    Другий тип підключення – “шина” – дозволяє з'єднання один з одним до 15 ведених пристроїв з тими ж двома ведучими пристроями. У цьому випадку передбачається обмін тільки даними в цифровій формі. У колі контролерів передбачене додаткове джерело струму, що забезпечує по 4 мА на кожного споживача

    Рис. 3.11 – Варіанти під’єднання HART-пристроїв:
    а – “точка”-“точка” з аналоговим сигналом; б – “шина” без передачі аналогового сигналу

    Для передачі цифрової інформації HART-протокол використовує принцип частотної модуляції. Цифрова інформація передається частотами 1200 Гц (логічна “1”) і 2200 Гц (логічний “0”), що накладаються на аналоговий струмовий сигнал.

    Частотно-модульований сигнал є двохполярним і при застосуванні відповідної фільтрації не впливає на основний аналоговий сигнал 4–20 мА, оскільки середнє значення синусоїди дорівнює нулю. HART-складова має невелику амплітуду (порядку 1 мА). Безпосередньо перед використанням аналогового сигналу HART-складова може бути легко вилучена з нього за допомогою простого фільтра нижніх частот. Швидкість передачі цифрових даних для HART складає 1,2 кбит/с.

    3.6 Мережі та вузли нижніх рівнів АСУ ТП

    3.6.1 Локальна мережа Ethernet

    Локальна мережа Ethernet базується на міжнародному стандарті IEEE 802.3, що визначає фізичний рівень та так званий підрівень МАС, який формує кадри для передавання і керує прийманням кадрів.

    Для позначення типу протоколу фізичного рівня використовується позначення, яке складається з трьох компонентів:

  • Швидкість передачі даних
  • Тип протоколу лінійного кодування
  • Тип використовуваного середовища передачі даних або максимальна довжина сегменту в 100 метрових квантах

    • Наприклад, умовне позначення 10Base2 розшифровується так

  • швидкість передачі даних: 10 Мбит/сек
  • тип протоколу лінійного кодування: Base band - без використання модуляції
  • тип використовуваного середовища передачі даних: тонкий коаксіальний кабель

    • Інші типи протоколів зведені в табл. 3.1

    Таблиця 3.1 - Типи протоколів фізичного рівня мережі Ethernet

    Характеристика | Ethernet | 10Base5 | 10Base2 | 10BaseT | 10BaseFL
Швидкість (Мбіт/с) | 10 | 10 | 10 | 10 | 10
Метод кодування | Baseband | Baseband | Baseband | Baseband | Baseband
Тип середовища | ТВКК | ТВКК | ТНКК | ВП | ОК
Топология мережі | ЗШ | ЗШ | ЗШ | Зірка | ТТ

    Умовні позначення в таблиці

  • ТВКК - товстий коаксіальний кабель
  • ТНКК - тонкий коаксіальний кабель
  • ВП - неекранована вита пара
  • OК - волоконно-оптичний кабель
  • ЗШ - топологія мережі "загальна шина"
  • ТТ - топологія мережі точка-точка

    • На канальному рівні технології Ethernet визначаються наступні параметри кадру:

  • Максимальна довжина кадру
  • Мінімальна довжина кадру
  • Розмір і зміст службових і обов'язкових полів кадру
  • Розмір і зміст факультативних полів кадру

    • Інформаційна взаємодія на канальному рівні мереж стандарту Ethernet розділена на додаткові рівні, які не передбачені моделлю OSI. Ці рівні називаються LLC(Logical Link Control) і MAC(Media Access Control).

    Для передачі даних по мережі Ethernet використовуються блоки даних канального рівня - кадри. Для позначення кадрів застосовуються наступні терміни:

  • RUNT - (коротун) кадр, розмір якого менше 64 байтів (512 битий)
  • LONG - (довгий) - кадр, розмір якого лежить в межах від 1518 до 6000 байтів
  • GIANT - (гігант) - кадр, розмір якого перевищує 6000 байтів
  • DRIBBLE - кадр такого типу утворюють два послідовні кадри, які були помилково сприйняті як один кадр.

    • Формат кадру Ethernet:

    Preamble Преамбула | DA Адрес призначення | SA Адрес відправника | Type Тип | Data Дані | CRC Контрольна сума
8 байтів | 6 байтів | 6 байтів | 2 байти | 46-1500 байтів | 4 байти

    Поле преамбули не призначене для передачі корисній інформації, наявність цього поля у кадрі пояснюється необхідністю встановлення надійної взаємної синхронізації тактових генераторів передавача і приймача даних. Поле Тип займає 2 байти в пакеті Ethernet II і містить інформацію про тип корисного навантаження даного пакету.

    Особливість технології Ethernet полягає в тому, що вона дозволяє реалізувати передачу даних за принципом "один для всіх" - "широкомовлення" (broadcasting). Для ідентифікації одержувача інформації в технологіях Ethernet використовуються 6-ти байтові MAC-адреса.

    Формат MAC-адреси забезпечує можливість використання специфічних режимів багатоадресної адресації в мережі Ethernet і, одночасно, виключити можливість появи в межах однієї локальної мережі двох станцій які мали б однакову адресу.

    Фізична адреса мережі Ethernet складається з двох частин:

  • Ідентифікатор виробника устаткування (Vendor codes)
  • Індивідуальний ідентифікатор пристрою

    • Кожен абонент мережі перевіряє адресу, що міститься у переданому по мережі кадрі. Якщо кадр адресований цьому абонентові він обробляє його, інакше передає наступному абонентові. Якщо канал передачі вільний, будь-яка станція може почати передавання даних.

    Використовують такі конфігурації :

    а) шинну топологію на коаксіальному кабелі з максимальною довжиною сегмента до 185 м;

    б) зіркоподібну топологію на витій парі з довжиною сегмента до 100 м;

    в) зіркоподібну топологію на волокно-оптичному кабелі з довжиною сегмента до 2000 м.

    Для з’єднання робочої станції з локальною мережею використовують мережеві адаптери, які мають конектори для під’єднання кабелю. У випадку використання зіркоподібної топології застосовують концентратори (хаби), які підключаються до центрального вузла мережі.

    Стандарт Ethernet з використанням коаксіального кабелю забезпечує швидкість передачі 10 Мбіт/с. Стандарт Fast Ethernet з витою парою розрахований на швидкість 100 Мбіт/с. Для високошвидкісного зв`язку використовують стандарт 10Gigabіt Ethernet, що передбачає використання оптоволоконного кабелю і швидкість до 10 Гбіт/с.

    Ethernet - це неофіційний світовий стандарт адміністративних і обчислювальних мереж.

    3.6.2 Локальна мережа Token Ring

    Локальна мережа Token Ring базується на міжнародному стандарті IEEE 802.35, що визначає фізичний рівень та підрівень МАС для реалізації маркерного доступу в локальних мережах кільцевої топології.

    Маркер (token) – це кадр певного формату, що безупинно циркулює між станціями мережі і має два стани: вільний чи зайнятий. Якщо яка-небудь станція має дані для передавання і визначає, що маркер вільний, вона захоплює маркер, додає до нього свої дані і пересилає наступній станції кільця. Станції пересилають кадр одна одній, але тільки станція-адресат зчитує дані з маркера. Коли маркер обійде кільце і повернеться до станції, що його захопила, та звільняє маркер і знову передає далі.

    Швидкість передавання даних становить 4,16 Мбіт/с, максимальна кількість станцій 250.

    Для збільшення швидкості передавання до 10 Мбіт/с розроблена нова технологія 100VGAnyLAN.

    3.6.3 Локальні радіомережі

    Стандартом IEEE 802.11 передбачане використання радіозв’язку для передачі даних на частотах від 2,4 до 2,483 ГГц.

    Згідно цього стандарту можливі два режими функціонування. У першому всі станції мережі оснащені безпровідними адаптерами і безпосередньо взаємодіють одна з одною. У другому режимі станції взаємодіють не прямо, а через так звану точку доступу, що виконує роль концентратора. Точки доступу різних мереж можуть з’єднуватись кабельними каналами.

    Швидкість передачі – 1 або 2 Мбіт/с.

    Новий стандарт IEEE 802.11а забезпечує передавання даних на частотах від 5,15 до 5,825 ГГц зі швидкостями до 54 Мбіт/с. Підвищення швидкості досягається використанням нових спеціальних методів кодування інформації.

    На малих відстанях (до lang=UK>10 м) для безпровідного зв`язку використовується технологія Bluetooth. Застосовуються радіочастоти у смузі 2400…4483,5 МГц.

    Локальна мережа Bluetooth складається з окремих пікомереж, в яку входять один пристрій-“хазяїн” і до семи пристроїв-“слуг”. Кожна пікомережа працює на окремій радіочастоті.

    Одна з найважливіших особливостей Bluetooth – автоматичне установлення з`єднання. Кожен пристрій здійснює пошук у радіоефірі інших пристроїв. Якщо один пристрій з`єднався з іншим, вони домовляються між собою про фізичні параметри з`єднання і формат передачі даних. Далі пристрій з`ясовує імена всіх доступних пристроїв і визначає прикладні задачі, які вони виконують. Для цього використовується спеціальний протокол виявлення сервісу.

    Таким чином для введення в локальну мережу нового пристрою достатньо піднести його на відстань менше 10 м до іншого пристрою.

    3.6.4 Польові шини

    3.6.4.1 Modbus

    Протокол Modbus був розроблений для збору даних контролерами Modicon з первинних (підлеглих) приладів. Структура протоколу надзвичайно сильно оптимізована для використання в ПЛК.

    Фізичний рівень - RS-232.
    Тип обміну : "Master-контролер" - запит, "slave-контролер" - відповідь.
    Підтримується до 247 адресованих "slave-контролера". Можлива передача циркулярного запиту (адреса - 0).
    Можливі два режими протоколу: RTU і ASCII. RTU – команди і дані передаються в бінарному вигляді. ASCII – команди і дані передаються в ASCII кодах.
    Протокол надзвичайно простий для реалізації.

    3.6.4.2 Modbus Plus.

    Специфікація Modbus Plus стала радикальною переробкою протоколу Modbus. (Специфікація – точне і докладне визначення дій, які має виконувати та чи інша система).

    Основне призначення Modbus Plus організація мереж із пристроїв кількістю до 64 одиниць з можливістю об'єднання цих мереж через мости.

    Швидкість передачі даних по мережі до 1000000 біт/сек.

    Мережна шина використовує або одиночний або подвійний кабель (для поліпшення надійності системи).
    Як кабель використовується екранована вита кручена пара.

    До 32 вузлів може бути підключене до кабелю мережі безпосередньо на дистанції 450 метрів. Може використовуватися повторювач для подовження кабелю до 1800 метрів і збільшення кількості вузлів до 64.
    Мережі можуть з'єднуватися між собою мостами. При цьому повідомлення з вузла в одній мережі можуть бути передані (маршрутизовані) до вузла в іншій мережі.

    Передача даних усередині мережі спирається на механізм делегування маркера. У кожен конкретний момент передачу запитів здійснює тільки один вузол. Вузол, що одержав маркер, відразу відправляє підтвердження в його одержанні. Після завершення сеансу опитування вузлів активний вузол передає маркер наступному вузлу і т.д.

    Самі запити, як і у випадку з Modbus, спираються на реєстрову структуру ПЛК.

    3.6.4.3 CAN

    Специфікація CAN була розроблена BOSH для інтегрування різноманітних датчиків автомобільної електроніки в рамках однієї цифрової мережі. На даний момент це дуже розповсюджена технологія і в інших галузях.

    Специфікація CAN визначає тільки два рівні: фізичний (бітове кодування, декодування, синхронізація) і канальний. Причому фізичний рівень не визначає параметри передавача, приймача і середовища передачі сигналу.

    Природно багато виробників скористалися таким положенням речей і доповнюючи специфікацію CAN рівнями, що залишилися, OSI створили свої власні стандарти.

    Основу специфікації CAN складає принцип адресування повідомлень. На відміну від інших специфікацій повідомлення в CAN передаються не конкретному вузлу, а циркулярно з використанням унікального ідентифікатора повідомлення. Кожен вузол вибирає з мережі повідомлення тільки з визначеними іцдентифікаторами.

    Існують дві специфікації CAN: 1.2 і 2.0. У CAN 1.2 ідентифікатор містить 11 біт, що дозволяє використовувати до 211 повідомлень. У CAN 2.0 ідентифікатор містить 29 біт.

    Визначений досить оригінальний метод розв’язування конфліктів виходу різних вузлів на загальну шину.
    Багато виробників мікросхем випускають CAN контролери, при цьому фізична реалізація середовища передачі залишається на совісті розроблювача.

    Розглянемо особливості окремих протоколів верхнього рівня технології CAN.

    3.6.4.3.1 DeviceNet

    Походження: Allen-Bradley, 1994 р. Підтримуюча організація: Open DeviceNet Vendor Association.

    Максимальне число вузлів: 64.

    Швидкість передачі даних: 125, 250 і 500 Кбит/с.

    Особливо широкого поширення дана шина набула в автомобільній і напівпровідниковій галузях промисловості. Живляча напруга для пристроїв автоматики подається по мережевому кабелю, загальне число використовуваних кабелів і складність розводки мінімальні.

    3.6.4.3.2 Interbus

    Походження: Phoenix Contact, 1984 р.

    Максимальне число вузлів: 256.

    Довжина з'єднання: 400 м на сегмент, в сумі до 12,8 км.

    Швидкість передачі: 500 Кбит/с (також можлива швидкість 2 Мбит/с).

    Може застосовуватися разом з підмережами SensorLoop і AS-I. Фізично Interbus нагадує звичайну мережу з багатовідвідними з'єднаннями, проте насправді є послідовним кільцем на базі зсувових регістрів. Завдяки незвичайній мережевій топології Interbus має дві додаткові переваги. По-перше, кільцева топологія дає головному пристрою можливість самому себе конфігурувати, причому в деяких випадках даний процес не вимагає втручання з боку користувача. По-друге, точність відомостей про мережеві відмови і місце їх виникнення значно спрощує процес пошуку і усунення відмов.

    3.6.4.3.3 AS-I (Actuator Sensor Interface)

    Походження: консорціум AS-I Consortium, 1993 р. Підтримуюча організація: AS-I Trade Organization.

    Максимальне число вузлів: 31 підлеглий, 1 головний.

    Довжина з'єднання: 100 м; з ретрансляторами до 300 м.

    Швидкість передачі: 167 Кбіт/с.

    Нова специфікація AS-I, що недавно вийшла, допускає підключення 62 (замість 31) підлеглих пристроїв з 4 входами і 3 виходами кожне. Зараз дану специфікацію підтримує мале число виробників, що проте задовольняють їй нові пристрої можуть використовуватися нарівні із старими.

    3.6.4.4 Foundation FieldBus

    Специфікація розробляється асоціацією Foundation Fieldbus.

    Параметри:
    швидкість передачі 31.25 кбит/сек;
    довжина мережі - до 2000 м;
    топологія мережі - шина;
    кабель - вита пара;
    У вузлів - 240/сегмент, 65535 сегментів усього;

    Основні особливості:

  • логічна організація мережі дозволяє вузлам організовувати однорангову взаємодію;
  • кожному типу вузла може бути створений т.з. профіль пристрою, що є повним описом усіх функціональних особливостей. Це дозволяє використовувати різні пристрої в існуючій мережі без розробки спеціального програмного забезпечення;
  • Доступ до мережі здійснюється не тільки з боку інженерної станції, але і з боку самих пристроїв.

    • Цифрова мережа Fieldbus покликана замінити що широко використалася до недавнього часу централізовану аналогову 4-20mA.технологию з метою зниження витрат на розробку і підвищення якості і ефективності кінцевої системи.

    Foundation Fieldbus - це відкритий міжнародний стандарт для відповідальних систем управління технологічними процесами і безпечних умов експлуатації. Типові області застосування: розподілені системи управління, управління безперервними процесами, періодичні технологічні процеси.

    3.6.4.5 INTERBUS-S

    В основі топології Interbus лежить кільцева система, тобто всі пристрої активно інтегровані в замкнутий передатний контур. Кожен вузол підсилює прийнятий сигнал і передає далі, що дозволяє використовувати високі швидкості передачі даних на великі відстані. Система master/slave Interbus дозволяє поєднувати до 512 пристроїв у 16 підмережах.

    · Топологія: активне кільце

    · Master/slave, пакети фіксованої довжини

    · Усі вузли на кільці є повторювачами

    · Швидкість передачі: 500 kbps

    · Максимум 4096 точок уведення-виведення

    · Загальна довжина між двома віддаленими вузлами до 13 км

    3.6.4.5 PROFIBUS

    Група з 13 компаній і 5 інститутів Німеччини працювали над специфікацією відкритої промислової мережі, що отримала назву PROFIBUS (PROcess Field BUS), на основі моделі міжмережевої взаємодії OSI.

    У квітні 1991 року PROFIBUS отримав статус національного стандарту DIN19245 і був оголошений відкритим рішенням - ніхто не володіє ліцензійним правом на нього.

    Архітектура складників протоколу PROFIBUS приведена на рис. 3.12.

    Рис. 3.12 - Архітектура протоколу PROFIBUS

    Всі три типи протоколу використовують загальний канальний рівень (протокол доступу до середовища, що передає).

    PROFIBUS-FMS протокол з'явився першим і вважається універсальним з високим ступенем функціональності. FMS-протокол допускає гібридну архітектуру взаємодії вузлів, засновану на таких поняттях, як віртуальний пристрій мережі, об'єктний словник пристрою (змінна, масив, запис, область пам'яті, подія і ін.), логічна адресація і т.д.

    PROFIBUS-FMS визначає рівні 1, 2 і 7 і надає користувачеві широкий вибір комунікаційних функцій. Підрівень 7-го рівня LLI (Lower Layer Interface) реалізує частина функцій отсутствующих 3-6 рівнів і робить можливим доступ до рівня 2 різних FMS-пристроїв різних виробників.

    PROFIBUS-DP. У DP-протоколі існують три типи пристроїв:

  • Майстер Класу-2 (DPM2) - може виконувати функції конфігурації і діагностики пристроїв мережі;
  • Майстер Класу-1 (DPM1) - програмовані контроллери (PLC, PC), в оперативному режимі виконуючі функції провідного вузла в мережі;
  • Ведомі пристрої (DP Slave) - пасивні пристрої з аналоговым/дискретным введенням/висновком.

    • PROFIBUS-DP використає 1-й і 2-й рівні і реалізує набір функцій, що забезпечують інтерфейс до прикладного завдання користувача. Відсутність рівня 7 забезпечує швидку і ефективну технологію передачі за рахунок прямого доступу до функцій канального рівня.

    PROFIBUS-PA є розширенням DP-протоколу в частині фізичного середовища передачі, заснованої на реалізації IEC1158-2 стандарту для організації передачі у вибухонебезпечних середовищах. Він може бути використаний як заміна старій 4-20mA технології зв'язку. Перехід на PA дозволяє скоротити витрати на організацію мережі приблизно на 40% (для комутації датчиків потрібна всього одна витаючи пара з можливістю живлення пристроїв по цьому ж каналу).

    На одному фізичному каналі одночасно можуть працювати пристрої всіх трьох типів PROFIBUS. Перехід з одного фізичного середовища в іншу реалізується на основі відповідних трансиверов.

    Передавальне середовище в PROFIBUS, як правило, будується на основі RS485 інтерфейсу. Ця технологія передачі має ще назву H2. Мережеві рішення на цій основі дозволяють будувати системи з невеликими витратами на організацію середовища передачі, з одного боку, і забезпечувати передачу даних на великих швидкостях, з іншого боку.

    Основні характеристики H2-технологии:

    Режим передачі даних | Напівдуплексний, асинхронний
Мережева топологія | Лінія, "дерево"
Середовище передачі | Екранована вита пара
Число вузлів | 32 вузли на сегмент без повторювачів (всього до 127)
Робочі швидкості передачі, kbit/sec (відстань, м) | 9.6, 19.2, 93.75 (1200); 187.5 (1000); 500 (400); 1500 (200); 12000 (100)
Доступ до шини | Естафетне маркерне кільце з режимом доступу Master/Slave

    У хімічній і нафтохімічній індустрії використовується технологія передачі, що забезпечує використання пристроїв у вибухонебезпечних середовищах з можливістю живлення цих пристроїв безпосередньо по комунікаційній шині. Ця технологія має назву H1 і використовується в PROFIBUS-PA (Process Automation). Посилані по шині сигнали модулюються струмом +/-9 mA від базового струму в 10 mA.

    Крім перерахованих H2 і H1 технологій передачі існує можливість використання оптичного кабелю як фізичного середовища. Ця технологія знаходить застосування в умовах, де присутній сильний електромагнітний вплив або є необхідність у високій швидкості передачі на великі відстані в порівнянні з RS485.

    3.6.5 Вибір типу мережі

    У 1950 році асоціація ISA організувала комітет SP50 з розробки стандарту на інтерфейс польового пристрою (field-пристрої). У 1961 році був створений стандарт аналогового інтерфейсу 4-20 мА. На цифрові засоби зв'язку до цих пір єдиного стандарту немає. Виробники розробляють власні цифрові комунікаційні стандарти і випускають продукцію на їх основі. Сьогодні в світі існує більше 60 таких стандартів для мереж рівня датчиків, польових пристроїв і управління, і більше 5000 пристроїв для цих мереж. На рис. 3.11 показана порівняльна діаграма об'ємів виробництва таких пристроїв.

    Рис. 3.13

    Схвалений в кінці 1999 року більшістю голосів стандарт IEC 61158 допускає вісім різних несумісних протоколів, кожний з яких претендує на відповідність стандарту.

    Останніми роками значних успіхів добилися Ethernet і технології Internet. Ethernet вважається найперспективнішою мережею для обміну інформацією між системами, що управляють, і окремими пристроями.

    Ethernet це тільки фізичне середовище, кабель, що сполучає пристрої. Необхідний ще і прикладний рівень, покликаний забезпечити спосіб обміну інформацією і взаємодії по мережі різних продуктів різних виробників. Кожна промислова шина реалізує в комунікаційному стеку власний прикладний інтерфейсний рівень. Отже якщо підвищена безпека і/або подача напруги живлення в підключений пристрій не потрібна, то промислові шини типа Foundation Fieldbus, Profibus і DeviceNet цілком можуть функціонувати на базі фізичних Ethernet-кабелів.

    Мережева структура, що представляє в загальному вигляді місце існуючих класів мереж на всіх рівнях промислового підприємства, показана на рис. 3.10.

    Рис. 3.14

    Ці і інші технології в поєднанні один з одним можуть служити основою створення широко розподіленої високоінтелектуальної архітектури систем, що управляють, з централізацією управління безпосередньо на виробничій ділянці (field-центричне управління).

    Рис. 3.15

    Виробниче устаткування (реактори, колони, казани, центрифуги і т.д.) об'єднуються відповідною мережею (process unit network), можливо, Ethernet, а можливо, і ні, що дозволяє цьому устаткуванню взаємодіяти один з одним незалежно від типу вбудованої в нього операційної системи. До цих мереж підключаються цільові (built-for-purpose - BFP) інтелектуальні прилади типу датчиків, вентилів, двигунів, контроллерів і т.д. Всі апаратні мережі об'єднуються в одну цехову мережу (process cell network). Як цільові прилади, підключені до цієї мережі, можуть виступати пристрої підтримки архівів, менеджери складів сумішей, безперервні оптимізатори процесу і інформаційні пристрої. Далі по ієрархії мереж йдуть загальнозаводські мережі. На цьому рівні цільовими приладами є автоматизовані довідкові системи, системи оперативного моделювання, архіви даних і оптимізатори процесів.

    3.6.6 Вузли нижніх рівнів АСУ ТП

    3.6.6.1 Програмовані контролери

    Програмований контролер – це комбінація керуючого обчислювального пристрою і пристрою зв’язку з об’єктом (ПЗО). Вони поділяються на програмовані логічні контролери (PLC) та універсальні IBM PC сумісні контролери. Перші призначені тільки для дискретного логічного керування, другі є вільно програмованими і можуть виконувати різні функції, в тому числі і реалізацію ПІД-регуляторів.

    Типова конфігурація промислового контролера показана на рис. 3.13. За такою схемою побудовані практично всі PLC і IBM PC сумісні контролери. Як ПЗО в таких системах використовуються спеціальні модулі введення-виведення, що мають з одного боку інтерфейс із внутрішньою шиною, а з іншого боку — кілька (звичайно кратно восьми) каналів для підключення зовнішніх сигналів. Незважаючи на широке поширення такого рішення, у нього є недоліки. Головний з них полягає в тім, що центральний процесор змушений займатися не тільки задачами керування і мережної взаємодії, але і введення-виведення.

    Рис. 3.16 – Структура промислового комп’ютера

    На рис. 3.17 показана структура системи з використанням віддалених ПЗО, з'єднаних з контролером за допомогою одного з відомих промислових мережних інтерфейсів (PROFIBUS, CAN, INTERBUS, MODBUS, і т.д.). До переваг такої конфігурації відносяться масштабованність і можливість використання ПЗО різних виробників. Процес уведення-виведення здійснюється контролером віддаленого ПЗО. Далі, як правило, стан каналів уведення-виведення кожного з контролерів ПЗО відображається в єдиному вікні двохпортовой пам'яті адаптера мережі, встановленої в центральному контролері. Таким чином, процесор здійснює керування каналами введення-виведення через вікно пам'яті, користуючись так званим образом процесу.

    Рис. 3.17 – Структура контролера з розподіленими ПЗО

    3.6.6.2 Інтелектуальні прилади

    В останні роки усе більш широке поширення у світі одержують нові класи засобів сприйняття і вимірювання, оснащені мікропроцесором. Такі засоби прийнято називати “інтелектуальними датчиками”. Під цим терміном розуміють різні за можливостями класи приладів і найчастіше будь-який датчик, що має у своєму складі мікропроцесор, незалежно від виконуваних цим мікропроцесором функцій, називається інтелектуальним. Однак правильним буде відносити до інтелектуальних тільки такі прилади, що є багатофункціональними програмованими вимірювальними засобами і мають зв'язки зі стандартними польовими мережами.

    Інтелектуальні датчики складаються з двох взаємозалежних модулів: модуля сенсора (чутливого елемента) і модуля електроніки (перетворювача). Перетворювач комплектується з програмувального мікропроцесора з оперативним і постійним модулями пам'яті, аналого-цифрового перетворювача, цифро-аналогового перетворювача, мережевого контролера зв'язку з типовими польовими мережами.

    Крім звичайних функцій сприйняття вимірюваної величини і перетворення сигналу, сучасні інтелектуальні датчики виконують ряд інших функцій, що істотно розширюють їхні можливості і поліпшують їхні технічні характеристики.

    Функції перетворення. Датчик перетворює електричну величину на виході сенсора і здійснює її вимірювання; при цьому він виконує корекцію сигналу по супутнім поточним показникам стану вимірюваного середовища (наприклад, по температурі і/або по тиску), у випадку, якщо показання датчика залежать і від них. У датчику відбувається необхідне перетворення вимірювальної інформації: посилення сигналів сенсора, стандартизація діапазонів вихідних аналогових сигналів, лінеаризація і фільтрація, розрахунок вихідних значень по заданих алгоритмах, аналого-цифрове перетворення значень вимірюваної величини.

    Функції самодіагностики. Датчики виконують аналіз своєї роботи: при виникненні різних збоїв, порушень і несправностей визначають їхнє місце виникнення і причину, фіксують вихід погрішності приладу за встановлене значення, аналізують роботу бази даних датчика, розглядають правильність обліку факторів, що коректують вихідні показання датчика. Звичайно інформація, що видається датчиком про його несправності, поділяється на два типи:

    · некритична інформація, коли датчик вимагає деякого обслуговування, але вимірювані ним значення можуть використовуватися для керування;

    · критична інформація, коли вихідні дані датчика невірні і, або потрібно негайне втручання оператора по припиненню використання його показань, або сам датчик переводить свій вихід у постійне безпечне для керування процесом значення, і повідомляє про необхідність термінового обслуговування приладу.

    Інформаційні функції. Датчики зберігають у своїй пам'яті і на запит користувача видають усі дані, що визначають властивості, характеристики, параметри даного конкретного приладу: його тип, заводський номер, технічні показники, можливі діапазони виміру, установлену на даний момент шкалу, версію програмного забезпечення, архів проведених метрологічних повірок, термін проведення наступної повірки датчика і т.п.

    Функції конфігурувания. Дистанційне формування чи модифікація користувачем основних настроєчних параметрів датчика: установлення нуля, вибір заданого діапазону виміру, вибір методів фільтрації поточних значень, вибір найменування одиниць виміру і т.п.

    Функції форматування. Автоматичний аналіз змін вимірюваної величини і поточного стану середовища виміру: визначення виходів значень вимірюваної величини за задані межі, видача різних повідомлень про зміни значень вимірюваної величини.

    Керуючі функції.

    Усе більше число додаткових функцій, безпосередньо зв'язаних з керуванням, покладаються на інтелектуальні датчики. Для реалізації цих функцій у пам'яті мікропроцесора датчика прошивається відповідний набір типових програмних модулів, а їхня ініціалізація і параметризація проводяться дистанційно за допомогою графічного конфігуратора. Як типові програмні модулі використовуються найпростіші арифметичні і логічні операції, таймер, елемент чистого запізнювання, інтегратор, варіанти регуляторів: П, І, ПІ, ПД, ПІД і т.п. функції, з яких легко набираються різні алгоритми керування технологічними процесами.

    Сучасні інтелектуальні датчики підтримують три стандарти польових мереж: мережа з HART-протоколом, мережа Profibus, мережа Foundation Fieldbus.

    HART-протокол націлений на зв'язок інтелектуальних приладів з контролером і має два варіанти такого зв'язку.

    При першому варіанті реалізується зв'язок кожного приладу з контролером по окремій парі проводів (стандартний варіант), по якій можуть проходити як аналоговий, так і цифрові сигнали. Цифрові сигнали містять додаткову інформацію про роботу приладу: діапазон і одиниці виміру, дату калібрування, результати самодіагностики.

    При другому варіанті зв'язку реалізується з'єднання ряду приладів з контролером по одній парі проводів (багаточечний варіант), у цьому випадку по парі проводів можуть проходити тільки цифрові сигнали.

    Кожне повідомлення від приладу може містити інформацію двох типів: поточні дані і статус приладу, що визначає його оперативний стан.

    3.6.6.3 Технологічні сервери

    Сервер - це комп’ютер або пристрій в мережі, який керує мережевими ресурсами. За своєю потужність сервери ділять на три групи:

    а) сервери початкового рівня мають у своєму складі від 2 до 16 процесорів;

    б) сервери середнього рівня мають від 16 до 64 процесорів;

    в) високорівневі сервери мають понад 64 процесори.

    Сервери мають і інші конструктивні особливості:

    а) резервування окремих компонентів;

    б) використання технологій підвищеної надійності зберігання даних;

    в) можливість зміни конфігурації в процесі роботи без вимкнення живлення.

    Дешеві сервери компонуються в корпусах того ж типу, що і для персональних комп’ютерів, тільки більшого розміру. Сервери більш високого класу компонуються в спеціальних стояках. Нова технологія копонування – технологія Blade (лезо) передбачає, що кожний компонент сервера має власні процесор, оперативну пам’ять, диски. Все це оформлюється як карта, що вставляється у стояк і являє собою окремий мікросервер зі свома характеристиками. Карти можуть функціонувати самостійно або бути об’єднані в групу, що має назву кластера. Кластери використовуються для розв’язання складних задач з розподіленням ресурсів даних між картами.

    Для підвищення надійності зберігання даних вони записуються одночасно на два жорсткі диски. При відмові одного диска дані зчитуються з іншого. Видаляти чи замінювати компоненти, що вийшли з ладу, можна без зупинки роботи сервера.

    3.7 Мережі та вузли верхніх рівнів АСУ ТП

    Вузлами верхніх рівнів АСУ ТП є автоматизовані робочі місця (АРМ) планово-управлінського персоналу

    та сервери баз даних.

    Згідно з державним стандартом 34.003-90 АРМ в АСУ — це програмно-технічний комплекс, призначений для автоматизації діяльності зазначеного виду. АРМ можна застосувати при розв'язуванні комплексів задач управління в різних сферах діяльності і на різних рівнях управління.

    За допомогою АРМ спеціаліст може автоматично обробляти тексти, надсилати і приймати повідомлення, брати участь в теленарадах, організовувати і вести особисті архіви документів на машинних носіях, проводити імітаційне моделювання для вивчення поводження системи, виконувати обчислення й діставати готові результати в табличній або графічній формі.

    Оскільки процес прийняття рішень у процесі управління в цілому реалізується колективом, необхідна проблемна спеціалізація АРМ управлінського персоналу, яка відповідає різним управлінським ланцюгам і функціям, що реалізуються. Реалізація різноманітних фаз прийняття рішень (підготовка інформації для прийняття рішень, саме прийняття рішень; реалізація прийнятих рішень) має багато спільного з різними службами об'єкта управління (облікові, планові, збутові служби). Це дає змогу створювати гнучкі структури управління, підвищувати ефективність і оперативність роботи служб. Локальні мережі, на основі яких можуть функціонувати комплекси АРМ, як у рамках окремих підрозділів, так і на рівні суміжних функцій, виконуваних різними підрозділами, слугують базою для взаємозв'язку окремих АРМ у системі.

    Створені на базі персональних комп’ютерів АРМ функціонально, фізично та органічно настроюються на конкретного користувача (персональне АРМ) або групу користувачів (групове АРМ).

    Задачі організаційного управління, які розв'язуються в складі АРМ, можна умовно поділити на три класи.

    До 1-го класу належать повністю формалізовані задачі (господарський та фінансовий облік, підготовка виробництва), для яких можна розробити структуризовані процедури вироблення рішень. Задачі можуть розв'язуватись на ЕОМ без участі людини за заздалегідь підготовленими алгоритмами, тобто алгоритм замінює людину.

    Для 2-го класу задач характерні слабко структуровані процедури вироблення рішень в умовах неповної інформації. До цього класу належать задачі потокового й оперативно-календарного планування виробництва й управління запасами.

    Задачі 3-го класу потребують застосування неструктурованих процедур вироблення рішень, творчого підходу, що ґрунтується на інформованості, класифікації, таланті та інтуїції людини.

    Працівників організаційного управління можна поділити на три групи: керівники (директори, головні адміністратори), спеціалісти (начальники функціональних служб, головні спеціалісти), технічні працівники (секретарки, касири, комірники). Керівники вирішують, як правило, задачі 3-го класу, рідко — 1-го. Спеціалісти розв'язують задачі 2-го класу, технічні працівники — 1-го. Згідно з характером розв'язуваних задач можна виділити три класи типових АРМ: АРМ керівника (АРМ-К), АРМ спеціаліста (АРМ-С), АРМ технічного та допоміжного персоналу (АРМ-Т).

    АРМ-К може мати розподільну та локальну структуру. При розподільній структурі дисплей установлюється на столі керівника, а основна функціональна структура (з додатковим дисплеєм) — у секретаря або помічника. Локальна структура АРМ-К передбачає повну функціональну замкненість, яка забезпечує автономну роботу.

    Вимоги до АРМ-К:

    · наявність достатньо розвиненої бази даних, постійно доповнюваних оперативною інформацією;

    · забезпечення керівника або його помічників оперативністю пошуку необхідної інформації в базі даних і наочністю подання інформації у формі, адаптованій до психологічних характеристик людини (за умови високого рівня її інтеграції на екрані незалежно від джерела даних);

    · наявність діалогових програмних засобів, що забезпечують прийняття рішень з максимальною адаптацією і регулюють організаційно-адміністративну діяльність;

    · забезпечення оперативного зв'язку з іншими джерелами інформації (у межах організаційної структури) та з безпосередніми помічниками;

    · забезпечення можливості нагромадження в пам'яті АРМ досвіду роботи і раніше прийнятих рішень.

    З урахуванням характеру й особливостей праці керівника програмне забезпечення АРМ-К містить підсистеми забезпечення та ділової діяльності (ПЗДД), прийняття рішень (ПЗПР), рутинних робіт (ПЗРР), комунікацій (ПЗК).

    Одна з головних — підсистема ПЗДД, оскільки 47 % робочого часу керівники перебувають у ділових контактах. До складу цієї підсистеми входити діловий пакет керівника. Головне меню пакета містить електронний записник, особистий архів, картотеку доручень. Модуль електронний записник, наприклад, містить електронний перекидний календар, куди керівник заносити щоденний особистий план (щоденник), щотижневий особистий план (щотижневик) з блоком найважливіших справ тижня й переліком найважливіших справ місяця.

    При створенні АРМ-С необхідно виходити із того, що спеціаліст — це професіонал у конкретній галузі, тому АРМ має бути таким, аби давати йому змогу проводити аналітичну роботу з документами (на це в середньому в спеціаліста витрачається 54 % робочого часу), використовуючи різноманітну інформацію.

    Його професійна орієнтація зумовлює вимоги до програмного і технічного забезпечення АРМ-С. Спеціалісту надається можливість працювати з персональною і центральною базами даних, вести комунікаційні діалоги з допоміжними джерелами інформації.

    Автоматизоване робоче місце спеціаліста містить системи забезпечення ділової та професійної діяльності, забезпечення рутинних робіт і підтримки комунікацій. Основа АРМ-С — підсистема забезпечення професійної діяльності. Вона, як правило, містить розвинену базу даних, засоби електронної обробки форм і ділової графіки, а також набір програмних засобів для проведення математичних розрахунків і моделювання.

    Набір пакетів для математичних розрахунків і моделювання, експертні системи і бази знань використовуються в АРМ-С для підтримки рішень формалізованих і неформалізованих задач.

    Автоматизовані робочі місця технічних працівників призначені для працівників, які виконують технічну роботу, що потребує певних професійних навичок. Для такої категорії службовців характерна робота з документами (68 % усього робочого часу) і телефонні переговори (20 % робочого часу). Основні їх функції — ввід інформації, оформлення документів (друк, тиражування, розсилання і т. ін.), ведення картотек і архівів, обробка вхідної та вихідної документації, контроль виконавчої діяльності. Ці роботи з високим ступенем ефективності можна автоматизувати, використовуючи різноманітні АРМ-Т на базі персональних ЕОМ.

    Характер діяльності технічних працівників мало залежить від специфіки галузі, установи, організації. Тому можливий масовий випуск типових АРМ-Т: АРМ оператора текстових документів, АРМ архіваріуса, АРМ комірника, АРМ інспектора, АРМ секретаря. Основні вимоги до програмних і технічних засобів АРМ-Т:

    - забезпечення максимальної ергономічності і «дружності» — зручне розміщення технічних засобів, висока якість візуальної інформації, клавіатура, що дає змогу швидко вводити інформацію,

    - простий діалог з підказками в разі хибних дій користувачів,

    - наявність технічних засобів для друкування і тиражування документів,

    - можливість ведення архіву.

    Подальший розвиток АРМ в організаційному управлінні пов'язаний з використанням робочих станцій управління (РСУ) замість ПЕОМ. В основу концепції РСУ покладено ідеї інтегрованого «інтелектуального» інтерфейсу користувача з маніпулюванням даними і широким доступом до розвинених обслуговуючих підсистем. Ці властивості РСУ дають змогу використовувати їх базу для. побудови персональних і групових АРМ. З погляду на те, що РСУ – універсальна система, необхідна певна функціональна спеціалізація цієї системи з трансформацією її в конкретне ділове автоматизоване робоче місце.

    Сервери баз даних – це спеціалізовані пристрої, призначені для зберігання великих об’ємів інформації та обслуговування запитів значної кількості користувачів.

    Базою даних (БД) називають форму представлення і організації даних, систематизованих так, щоб ці дані могли бути знайдені та оброблені комп’ютером. Дані збегігаються на сервері. Там же розміщується відповідне програмне забезпечення – система управління базами данних (СУБД). Користувачі на своїх АРМах формулюють запити, в яких вказують, яка інформація потрібна і в якій формі має бути подана. Запити є засобом вибірки даних з однієй або кількох таблиць БД. Сервер обробляє запит, формує вибірку даних і відправляє її на відповідний АРМ. З АРМів заноситься у БД і нова інформація. Подія, яка зумовлює або формування нового запису БД, або зміну чи вилучення наявного запису, називається транзакцією.

    У розподіленій БД збереження даних і управління ними здійснюються на кількох серверах. Розбиття даних може досягатися збереженням різних таблиць даних на різних серверах або різних фрагментів однієї таблиці на них. Для користувача не повиннго мати ніякого значення, в який спосіб дані розподілено між комп’ютерами.

    З метою уніфікації формування запитів створена мова структурованих запитів Structured Query Language (SQL). Запити, записані мовою SQL, розпізнаються усіма сучасними СУБД.

    3.8 Корпоративні обчислювальні мережі, Інтранет

    3.8.1 Глобальні мережі. Призначення і послуги глобальних мереж

    Глобальні мережі відрізняються від локальних як принципами роботи, так і термінологією.

    Глобальні мережі створюються великими телекомунікаційними компаніями для надання платних послуг абонентам. Такі мережі називають публічними. Прикладом є всесвітня глобальна мережа Інтернет. Іноді глобальну мережу створює яка-небудь велика корпорація для своїх власних проблем. У цьому випадку мережу називають корпоративною. Часто використовується проміжний варіант, коли корпоративна мережа користується послугами чи устаткуванням публічної мережі, але доповнює ці послуги чи устаткування своїми власними.

    Працездатність глобальної мережі підтримується оператором мережі, в надання платних послуг забезпечується провайдером.

    Основними видами послуг є електронна пошта та пересилання файлів, які можуть містити будь-яку інформацію: комп`ютерні дані, телефонні розмови, факси, телевізійне зображення.

    В автоматизованих системах керування глобальні мережі застосовують для пересилання як технологічної, так і управлінської інформації на значну відстань, коли застосування локальних мереж або технічно неможливе, або економічно недоцільне.

    3.8.2 Технології транспортування даних у глобальних мережах

    Х.25 – перша технологія, що з`явилась у 70-ті роки і розрахована на використання телефонних аналогових каналів;

    ISDN – цифрова мережа з інтегрованим обслуговуванням, призначена для передавання будь-яких типів даних;

    TCP/IP – нижні рівні мережі Інтернет, що використовуються як в локальних, так і в глобальних мережах.

    Стандарт Х.25 призначено для використання в глобальних телефонних мережах передавання даних у режимі комутації пакетів і є реалізацією трьох нижніх рівнів еталонної моделі OSI: фізичного, канального і мережевого.

    На фізичному рівні можуть бути використані будь-які універсальні або спеціалізовані інтерфейси. Окрім стандартних для будь-яких мереж компонентів DTE, DCE і DSE (див. п. 3.3.1) використовується компонент PAD (packet assembler/disassembler), який є специфічним пристроєм мережі X.25. PAD призначений для забезпечення взаємодії будь-яких неспеціалізованих терміналів з мережею, для перетворення потоку символів, який поступає від неспеціалізованого терміналу в пакети X.25 і виконання зворотного перетворення.

    З’єднання “точка-точка” між кінцевим устаткуванням даних у мережі Х.25 виконується за допомогою двонаправленого зв’язку, названого віртуальним каналом. Віртуальний канал дозволяє організувати постійний зв’язок між вузлами мережі через будь-яку кількість проміжних вузлів без закріплення фізичних ресурсів передавального середовища за цим каналом.

    На мережевому рівні стандарт Х.25 передбачає три режими:

    а) постійний віртуальний канал, аналогічний арендованій або виділеній телефонній лінії;

    б) комутований віртуальний канал, аналогічний телефонній лінії з набором номеру;

    в) виклик зі швидким вибором, використовуваний для обміну невеликим обсягом даних.

    ISDN є глобальною мережею, яка для забезпечення передачі даних використовує ті ж ідеї, принципи і апаратні рішення, які покладені в основу побудови сучасної телефонної мережі.

    Інформаційна взаємодія між компонентами мережі здійснюється на трьох рівнях, які функціонально відповідають фізичному, канальному і мережевому рівням моделі OSI.

    Інтерфейс ISDN надає користувачеві два канали, звані каналами типу В, з пропускною спроможністю 64 Кбіт/с. Для передачі команд управління і канальної сигналізації використовується окремий канал типа D, який має пропускну спроможність 16 Кбіт/с.

    Інформаційна взаємодія на фізичному рівні інтерфейсу ISDN здійснюється по чотирьохпроводній лінії за допомогою обміну інформаційними блоками (кадрами фізичного рівня). Кадр складається з 48 бітів і передається з частотою 4 кГц (період повторення 250 мс). До складу кадрів входять 32 біти (4 байти) даних, які передаються в B-каналах, і чотири біта канальної сигналізації, які передаються D-каналом.

    Управління процесами передачі даних по B-каналах мережі ISDN здійснюється шляхом встановлення викликів. Команди, які управляють організацією виклику, передаються по каналах D. Для того, щоб забезпечити передачу інформації виклику конкретному користувачеві з групи, ця інформація передається на двох рівнях моделі OSI: на канальному рівні і мережевому рівні.

    Для передачі керуючої інформації на канальному рівні використовується протокол LAPD (Link Access Procedure D-channel). Він передбачає формування кадрів наступних типів:

    Інформаційні кадри (I-кадри) призначені для безпосередньої передачі повідомлень наступного - мережевого рівня ISDN.

    Керуючі кадри (S-кадри) призначені для управління процесом передачі I-кадрів і для вирішення проблем, які пов'язані з втратами кадрів в процесі передачі.

    Ненумеровані кадри (U-кадри) призначені для встановлення і розривання логічного з'єднання, узгодження параметрів лінії і формування сигналів про виникнення неусувних помилок в процесі передачі даних I-кадрами.

    Блоки даних мережевого рівня - пакети ISDN - призначені для безпосередньої передачі інформації сигналізації. Повідомлення мережевого рівня ISDN складається з двох основних частин - загальної частини і специфічної частини.

    Загальна частина повідомлення призначена для визначення типу протоколу, який використовується для управління викликами. У загальній частині є також номер, який привласнюється кожному виклику для того, щоб забезпечити можливість використання каналу D для одночасного управління декількома викликами.

    Специфічна частина пакету ISDN є полем змінної довжини. Інформація, яка розміщується в даній частині відповідного пакету ISDN, використовується для визначення конкретних параметрів процедури управління викликом. Зокрема в специфічній частині пакету, який призначений для створення виклику, розміщуються поля ознак швидкості передачі даних для запрошуваного виклику і адреси абонентів, що викликаються і викликають.

    Треба відмітити, що найбільшого поширення знайшли мережі не за протоколом Х.25 чи ISDN, а за протоколами Інтернет, оскільки:

    а) вони однаково добре працюють як у глобальних, так і локальних мережах;

    б) їх не орієнтовано на конкретну комп’ютерну платформу чи операційну систему;

    в) для них стандартизовані протоколи всіх рівнів еталонної моделі.

    3.8.3 Мережа Інтернет

    Мережа Інтернет децентралізована. Не існує центрального органу, який керує мережею. Однак усі, хто під’єднуються до Інтернет, повинні дотримуватись певних стандартів. Ці стандарти затверджуються кількома добровільними організаціями. Наприклад, Рада з архітектури IAB розглядає і затверджує протоколи передачі і стандарти адресації.

    Доступ до Інтернет можна отримати, встановивши з’єднання з провайдером послуг Інтернет. Провайдер виступає посередником, забезпечуючи під’єднання користувачів до Інтернет через маршрутизатор. Маршрутизатори – це пристрої, що виконують свої функції на мережевому рівні еталонної моделі, тобто передають пакети між мережами. Вони вибирають за визначеним алгоритмом маршрут проходження переданих через неих пакетів.

    Існує декілька варіантів під’єднання до Інтернет:

    а) електронна пошта (Email) є найпоширенійшею формою застосування Інтернет; вона не надає інших можливостей, крім обміну електронними листами між користувачами;

    б) доменний доступ для організацій, які використовують Інтернет як для одержання загальної інформації, так і для проведення інтерактивних конференцій і досліджень;

    в) клієнтський доступ, який використовується для запуску на робочих станціях спеціальних Інтернет-додатків, наприклад, для торгівлі акціями у режимі реального часу.

    Зв’язок користувача з провайдером можливий за допомогою звичайної телефонної мережі через АТС (комутований доступ – dial-up) або за допомогою спеціальної лінії зв’язку (через виділені лінії – leased line).

    Інтернет використовує сімейство протоколів TCP/IP. Протоколи TCP/IP відносяться до транспортного рівня і не залежать від протоколів інших рівнів. Інформація, що передається, розбивається на пакети – невеликі порції даних. Пакети пересилаються незалежно один від одного, а в пункті приймання збираються в потрібній послідовності. Такий принцип називається дейтаграмним, а порція даних – дейтаграмою. Розмір дейтаграми не перевищує 1500 символів.

    Дейтаграма складається з двох частин:

  • Заголовок дейтаграми (Datagram Header)
  • Поле даних дейтаграми (Datagram Data Area)

    • Інформація користувача розміщується в полі даних дейтаграми. У це поле можуть бути поміщені зокрема блоки даних протоколів верхніх рівнів. У заголовку дейтаграми розміщується інформація, яка необхідна для того, щоб доставити вміст корисного навантаження в необхідний вузол призначення мережі.

    Для перевірки правильності передачі даних використовується контрольна сума – число, що обчислюється для всіх символів за спеціальним алгоритмом і вставліється у заголовок дейтаграми. Заголовок також містить номер дейтаграми. Формує заголовок протокол TCP, після чого дейтаграма обробляється протоколом ІР, який додає до дейтаграми адресний заголовок, що включає в себе адреси відправника і одержувача інформації.

    Далі використовується протокол РРР (Point-to-Point), який розміщує дейтаграму в кадр даних і відправляє у мережу.

    Поки кадр даних подорожує у Інтернеті, він проходить кілька ІР-маршрутизаторів. Кожен маршрутизатор читає адресу і вибирає наступний маршрутизатор. Різні кадри можуть проходити через різні маршрутизатори.

    Адреса складається з чотирьох чисел в інтервалі від 1 до 254, розділених крапками, наприклад, 10.4.89.102. Ці числа називаються октетами, бо для іх представлення використовують 8 двійкових розрядів. Октети послідовно деталізують адресу від мережі вищого рівня до підмережі нижчого рівня. Останній октет характеризує конкретний сервер або робочу станцію.

    Октети 0 та 255 зарезервовані. Число 255 використовується для спрямування дейтаграми усім комп’ютерам мережі чи підмережі. Число 0 використовується для спеціального зазначення підадреси. Наприклад, для вищенаведеної адреси підадреса 10.4.89.0 позначає підмережу, а 0.0.0.102 – тільки один вузол мережі.

    Для кращого запам’ятовування адрес застосовується система доменних імен DNS (Domen Name System). Домен – це група комп’ютерів, до якої можна звертатись за допомогою унікального ідентифікаційного імені, що складається з серії символів, розділених крапками, наприклад, usuce.dp.ua. Права частина імені домену –найбільший домен, до якого належить конкретна адреса. В нашому випадку домен ua означає, що ця адреса належить Україні. Піддомен dp означає Дніпропетровську область, а піддомен usuce – УДХТУ.

    Між доменним іменем і ІР-адресою є однозначний зв’язок. Бази даних імен доменів і відповідні їм ІР-адреси зберігаються на серверах імен.

    Для зв'язку з Інтернет використовується спеціальна програма – браузер. Найбільш популярними браузерами є ІЕ та Netscape Navigator.

    Для того, щоб з допомогою браузера звернутись до сервера, що має певну ІР-адресу, треба ввести повне доменне ім’я цього сервера. Наприклад, щоб зв’язатись з УДХТУ, треба ввести у відповідне вікно браузера текст:

    http://usuce.dp.ua

    В цьому разі браузер буде виконувати протокол передачі гіпертексту HTTP, який забезпечує передачу на комп’ютер користувача текстів, графічних зображень та звуку і формує на екрані так звану WEB-сторінку. Комплект WEB-сторінок, що належить якомусь власникові, називається сайтом.

    Інтернет-портал (від англ. portal "головний вхід; ворота")- веб-сайт, що надає користувачу можливість подальшого отримання інформації з інших сайтів, іншими словами, що містить велику кількість зовнішніх (тобто таких, що ведуть на інші ресурси) посилань. Як правило, портали також надають користувачеві ряд додаткових можливостей по вибору і структуризації інформації, що відповідає його інтересам.

    Існують також сервери, призначені для зберігання файлів різноманітних даних і програм. Вони називаються FTP-серверами. Для отримання таких файлів браузер використовує FTP-протокол (File Transfer Protocol). Ознаку цього треба вказувати перед доменним ім’ям, наприклад:

    ftp://trifle.net

    Запис, що включає тип протоколу і доменне ім’я називають універсальним локатором ресурсу URL.

    Для обміну електронними листами існують поштові сервери. Кожний абонент електронної пошти має унікальну адресу, що складається з імені абонента та доменного імені, розділених знаком @. Наприклад, Ви можете писати мені на електронну адресу

    bsoft@a-teleport.com

    Отримавши листа з подібною адресою, поштовий сервер визначає ІР-адресу одержувача і пересилає лист. При цьому використовується простий протокол передачі пошти (Simple Mail Transfer Protocol – SMTP). До листів можна приєднувати будь-які файли даних. Протоколи TCP/IP розраховані на пересилання символьних даних. Якщо до листа приєднуються не текстові файли, то перед пересиланням двійкові дані перетворюються у символи формату ASCII за допомогою багатоцільового розширення Інтернет-пошти (Multipurpose Internet Mail Extention – MIME).

    Якщо поштові скриньки користувачів зберігаються на сервері провайдера, то для такого віддаленого доступу до еклектронної пошти використовується протокол РОР3 (Post Office Protocol v.3).

    3.8.4 Intranet

    Intranet – це корпоративна мережа, що використовує технології Інтернет для обміну інформацією.

    З технічної точки зору интранет - це внутрішній корпоративний web-портал , покликаний вирішувати задачі конкретної компанії; завдання, в першу чергу, по систематизації, зберіганню і обробці внутрішньокорпоративної інформації. Интранет- сайт , доступний тільки в рамках локальної мережі Компанії включаючи видалені філіали (intranet) або як портал в мережі Інтернет, що невидимий в пошукових системах і вимагає авторизації при вході (extranet). Доступ до сторінок порталу здійснюється через web-браузер , що дозволяє користуватися послугами интранет-систем людям з мінімальною комп'ютерною підготовкою. Оновлення інформації здійснюється відповідальними співробітниками за допомогою спеціальних інтерфейсів, робота з якими практично ідентична роботі з офісними програмами.

    В мережах Intranet або взагалі нема підключення до Інтернет, або це підключення контрольоване з доступом обмеженого кола користувачів. В Intranet використовуються стандартні для Інтернет служби і протоколи HTML, TCP/IP, SMTP, FTP, система доменних імен і браузери. Intranet-технології забезпечують зв’язок електронною поштою, проведення телеконференцій, збирання, збереження і відновлення інформації з мінімальними витратами на керування мережею і високим рівнем захисту від несанкціонованого доступу.

    В Intranet використовуються набори форм, звані сторінками, які є аналогом web-сторінок . Це текстові файли, що містять інструкції для збирання і збереження інформації в різних форматах – текстовому, графічному чи звуковому. Браузери робочих станцій звертаються до серверів, одержують і відображають ці сторінки відповідно до інструкцій, що записані в тексті сторінок за допомогою мови формування гіпертексту HTML .

    Для пошуку необхідної сторінки застосовується пошукова машина. Це спеціальна програма, яка має базу даних про всі сторінки на всіх серверах корпоративної мережі. Пошук проводиться за допомогою ключових слів. В результаті пошуку на екран користувача виводиться перелік посилань на сторінки, які містять введені користувачем ключові слова.

    Крім того, у корпоративних мережах використовують і інше специфічне програмне забезпечення.

  • Програми класу брандмауер (firewall) призначені для захисту корпоративної мережі або робочої станції від зовнішніх атак, вірусів, просочування конфіденційної інформації, а також для контролю роботи додатків.
  • Проксі-сервер дає можливість організувати централізований вихід в Інтернет з робочих станцій локальної мережі, а також прискорити з'єднання і зменшити трафік кешуванням запитаних web-сторінок.

    • Ключовим словом при описі intranet-систем є слово "єдиний":

  • єдиний спосіб обробки, зберігання, доступу до інформації,
  • єдине уніфіковане середовище роботи,
  • єдиний формат документів.

    • Такий підхід дає співробітникам можливість найефективніше використовувати накопичені корпоративні знання, оперативно реагувати на події, що відбуваються, а підприємству в цілому надає нові можливості організації свого бізнесу.

    Завдання, що вирішуються за допомогою интранет-систем:

  • централізоване зберігання загальнокорпоративної інформації і організація оперативного доступу до неї;
  • організація авторизованого доступу до службової документації компанії;
  • своєчасне сповіщення співробітників про події усередині компанії;
  • оперативний доступ до інформації про структурні підрозділи компанії і персонал;
  • стимулювання ділового спілкування між співробітниками;
  • організація "зворотного зв'язку" між підрозділами компанії і керівництвом;
  • централізація і автоматизація типових службових завдань;
  • підвищення загальної інформаційної прозорості усередині компанії;

    • Типова структура интранет-порталу припускає наявність наступних розділів.

    1. Інформація про компанію

      2. Реквізити, схеми проходу/проїзду до офісів, організаційна структура компанії, статут, місія компанії, корпоративний стиль, посадові інструкції і т.д.
    2. Інформація про співробітників

      3. Довідник по співробітниках (телефони, e-mail адреси, ICQ, підрозділ і посада, фотографії), особисті сторінки співробітників, дошка шани
    3. Оперативна інформація

      4. Оголошення, накази і розпорядження, обов'язкові заходи (планерки, збори і т.д.), стягнення і подяки за наслідками звітного періоду, інформаційні огляди, зовнішні і внутрішні курси валют, погода і т.д.
    4. Корпоративна база знань

      5. Стандартні документи і шаблони, внутрішньокорпоративна довідкова інформація (каталог продукції і прайс-листи, повчальні матеріали), файловий архів (робоча інформація, дистрибутиви програм, музика) і т.д.
    5. Сервісні механізми

      6. Заявки в служби на закупівля товарів (витратні матеріали, оргтехніка, канцелярія), заявки на виконання робіт,

    3.8.5 Використання Інтернет у КІСУ

    Інтернет дозволяє організувати диспетчеризацію практично будь-яких об'єктів незалежно від місця їх розташування. Диспетчерський пункт для роботи з одним або декількома територіально розосередженими об'єктами може знаходитися в будь-якому місці, де є доступ в Інтернет.

    Використовують наступні способи підключення приладів до Інтернет.

  • Виділена лінія через модем . Володіє високою швидкістю передачі даних і дозволяє одночасно підключити декілька пристроїв через маршрутизатор (роутер).
  • Телефонна лінія через DSL-модем. ТехнологіяDSL DSL (Digital Subscriber Line цифрова абонентська лінія) забезпечує високошвидкісне підключення Весь діапазон передаваних по лінії частот ділиться на три частини. "Голосові" частоти (від 0 до 4 кГц) використовуються виключно для телефонних розмов. Частоти від 25 до 160 кГц, використовуються для передачі даних від користувача до провайдера. Діапазону від 240 кГц до 1,5 Мгц несе інформацію у зворотний бік. Телефонна лінія залишається вільною для розмов. Багато моделей DSL-модемів мають вбудований маршрутизатор (роутер), що дає можливість підключення до Інтернет відразу декількох пристроїв.
  • Стільниковий зв'язок через GSM-модем. GSM (Global System for Mobile Communications) - глобальний цифровий стандарт для мобільного стільникового зв'язку, з розділенням каналу за часом і високим ступенем безпеки. GSM-модем - це пасивний приймач-передавач, що використовує мережі операторів мобільною зв'язку GSM для передачі/прийому інформації. GSM-модеми можуть бути легко інтегровані в різне телеметричне, диспечерське, охоронне і ін. устаткування.
  • Мережа стільникового зв'язку GPRS через стільниковий модем. Доступність зв'язку практично по всій території країни (Білайн, Мегафон, МТС). Зміна оператора стільникового зв'язку шляхом заміни SIM-карти в модемі. Деякі моделі стільникових модемів мають вбудований маршрутизатор (роутер), що дає можливість підключення до Інтернет відразу декількох пристроїв. Рекомендовані моделі модемів: MT232 GPRS TCP/IP, WAVEWCOM 1206(1306), SIEMENS MC35i.

    • GPRS (General Packet Radio Service) - це своєрідна надбудова над звичайною GSM-мережею, яка дозволяє передавати дані на істотно вищих, ніж в звичайній GSM мережі (максимум 14,4 Кбіт/с), швидкостях - теоретичний максимум в GPRS складає 171.2 Кбіт/с. GPRS - це пакетна система передачі даних, що функціонує аналогічно Internet: потік даних відправника розбивається на окремі пакети і потім доставляється одержувачеві, де всі пакети збираються воєдино.

  • Мережа стільникового зв'язку CDMA через стільниковий модем.

    CDMA (англ. Code Division Multiple Access) - множинний доступ з кодовим розділенням. Канали трафіку при такому способі розділення середовища передачі створюються привласненням кожному користувачеві окремого числового коду, який "розпорошується" по всій ширині смуги частот каналу. Отже, всі абоненти одночасно використовують всю ширину каналу. Смуга частот каналу дуже широка, віщання абонентів накладається одне на одне, але, оскільки їхні коди відрізняються, вони можуть бути диференційовані на приймальній стороні. Технологія CDMA вимагає точної синхронізації роботи передавача і приймача.

    CDMA - зона обхвату мережі SkyLink. Рекомендована модель модему: CDMA PCT-24.1.

    Стільниковий зв'язок дає додаткові можливості розширення функцій управління, наприклад, SMS-диспетчеризацію через GSM-модем. Вона передбачає:

  • Сповіщення у разі виникнення тривожної ситуації на об'єкті за ініціативою контролера.
  • Відповідь за SMS-запит користувача з інформацією про значення параметрів і стан відмов.

    • Обмін даними за допомогою SMS-повідомлень раціонально застосовувати тоді, коли потрібно передавати обмежене число параметрів (як правило, число каналів в системі автоматизації не більше 10-12). В цьому випадку, пакет даних, що містить інформацію про значення атрибутів каналів, цілком вміщається в ліміт SMS-повідомлення - 160 символів. Сам механізм обміну в цьому режимі обміну даними нічим не відрізняється від звичайного - на запит (SMS-повідомлення) головної (Master) або підлеглої системи (Slave), формується відповідь, що містить запрошувану інформацію, і відправляється за допомогою такого ж SMS-повідомлення. Час зв'язку (від початку передачі SMS-запиту до приходу SMS-пакету із запитаними даними) сильно залежить від можливостей і завантаженості оператора зв'язку і варіюється від 5 до 20-25 з. (у робочі дні, і до 1-2 діб в святкові дні).

    Режим прямого з'єднання нічим не відрізняється від звичайної комутованої лінії, використовуваної в традиційних телефонних мережах, крім того GSM-мережі дозволяють передавати дані з швидкістю до 9600 бод. В цьому випадку зв'язок між двома вузлами не уривається до тих пір, поки не будуть передані всі запрошувані дані. Цей режим, в порівнянні з SMS-повідомленнями має ряд особливостей:

  • Передача теоретично будь-якого об'єму інформації за одне з'єднання;
  • Вища швидкість передачі інформації (до 115 кБіт/с);
  • Володіє властивістю всіх комутованих ліній обривати зв'язок при збоях;
  • Встановлення зв'язку між вузлами займає якийсь час і складає 5-10 с.

    • Прикладом використання Интернет може служити система диспетчеризації для програмно-технічного комплексу (ПТК) КОНТАР. Дане програмне забезпечення не розповсюджується серед користувачів, а встановлено на сервері розробника комплексу, виведено в мережу Інтернет і надано в загальне користування. Кожному користувачеві ПТК КОНТАР може бути виділений доступ в систему (ім'я користувача і пароль) для створення власного проекту диспетчеризації. Для роботи з системою ніяких спеціальних програм не потрібні, достатньо стандартного Интернет-браузера, наприклад, Internet Explorer, що входить до складу Windows. Користувач може працювати з своїм проектом, ніяк не впливаючи на роботу інших користувачів. Доступ до системи може бути здійснений з будь-якого комп'ютера, підключеного до мережі Інтернет.

    Дана система ідеально підходить для диспетчеризації видалених необслуговуваних об'єктів, наприклад, модульних котельних, невеликих магазинів і ресторанів, заправних станцій і т.п. в умовах, коли недоцільно організовувати окрему диспетчерську службу або відсутня необхідність безперервного спостереження за значеннями параметрів на об'єктах. В цьому випадку диспетчерським комп'ютером може стати будь-який комп'ютер, підключений до мережі Інтернет. При цьому слід мати на увазі, що система не призначена для безперервного цілодобового спостереження за об'єктами.

    У NASA була розроблена web-технологія Tempest, що перетворює вбудований мікропроцесор на відкритий web-сайт. Технологія Tempest - це проста в установці, повністю документована комерційної якості технологія, яка може підтримувати нескладні графічні інтерфейси.

    3.9 Традиційна диспетчеризація і системи SCADA

    У традиційних системах диспетчеризації перед оператором установлювали великий щит із мнемосхемою технологічного процесу (рис. 3.18, а).

    Рис. 3.18 – Системи диспетчеризації: а – традиційна; б – SCADA

    Стан кожної одиниці устаткування відображався світловими індикаторами, що вмикались у відповідності зі значеннями сигналів від датчиків на об'єкті. Аналізуючи по індикаторах та вторинних приладах роботу устаткування, диспетчер подавав команди на виконавчі пристрої об'єкта.

    Створення диспетчерського пульта і пристроїв зв'язку з датчиками для кожного процесу, необхідність спеціального підбора і навчання диспетчерів вимагали великих витрат.

    З'явилася ідея узагальнити інформацію про стан об'єкта і показати її на мнемосхемі технологічного процесу, намальованої на екрані персонального комп'ютера диспетчера (рис. 3.15, б). Сигнали датчиків відображаються у вигляді зміни зображень на такій комп'ютерній мнемосхемі процесу. В комп’ютері ці сигнали узагальнюють, архівують і оцінюють з позиції ефективності керування виробництвом.

    Так з'явилися і почали швидко розвиватися системи диспетчерського керування і збору даних SCADA (Supervisory Control And Data Acquisition). Крім простого відображення технологічного процесу в SCADA-системах стало можливим деталізувати дані про роботу будь-якої ділянки процесу, оцінювати собівартість продукції, попереджати розвиток аварійних ситуацій, перепрограмувати віддалені пристрої керування, контролювати дії диспетчера, порівнювати поточні і минулі показники процесу.

    Система SCADA містить три компоненти (рис. 3.16):

    - віддалені термінали RTU (Remote Terminal Units) – датчики стану устаткування, виконавчі пристрої і ПЛК, що забезпечують керування устаткуванням у реальному часі;

    - головний термінал MTU (Master Terminal Unit) чи диспетчерський пункт керування, що здійснює обробку даних про процес для диспетчера і перетворення команд диспетчера в сигнали керування об'єктом;

    - комунікаційна система CS (Communication System) – канал зв'язку головного і віддалених терміналів.

    Рис. 3.19 – Склад системи SCADA

    Функції системи SCADA полягають у наступному:

    а) збирання поточної інформації про роботу устаткування з датчиків і контролерів;

    б) первинне перетворення зібраної інформації;

    в) збереження поточної інформації;

    г) представлення поточної та збереденої інформації у вигляді таблиць, графіків і т.п.

    д) друк звітів і протоколів про роботу устаткування;

    е) передача і введення в пристрої керування команд оператора;

    ж) використання поточної інформації для вирішення виробничих задач;

    з) організація зв'язку з пристроями, підключеними до інформаційної мережі.

    Особливо ефективне застосування систем SCADA для виробництв, у яких:

    - технологічні процеси повинні контролюватися людиною;

    - неправильний вплив на об'єкт може привести до катастрофічних наслідків;

    - навіть у нормальних умовах іноді потрібно коректувати керування устаткуванням;

    - оператор несе відповідальність за хід виробництва, але його втручання в процес відбувається рідко, за винятком непередбачених ситуацій;

    - у непередбачених ситуаціях час прийняття рішень оператором обмежений секундами і хвилинами.

    Перевагою SCADA-систем є те, що вони забезпечують:

    а) наочну інформацію про хід виробництва;

    б) відображення стану технологічного устаткування;

    в) деталізацію обраних диспетчером частин процесу;

    г) розрахунок показників процесу в динаміці і виведення узагальненої інформації у вигляді графіків, таблиць і малюнків;

    д) розпізнавання аварійних і передаварійних ситуацій з формуванням відповідних підказок для дій диспетчера;

    е) створення архіву поводження процесу в часі, аварій та інших подій.


1 Комп'ютерно-інтегроване управління в сучасних АСУ

4 Принципи функціонування комп’ютерно-інтегрованих систем управління (КІСУ)

4.1 Функції та режими роботи КІСУ

Згадаємо деякі визначення.

Автоматизована система (АС) – це система, що складається з персоналу та комплексу засобів автоматизації його діяльності і така, що реалізує інформаційну технологію виконання встановлених функцій.

Функція автоматизованої системи – сукупність дій АС, яка направлена на досягнення певної цілі.

Кожна функція АС реалізується сукупністю комплексів задач, окремих задач та операцій.

Задача автоматизованої системи – функція чи частина функції АС, що являє собою формалізовану сукупність автоматизованих дій, виконання яких приводить до результату заданого виду.

Функції АС об‘єднуються у підсистеми за функціональними та іншими ознаками, наприклад, інформаційно-вимірювальна підсистема, керуюча підсистема, підсистема діагностування.

АСК ТП виконує функції керування, інформаційні та допоміжні функції.

Функція керування – це функція АСК ТП, яка включає отримання інформації про стан технологічного об‘єкта керування, оцінку інформації, вибір керуючих дій та їх реалізацію.

Інформаційна функція – це функція АСК ТП, яка включає отримання інформації, її обробку і передачу персоналу для інформування про стан технологічного об‘єкта керування або зовнішнього середовища.

Допоміжна функція – це функція АСК ТП, яка включає збирання та обробку даних про стан АСУ ТП і або представлення цієї інформації персоналу, або здійснення керуючих дій на технічні та програмні засоби АСК ТП.

АСК ТП може функціонувати у трьох режимах.

Автоматизований режим виконання функції АСК ТП – це режим виконання функції АСК, за якого вона виконується автоматично, а людина спостерігає за перебігом технологічного процесу, будучи готовою втрутитись, якщо виникне така необхідність.

Діалоговий режим виконання функції АСК ТП – це режим, за якого людина управляє розв‘язанням задач функції, змінюючи її умови і алгоритм функціонування АСК на основі оцінки інформації, яка надається технічними засобами АСК.

Неавтоматизований режим виконання функції АСК ТП – це режим виконання функції АСК, за якого вона виконується тільки людиною.

Крім режимів виконання функцій розрізняють також різні режими керування.

4.1.1 Пуск ТП являє собою сукупність неавтоматизованих, або з певним рівнем автоматизації операцій, що виконуються персоналом як на місці, так і дистанційно з АРМ оператора. Контроль технологічних параметрів проводиться персоналом по приладах, встановлених «за місцем», а також з екрану АРМ. В процесі пуску канали керування можуть бути переведені як в режим «місцевого» керування, так і в режим «автоматизованого» керування. Дії персоналу в процесі пуску визначаються технологічним регламентом.

4.1.2 Функціонування у перехідному режимі є пов‘язаним зі зміною яких-небудь параметрів функціонування ТП (наприклад, зміна продуктивності або параметрів сировини). В перехідному режимі оператор або керуючий обчислювальний пристрій змінюють у відповідності з технологічним регламентом завдання контурам регулювання.

4.1.3 Функцонування у сталому режимі, у якому система здійснює автоматичне підтримання контрольованих параметрів в заданих межах. Головні задачі системи складаються збиранні та первинній обробці інформації, виробленні керуючих впливів та діагностуванні стану комплексу технічних засобів системи.

У сталому режимі персоналом можуть проводитись окремі операції, що не впливають на режим функціонування ТП (наприклад, переключення резервних комплектів устаткування).

4.1.4 Зупинення ТП у відповідності з технологічним регламентом виконується як в режимі автоматизованого, так і в режимі ручного керування. В процесі зупинення оператор здійснює припинення подачі сировини і відбору продуктів ТП.

4.1.5 Аварійне зупинення в автоматичному режимі проводиться при виникненні однієї або сукупності аварійних ситуацій.

При виникненні аварійної ситуації система видає звуковий та відеосигнал, на екран монітора виводиться пропозиція оператору задіяти процедуру автоматичного зупинення ТП, яка при відсутності реакції з боку оператора буде виконана автоматично через визначений час.

Під час очікування системою реакції оператора на аварійну ситуацію, а також в процесі автоматичного зупинення ТП, оператор може відмовитись від автоматичного зупинення ТП і виконати необхідні дії в діалоговому або неавтоматизованому режимах.

4.1.6 Аварійне ручне керування призначене для приведення ТП в безпечний стан у випадках відмови АСК ТП.

При переході в режим аварійного ручного керування контролери повністю від‘єднуються від каналів керування, задіються пульти місцевого і дистанційного керування, з яких і проводиться керування ТП в наступних випадках:

  • вимкнення живлення керуючого обчислювального пристрою;
  • відмова контроллера або АРМ оператора;
  • натиснення оператором спеціальної кнопки на пульті дистанційного керування.

    • При функціонуванні системи в режимі аварійного ручного керування не функціонують технологічні захисти і блокування, безпечність процесу визначається тільки діями оператора.

    4.2 Функція збирання та первинної обробки інформації

    4.2.1 Загальні відомості

    Функція збирання та первинної обробки інформації відноситься до інформаційних функцій. У комп’ютерно-інтегрованих системах вона реалізується в основному на нижньому рівні управління за допомогою програмованих контролерів або комп’ютерів, оснащених спеціальними модулями введення-виведення технологічних сигналів. Частково може бути реалізована і на верхніх рівнях управління, зокрема, за допомогою комп’ютерного обладнання цехових та заводських лабораторій.

    До задач цієї функції відносяться:

    а) введення аналогових сигналів від датчиків і первинних перетворювачів;

    б) введення дискретних сигналів реле і датчиків стану основного устаткування;

    в) контроль вірогідності введених аналогових та дискретних сигналів;

    г) нормалізація і фільтрація значень введених аналогових сигналів;

    д) математична обробка нормалізованих значень сигналів;

    е) контроль значень введених та розрахованих параметрів і показників на технологічні й аварійні допуски.

    Технологічні допуски - граничні значення технологічних параметрів, які допускаються технологічним регламентом процесу, що автоматизується. Аварійні допуски - граничні значення, при виході за які можлива аварійна ситуація. Взаємне розміщення технологічних і аварійних допусків на осі значень технологічного параметру Х ілюструється рис. 4.1.

    Допуски
    Рис. 4.1

    Для розв’язування перелічених задач використовується спеціальне програмне забезпечення. Це може бути стандарне програмне забезпечення SCADA-системи, наприклад, російське Trace Mode, українське “Контур”, американське GENESIS 32, або програми, що розробляються проектувальниками конкретних систем за стандартними або оригінальними алгоритмами.

    Розглянемо приклади стандарних алгоритмів, орієнтованих на реалізацію за допомогою програмованих контролерів.

    4.2.2 Загальний алгоритм функціонування контролера

    У загальному алгоритмі передбачають наступні робочі цикли:

    - початкового пуску;

    - включеного стану системи;

    - відключеного стану системи.

    Окремими випадками включеного і відключеного стану системи є відповідно цикл включення і цикл відключення.

    У циклі початкового пуску здійснюється установлення початкових значень необхідних констант і програмних прапорів-ознак, перелік і значення яких визначаються при програмуванні контролера.

    У циклі включеного стану системи проводяться запис у внутрімашинні масиви даних значень вхідних сигналів, їх обробка, розрахунок вихідних даних, реалізація локальних контурів регулювання, аналіз аварійних ситуацій і формування тривожних сигналізацій.

    В циклі відключення системи здійснюється формування даних для виведення керуючих сигналів, що відповідають виключеному стану системи. Наприклад, при вимиканні системи повинні бути сформовані такі значення вихідних сигналів, при яких загальмовуються виконавчі механізми.

    4.2.3 Алгоритм запису у внутрімашинні масиви даних уведених значень вхідних дискретних сигналів

    Призначення задачі, розв'язуваної алгоритмом:

    а) фільтрація сигналів методом подавлення «брязкотіння контакту»;

    б) запам'ятовування значень сигналів;

    в) контроль зміни значення сигналу.

    Фільтрація j-того дискретного сигналу DIj полягає в тому, що результат визнається правдивим, якщо хоча б два з підряд уведених трьох значень сигналу є незмінними.

    На початку алгоритму (рис. 4.2) перевіряється стан прапора-ознаки циклу включення FVKL. В циклі включення системи для кожного j-того сигналу здійснюється:

    а) ініціалізаційне (первинне) запам'ятовування значення введеного значення сигналу DIj у трьох комірках пам’яті, призначених для зберіганні трьох послідовних значень сигналу (блок D1);

    б) ініціалізаційне запам'ятовування введеного значення сигналу DIj у комірці пам’яті, призначеній для зберігання істинного значення сигналу IST(j) (блок Е1);

    в) ініціалізаційне запам'ятовування параметра IST(j) як змінної PBI(j) для контролю зміни сигналу у наступних циклах (блок Е1);

    г) ініціалізаційне установлення прапора-ознаки зміни j-того сигналу FIZM(j) (блок Е1).

    В усіх робочих циклах, що відповідають включеному стану системи, за винятком циклу включення здійснюється:

    а) запам'ятовування трьох підряд уведених значень j-того сигналу (блок В3);

    б) фільтрація j-того сигналу (блоки С3, D3, Е3, F3);

    в) формування ознаки зміни j-того сигналу (блоки D4, Е4, F4);

    г) запам'ятовування відфільтрованого значення сигналу IST(j) (блок A5).

    Рис. 4.2

    Зміна сигналу ідентифікується аналізом нового результату фільтрації IST(j) і раніше запам'ятованого значення BPI(j). Якщо вони не рівні, то мала місце зміна j-того сигналу і в цьому випадку установлюється відповідний прапор-ознака FIZM(j).

    4.2.4 Алгоритми контролю вірогідності введених аналогових сигналів

    Контроль здійснюється для кожного введеного значення вхідного аналогового сигналу.

    Контроль вірогідності введеного значення вхідного аналогового сигналу містить у собі :

    а) контроль на апаратні уставки (рис. 4.3, а);

    б) контроль на припустимий тренд (рис. 4.3, б).

    Рис. 4.3

    Апаратні уставки – граничні допуски, при виході значення вхідного аналогового сигналу AIj за які можна констатувати невірогідність сигналу. Значення апаратних уставок сигналів задаються при програмуванні.

    Контроль на апаратні уставки здійснюється для того сигналу, для якого задані відповідними прапорами-ознаками контроль сигналу взагалі (блок B2) і його контроль на апаратні уставки (блок C2).

    Умови виходу за апаратні уставки :

    - істина AIj > AIj max (блок D2);

    - істина AIj < AIj min (блок E2).

    При виході за апаратні уставки формується одиничне значення ознаки тривоги ALARMI1(j) (блок E3), у протилежному випадку ця ознака обнулюється (блок F2).

    Тренд - абсолютна зміна введеного значення вхідного аналогового сигналу в міжцикловий період. Якщо тренд перевищує припустиме значення, можна констатувати невірогідність сигналу. Припустимі значення трендів сигналів визначаються при програмуванні.

    Контроль тренда здійснюється для того сигналу, для якого задані власне контроль сигналу (блок A5) і контроль тренда (блок B5).

    Умови виходу за припустимий тренд (блок C5):

    ABS(DIG(j) – AIj) > LIMIT(j) ,

    де DIG(j) - раніше запам'ятоване значення сигналу; LIMIT(j) – припустиме значення тренду; ABS - символ абсолютного значення.

    При виході за припустимий тренд формується одиничне значення ознаки тривоги ALARMI2(j) (блок D5), у противному випадку ця ознака обнулюється (блок E5).

    У циклі включення системи контроль аналогового сигналу на припустимий тренд не проводиться.

    4.2.5 Алгоритм нормалізації і фільтрації введеного аналогового сигналу

    Призначення задачі, розв'язуваної алгоритмом:

    а) масштабування введеного значення сигналу з урахуванням внутрімашинного формату представлення чисел у PLC;

    б) фільтрація аналогового сигналу.

    Нормалізація і фільтрація здійснюються для кожного вхідного аналогового сигналу.

    Нормалізація (масштабування) здійснюється розрахунковим шляхом відповідно до формули:

    FLOW(j) := ADD1(j) + MUL1(j)*DIG(j) ;

    де ADD1(j), MUL1(j) - адитивний і мультиплікативні коефіцієнти масштабування.

    Вид фільтрації, що рекомендується - експонентне згладжування.

    Експонентне згладжування здійснюється відповідно до формули

    FLOW(j) := (FLOW(j) – PAST(j))*EXPS(j) + FLOW(j) ,

    де EXPS(j) - коефіцієнт експонентного згладжування, що задається при програмуванні.

    В загальному випадку нормалізація і фільтрація (перетворення) сигналу здійснюється з інтервалом часу RDT. Значення RDT установлюється для кожного сигналу. В окремому випадку воно може дорівнювати періоду циклу функціонування контролера (але не менше його).

    Перетворення здійснюється для сигналів, для яких заданий прапором-ознакою їхній контроль (блок В2 на рис. 4.4).

    Рис. 4.4 – Схема алгоритму нормалізації і фільтрації аналогового сигналу

    У циклі вмикання системи для контрольованого сигналу здійснюється :

    а) запуск таймера інтервалу обробки сигналу RTM(j)і встановлення прапора-ознаки FRTM(j) ввімкненого стану таймера (блок D2);

    б) перетворення значення сигналу DIG(j) у необхідний формат, нормалізація і запис у БД (блок E2).

    Якщо отримане значення FLOW (j) менше допуску флуктуації DELT1(j), що задається при програмуванні, то значенню сигналу, що запам'ятовується, привласнюється нульове значення (блок F3)

    Після закінчення інтервалу обробки сигналу здійснюється :

    а) обнулення таймера інтервалу обробки сигналу (RTM(j):=0) (блок C4);

    б) запам'ятовування попереднього значення реультата обробки сигналу (PAST(j) := FLOW(j)) (блок D4);

    в) перетворення цілочисленого значения сигналу, отриманого від АЦП, в дійсний формат, нормалізація і запис у БД (блок A5);

    г) фільтрація сигналу (блок B5);

    д) контроль нульового значення сигналу аналогового сигналу (блок C5).

    Операції і процедури алгоритму здійснюються циклічно c заданим періодом RDT(j) по досягненню таймером RTM(j) цього значення.

    4.3 Функція обчислення невимірюваних величин та узагальнених показників процесу

    Деякі технологічні параметри та узагальнені показники процесу неможливо виміряти приладами безпосередньої оцінки, доводиться застосовувати непрямі методи вимірювання з виконанням розрахунків на обчислювальному пристрої.

    Найбільш поширеною є задача визначення витрати рідини чи газу за перепадом тиску на звужуючому пристрої. Розглянемо алгоритм розрахунку витрати водяної пари.

    Призначення задачі та відповідного алгоритму:

    а) формування даних, використовуваних для розрахунку контрольованої витрати пари;

    б) розрахунок оцінного значення витрати пари для оперативного відображення на АРМ оператора.

    Оскільки витрата водяної пари є важливим техніко-економічним показником, для підвищення точності вимірювання перепаду тиску на діафрагмі використовуються два дифманометри: один з меншим діапазоном виміру для використання при малих витратах пари, інший з більшим діапазоном для виміру великих витрат.

    Задача, реалізована алгоритмом, виконується, якщо заданий прапор-ознака контролю витрати (блок В1 на рис. 4.5).

    Обов'язковими процедурами в алгоритмі є аналіз можливості виміру параметрів потоку:

    а) перепаду тиску на звужуючому пристрої (блоки C1, D1 та D2);

    б) температури пари (блок А3);

    в) надлишкового тиску пари (блок B3).

    Рис. 4.5 – Схема алгоритму разрахунку витрати водяної пари

    Аналіз здійснюється на підставі значень прапорів-ознак виконання контролю параметра і вірогідності сигналу відповідного датчика. При цьому сигнал датчика з меншим діапазоном виміру не аналізується на вихід за верхню апаратну уставку.

    Якщо установлений факт неможливості виміру параметрів потоку, встановлюється ознака неможливості розрахунку витрати FNQ:=1 і ніяких дій не виробляється.

    Якщо вимір параметрів потоку можливий, то в першу чергу здійснюється оцінка, сигнал якого дифманометра використовувати як результат виміру перепаду тиску. В нашому алгоритмі це здійснюється аналізом відповідності значення сигналу дифманометра з меншим діапазоном виміру межам виміру цього дифманометра – блок D1. При істинності результату цього аналізу як обмірюване значення перепаду тиску приймається нормалізоване значення сигналу дифманометра з меншим діапазоном виміру (блок Е1), при запереченні - сигналу дифманометра з більшим діапазоном виміру (блок Е2).

    Далі для контрольованого потоку здійснюється:

    а) розрахунок значення абсолютної температури за формулою (блок С3):

    TА = t + 273,15,

    де t – результат виміру температури в град.С;

    б) розрахунок значення абсолютного тиску контрольованого потоку пари за формулою (блок D3):

    PА = Pи + P0,

    де P0=101,325 кПа – атмосферний тиск (фізична атмосфера в кПа); Pи – надлишковий тиск (результат виміру); значення PА, Pи, P0 повинні мати ту саму розмірність; при приведенні них до однієї розмірності треба використовувати коефіцієнти відповідно до ГОСТ 8.563.2;

    в) розрахунок оцінки нормалізованого значення витрати пари (блок E3) по формулі:

    Qн = СQ ( DP × Pa /T)0,5 ,

    де СQ – коефіцієнт витрати, що розраховується наступним чином:

    СQ = Qmax /( Paр × DPmax/Tр)0,5,

    де Qmax – розрахункова верхня межа виміру витрати діафрагмою (т/ч); Pр, Tр – розрахункові параметри діафрагми (абсолютний тиск, абсолютна температура); DPmax - верхня межа виміру застосовуваного у вузлі обліку основного дифманометра (дифманометра з більшою межею виміру;

    г) обнулення ознаки неможливості розрахунку витрати FNQ:=0.

    4.4 Вироблення керуючих впливів

    Функція вироблення керуючих впливів відноситься до функцій керування АСК ТП. Вона, як і функція збирання та первинної обробки інформації, реалізується в основному на нижньому рівні управління за допомогою програмованих контролерів, мікропроцесорних регуляторів або комп’ютерів, оснащених модулями введення-виведення технологічних сигналів.

    До задач цієї функції відносяться:

    а) реалізація позіційного регулятора;

    б) реалізація аналогового ПІД-регулятора;

    в) реалізація широтно-імпульсного ПІД-регулятора;

    г) дістанційне керування виконуючими механізмами;

    д) безударний перехід з дистанційного керування на автоматичне.

    Як правило, автоматизована система має реалізувати наступні режими:

    а) ручне керування об'єктом засобами КВПтаА;

    б) дистанційне управління положенням виконавчого механізму через контролер;

    в) автоматичне регулювання технологічних параметрів.

    Перехід на ручне керування засобами КВПтаА здійснюється комутацією оператором кіл керування з інформуванням контролера відповідним сигналом.

    В автоматизованій системі постійно контролюється стан датчиків регульованих параметрів і при їхніх відмовах здійснюється автоматичний перехід на дистанційне керування виконавчими механізмами з формуванням прапора-ознаки для вироблення відповідної сигналізації (повідомлення).

    Автоматичне регулювання може здійснюватися по двох схемах: двохкаскадній та однокаскадній.

    Двохкаскадна схема – більш досконалий вид керування. В цьому випадку ведучий каскад формує уставку веденого. Ведений каскад формує керуючий вплив на виконавчий механізм.

    При однокаскадній схемі єдиний регулятор безпосередньо формує керуючий вплив на виконавчий механізм.

    Ведучий каскад реалізується на базі аналогового ПІД-регулятора.

    Ведений каскад і регулятор при однокаскадному керуванні реалізуються в залежності від стану датчика положення виконавчого механізму або на базі аналогового ПІД-регулятора, або на базі широтно-імпульсного (ШІМ) ПІД-регулятора.

    Аналоговий регулятор розраховує необхідне значення положення виконавчого механізму (ВМ), що порівнюється з поточним значенням сигналу датчика положення ВМ і при їхній невідповідності формується сигнал керування виконавчим механізмом на компенсацію цієї невідповідності (сигнал БІЛЬШЕ чи МЕНШЕ).

    При відмові чи відсутності датчика положення виконавчого механізму функціонує ШІМ-регулятор, у якому розраховується необхідний квант зміни положення виконавчого механізму і формується функціонально залежний від значення цієї зміни імпульс вмикання ВМ по відповідному каналу керування в залежності від знака розбалансу регулятора (сигнал БІЛЬШЕ чи МЕНШЕ).

    Перехід на ШИМ-регулятор здійснюється програмно.

    У регуляторах систем керування ПІД-розрахунок здійснюється у відповідності з наступною математичною моделлю:

    Du(tk) = KP[yd-y(tk)] + Dt(KI/ TI) [yd-y(tk)] + KD(TD/Dt)[ y(tk)- y(tk-1)], (4.1)

    де Du(tk) – розрахований на поточний момент часу t = tk квант зміни керуючого впливу (в алгоритмі позначена як DUPR); KP, KI, KD – коефіцієнти підсилення пропорційної, інтегральної, диференціальний частин регулятора; TI, TD – постійні часу інтегратора і дифференціатора регулятора; yd – уставка регулятора; y(tk) – значення регульованої величини на момент часу t=tk; Dt – інтервал дискретизації контролю і керування; k та (k-1) -індекси поточного і попереднього циклів функціонування регулятора.

    Приведена модель може бути реалізована стандартними програмними модулями контролера. В цьому випадку номенклатура настроювань регулятора уточнюється і встановлюється при програмуванні з урахуванням параметрів застосовуваних програмних модулів контролера.

    В аналоговому регуляторі формований керуючий вплив розраховується як

    u(tk) = u(tk-1) + Du(tk). (4.2)

    В однокаскадній САР і веденому регуляторі двохкаскадної системи розраховане u(tk) являє собою необхідне положення виконавчого механізму регулюючого органу системи.

    У ведучому каскаді двохкаскадної системи u(tk) являє собою необхідну уставку регулятора веденого каскаду.

    В ШІМ-регуляторі на підставі ПІД-розрахованого Du(tk) визначається тривалість імпульсу вмикання виконавчого механізму системи регулювання TIMP:

    TIMP = KM×Du(tk). (4.3)

    Тут KM - мультиплікативний коефіцієнт для розрахунку тривалості импульсу TIMP (параметр настроювання ШІМ-регулятора).

    При аналоговому ПІД-регулюванні, у тому числі при двохкаскадному керуванні, на підставі розрахованого керуючого впливу як необхідного значення положення виконавчого механізму здійснюється:

    а) розрахунок розбалансу між необхідним і поточним положенням виконавчого механізму;

    б) формування керуючих даних на останов виконавчого механізму, якщо цей розбаланс незначний;

    в) формування керуючих даних на вмикання виконавчого механізму по каналах БІЛЬШЕ чи МЕНШЕ в залежності від знака розбалансу при його істотному відхиленні.

    При функціонуванні аналогового ПІД-регулятора здійснюється постійний контроль стану датчика положення виконавчого механізму. При його відмові формується відповідний прапор-ознака і здійснюється перехід на ШІМ-регулювання. При нормальному стані датчика продовжується функціонування аналогового ПІД-регулятора.

    При функціонуванні ШІМ-регулятора продовжується контроль стану датчика положення виконавчого механізму. При його несправному стані продовжується функціонування ШІМ-регулятора. При відновленні нормального стану датчика здійснюється перехід на функціонування аналогового ПІД-регулятора.

    В аналогових ПІД-регуляторах здійснюється:

    а) розрахунок розбалансу регулятора;

    б) аналіз значимості розбалансу;

    в) ПІД-розрахунок кванту керуючого впливу (4.1) при істотній значимості разбланса;

    г) присвоєння кванту керуючого впливу нульового значення при неістотній значимості разбланса;

    д) розрахунок керуючого впливу (4.2);

    е) обмеження розрахованого керуючого впливу згідно технічним можливостям виконавчого пристрою.

    В ШІМ-регуляторах здійснюється:

    а) розрахунок розбалансу регулятора;

    б) аналіз значимості розбалансу;

    в) ПІД-розрахунок кванту керуючого впливу при істотній значимості разбланса;

    г) присвоєння кванту керуючого впливу нульового значення при неістотній значимості разбланса;

    д) розрахунок тривалості імпульсу умикання виконавчого механізму (4.3) на підставі розрахованого збільшення керуючого впливу;

    е) обмеження розрахованої тривалості імпульсу;

    ж) запуск таймера на відпрацьовування імпульсу з установкою ознаки відпрацьовування;

    з) формування керуючих даних на вмикання виконавчого механізму (БІЛЬШЕ чи МЕНШЕ в залежності від знака розбалансу регулятора);

    і) формування керуючих даних на останов виконавчого механізму, якщо розбаланс регулятора незначний.

    При відпрацьовуванні імпульсу умикання виконавчого механізму в кожному циклі контролера здійснюється контроль значення таймера на досягнення заданої тривалості імпульсу. При досягненні таймером заданої тривалості здійснюється перезапуск таймера на відпрацьовування паузи між умиканнями з обнулінням ознаки відпрацьовування тривалості імпульсу вмикання, з установкою ознаки відпрацьовування паузи і з формуванням керуючих даних на останов виконавчого механізму.

    Тривалість паузи є настроюванням регулятора.

    При відпрацьовуванні паузи здійснюється контроль значення таймера на досягнення заданої тривалості паузи. При досягненні таймером заданої тривалості здійснюється обнуління ознаки відпрацьовування паузи і перехід на розрахунок розбалансу регулятора і далі на новий ПІД-розрахунок .

    У системі передбачений безударний перехід на автоматичні режими:

    а) при функціонуванні аналогового регулювання – присвоєнням формованому керуючому впливу початкового значення, рівного поточному значенню сигналу датчика положення виконавчого механізму;

    б) при функціонуванні ШІМ-регулирования – обмеженням тривалості імпульсу вмикання виконавчого механізму.

    4.5 Діагностика стану комплексу технічних засобів КІСУ

    Під діагностикою розуміється комплекс програмних і технічних засобів АСУ, задіяний для виконання діагностичних функцій. Розрізняють убудовану діагностику (знаходиться усередині програмованих контролерів, мікропроцесорних регуляторів, ПЗО і т.д.) і зовнішню (реалізована як зовнішня діагностична станція, що відображає стан обладнання КІСУ).

    Убудована діагностика повинна мати два режими: обов'язковий - при будь-якому вмиканні системи керування, і розширений - вмикається за бажанням більш детальної діагностики окремих модулів і вузлів АСУ з метою локалізації несправності чи настроювання параметрів системи. Усі повідомлення убудована діагностика повинна видавати на власний дисплей діагностованого пристрою.

    Діагностування датчиків та виконуючих пристроїв здійснюється пристроями зва'язку з об'єктом. Для полегшення задач діагностування слід застосовувати датчики з вихідним сигналом 4-20 мА. Тоді струм, менший за 4 мА, однозначно свідчить про несправність. Цілям діагностики служать і описані в п. 4.2 алгоритми контролю тренду і виходу за апаратні уставки.

    Ряд апаратних засобів КІСУ оснащується системами самодіагностування.

    Призначенням систем самодіагностування і тестування контролерів є забезпечення оперативного виявлення несправностей апаратних засобів контролера, а також програмних помилок.

    Розрізняють апаратні і програмні засоби самодіагностування. Апаратні засоби мають світлові індикатори, які розташовані на лицьових панелях модулів контролера. Їхній стан дає можливість візуально визначити працездатність контролера і окремих його модулів. Програмне самодіагностування виконується в кожному робочому циклу контролера. Його результати записуються у пам'ять контролера і дозволяють програмним шляхом реалізувати алгоритми реагування системи на виявлення відповідних помилок.

    Детельніше виявити причини порушення працездатності контролера дають змогу системи діагностування і тестування, які запускаються з терміналів або пультів програмування. Ці системи дають можливість швидко визначити причини помилок і відмов контролера.

    Інтелектуальні прилади також здатні виконувати функції самодіагностування з видачею повідомлень про виявлені несправності на АРМ оператора.

    При проектуванні систем діагностики технічних засобів КІСУ слід керуватися наступними правилами.

    Зовнішня діагностика повинна надавати інформацію у вигляді розгорнутої структури відеокадрів. На кореневому відеокадрі повинна бути представлена інформація про поточний режим і стан об'єкта керування, його основних компонентів, основна технологічна інформація, аварійна сигналізація. Докладна інформація з поточного стану, локалізації джерел і причин порушення нормального стану, перешкодах відновлення необхідного стану й інша специфічна інформація, у тому числі стосовна до конкретних елементів устаткування, повинна надаватися окремими відеокадрами.

    Відеокадри однотипного устаткування повинні бути максимально уніфіковані.

    На усіх відеокадрах повинна бути наскрізна інформація (умовний сигнал чи рядок текстового повідомлення) про наявність інформації про аварію, несправності, останови і попередження. Повинна бути реалізована функція вказівки швидкого переходу до екранів, призначених для візуалізації розгорнутих варіантів вказаних повідомлень.

    При представленні інформації треба дотримуватись загальноприйнятих угод по кольорам:

  • червоний - аварії і несправності;
  • жовтий - попередження;
  • зелений - нормальні, відповідні технології сигнали, повідомлення і стани;
  • інші - кольори для інформації, що не відповідає призначенням червоного, жовтого і зеленого кольорів, вибираються по зручності сприйняття;
  • миготіння - може використовуватися для виділення, локалізації першоджерела інформації, щоб привернути увагу до зміни стану якого-небудь сигналу або до підказки оператору про шлях доступу до інформації і т.д.

    • Повинна бути розроблена система допомоги (підказки) з роз'ясненнями по змісту, умовним позначкам і активним клавішам.

    Повинна бути передбачена можливість централізованого установлення календарного часу всіх керуючих обчислювальних пристроїв з боку АСУ верхнього рівня.

    Також повинен бути розроблений відеокадр самої системи діагностики, що відображає справність окремих (складових) частин системи діагностики.

    Обсяг інформації, наданий системою діагностики, повинен включати діагностичну, технологічну і статистичну інформацію, як по усіх функціях технологічного устаткування, так і по роботі системи керування.

    Діагностична інформація повинна формуватися і надаватися у відповідності з наступними рівнями пріоритету:

    а) аварії - аномалії, при яких необхідно перервати будь-який режим роботи з ввімкненням аварійних ланцюгів, щоб уникнути погрози травмування обслуговуючого персоналу, поломки устаткування чи випуску бракованої продукції;

    б) несправності - аномалії в роботі пристроїв, механізмів, що виявляються в не виконанні ними своїх функцій:

    в) останови - припинення роботи устаткування за допомогою виконання штатних функцій без включення аварійних ланцюгів, включаючи технологічні останови;

    г) попередження - повідомлення про події, що вимагають від обслуговуючого персоналу виконання яких-небудь дій для забезпечення ефективної, надійної і якісної роботи устаткування відповідно до обраного режиму і технологічного процесу;

    д) інформація, що відображає стан устаткування технологічного процесу і зв'язків із суміжним устаткуванням.

    Для однозначного визначення причини будь-якого переривання в роботі об'єкта керування, викликаного аваріями, несправностями чи остановами, або причини невиконання керуючих дій діагностика повинна:

    а) стежити за поточним станом систем і елементів устаткування і за тим, що повинно виконуватися в кожен момент часу по всіх задачах керування. (Наприклад, при натиснутій кнопці переміщення виконавчого механізму в ручному режимі);

    б) при перериванні в роботі устаткування чи невиконанні керуючих дій - аналізувати виконання робочої програми і стан елементів та систем устаткування з метою виявлення всіх діючих першопричин цих відхилень;

    в) видавати інформацію про всі діючі першопричини відхилень у наступному вигляді:

    1) тип відхилення в роботі устаткування (аварія, несправність, останов, невиконання керуючого впливу);

    2) відповідний сигнал контролера з коментарем, що стан цього сигналу є першопричиною відхилення в роботі устаткування;

    3) для виконуючих механізмів: адреса (з коментарем) вихідного сигналу, у результаті вмикання/вимикання якого повинен установитися необхідний стан вхідного сигналу;

    4) локалізація джерела сигналу-першопричини відхилення в роботі устаткування за допомогою умовного символу на мнемосхемі устаткування відповідно до територіального розташування джерела відхилення;

    г) діагностика повинна реєструвати і зберігати інформацію про причини відхилень у роботі устаткування.

    Діагностика повинна також забезпечити виявлення причини короткочасних несанкціонованих вмикань/вимикань вихідних сигналів (наприклад, через несправність датчиків). За запитом оператора повинна зареєструвати і надати оператору на станції діагностики адресу і коментар вхідного сигналу контролера, що є причиною короткочасного несанкціонованого вмикання чи вимикання заданого оператором вихідного сигналу.

    Діагностика повинна відображати поточні режими роботи і стан основних систем та функціональних частин устаткування. Інформація повинна видаватись з режимам роботи, несправностям і помилкам окремих електронних пристроїв АСК і її елементів (джерело і код помилки з коментарями) з точністю до замінного модуля чи окремої електронної плати, із указівками на необхідність заміни цих пристроїв.

    Станція діагностики повинна відображати також статистичну інформацію:

  • статистику простоїв устаткування за поточну і попередню зміни;
  • таблиці продуктивності виробництва за поточну і попередню зміни;
  • поточний графік робочого часу, централізований календарний час у контролерах, що виконують статистичні функції;
  • іншу необхідну інформацію.

    • У протоколі, що друкується на станції діагностики, повинна фіксуватися інформація про аварії, несправності і попередження з указівкою першопричини і часу початку та закінчення подій. Діючі (неусунуті) причини повинні бути виділені окремо.

    4.6 Методи підвищення надійності функціонування КІСУ

    Основні характеристики надійності КІСУ не можуть досить точно визначатися такою характеристикою, як «число годин напрацювання на відмову». Через високу надійність сучасних керуючих обчислювальних пристроїв, наскрізного контролю модулів і конструктивів у процесі їхнього виготовлення відмови в роботі компонентів КІСУ дуже рідкі, і набрати статистичний матеріал для розрахунку числа годин напрацювання на відмову виробники звичайно не можуть. Тому характеристики надійності звичайно оцінюють непрямими показниками і можливостями КІСУ:

    а) глибиною і повнотою діагностичних тестів визначення несправностей в окремих компонентах КІСУ;

    б) наявністю убудованих у систему блоків безперебійного живлення (UPS) і часом їхньої роботи при припиненні живлення від мережі, а також можливістю і тривалістю перерви живлення (при відсутності UPS) без порушення функцій керування;

    в) можливостями, варіантами і повнотою резервування окремих компонентів КІСУ: мереж, контролерів, блоків уведення-виведення, пультів оператора, серверів.

    Використання резервування і його повнота прямо зв'язані з вартістю системи. Тому в розроблювальній системі автоматизації важливо правильно оцінити необхідність і бажаний вид резервування різних частин КІСУ.

    Локальна АСУ ТП і КІСУ мають загальну особливість: обидві системи автоматизації можуть цілком вийти з ладу, якщо лише в одному компоненті системи (комп’ютері, з'єднаному з контролерами чи мережею контролерів) виникне несправність.

    Якщо які-небудь компоненти виробничого процесу (чи весь процес) є критично важливими чи вартість зупинки виробництва дуже висока, виникає необхідність побудови резервованих систем. У системах з резервуванням вихід з ладу одного компонента не спричиняє зупинку всієї системи. реалізацію резервування більшості компонентів системи підтримує, наприклад, програмне забезпечення для керування виробничими процесами (SCADA-система).

    Розподіл процесів керування і контролю по декількох комп'ютерах, об'єднаних у локальну мережу, і використання архітектури «клієнта-сервер» дозволяють підвищити ефективність і швидкість роботи всієї системи, спростити створення резервованих систем.

    Навіть у простій системі комп'ютер, з'єднаний із промисловим устаткуванням, стає сервером, призначеним для взаємодії з контролерами, у той час як інші обчислювальні пристрої мережі – клієнтами.

    Коли комп'ютеру-клієнту потрібні дані для відображення, він запитує їх у сервера і потім обробляє локально.

    Для забезпечення резервування в систему може бути доданий другий (резервний) сервер, також призначений для взаємодії з промисловим устаткуванням. Якщо основний сервер виходить з ладу, запити клієнтів направляються до резервного сервера. При цьому резервний сервер не повинен цілком дублювати роботу основного, оскільки в цьому випадку обидва сервери взаємодіють з контролерами, подвоюючи навантаження на промислову мережу і скорочуючи, таким чином, її загальну продуктивність.

    Звичайно в клієнт-серверній архітектурі з контролерами взаємодіє тільки основний сервер. Одночасно він обмінюється даними з резервним сервером, постійно обновлюючи його статус. Якщо обмін даними з основним сервером припиняється, резервний сервер приймає рішення, що основний вийшов з ладу і бере його функції на себе.

    Резервування на рівні задач. Багато сучасних SCADA-програм дозволяють організувати резервування системи на рівні задач, таких як уведення-виведення сигналів з підтримкою баз даних реального часу (БД РЧ), обслуговування тривог (алармів), архівувания даних, організації звітів, обробки графічної інформації й ін.

    Кожна з цих задач підтримує свою базу даних незалежно від інших задач, так що можна дублювати кожну задачу окремо. Якщо основний сервер деякої задачі, наприклад, сервер тривог, виходить з ладу, усі клієнти одержують дані з відповідного резервного сервера.

    Резервування мережі. Резервування серверів і робочих станцій істотно підвищує надійність системи. Однак, якщо виходить з ладу мережа, порушується і керування на всіх клієнтських комп'ютерах. Використання додаткової резервної мережі забезпечує стабільність роботи системи у випадку виходу з ладу основної мережі.

    Резервування зв'язку з контролером. У більшості контролерів можна організувати додатковий зв'язок між сервером і пристроєм уведення-виведення.

    Наявність додаткового каналу зв'язку гарантує збереження обміну даними при виході з ладу основного каналу. Якщо обмін даними порушується (наприклад, відбувся обрив кабелю), SCADA-система робить переключення на резервний канал. Після відновлення фізичного з'єднання звичайно відбувається зворотний перехід на основний канал.

    Резервування контролерів звичайно здійснюється двома шляхами:

    • апаратне резервування складових частин контролера: при цьому резервуватися можуть як окремі вузли контролера, так і весь контролер у цілому; основні і резервні вузли контролера, як правило, розташовані в одному корпусі і зв'язок між ними здійснюється по внутрішньоконтролерній шині.

    • Резервування з використанням мережі контролерів: при цьому способі резервуються контролери в цілому, і їхня взаємодія здійснюється за допомогою мережевого зв'язку.

    При керуванні потенційно небезпечними виробництвами, де потрібно підвищена надійність керуючих контролерів, застосовуються різні способи резервування:

    а) гаряче резервування окремих компонентів та/чи контролера в цілому (при непроходженні тесту в робочому контролері керування переходить до другого контролера, рис. 4.6);

    Рис. 4.6 – Схема гарячого резервування

    б) використання схеми потроєння з «голосуванням» результатів обробки сигналів усіма контролерами групи (рис. 4.7). при цьому за вихідний сигнал приймається той, котрий видали більшість контролерів групи, а контролер, що дав інший результат, вважається несправним;

    Рис. 4.7 – Схема потроєння з “голосуванням”

    в) використання схеми, побудованої на принципі «пара і резерв» (рис. 4.8).

    Тут паралельно працює пара контролерів з «голосуванням» результатів, і аналогічна пара знаходиться в гарячому резерві. при виявленні відмінностей результатів роботи контролерів першої пари керування переходить до другої пари. Після проведення тестування першої пари, у випадку короткочасного випадкового збою керування повертається до першої пари. У протилежному випадку, якщо діагностується несправність, керування залишається в другої пари контролерів.

    Рис. 4.8 – Схеми, побудована на принципі «пара і резерв»

    Як приклад розглянемо систему з дубльованими контролерами.

    Контролери серії OpenLine 200 і 300 дозволяють мати на одній локальній магістралі два джерела живлення і два контролери для забезпечення "гарячого" резервування (рис. 4.9).

    Рис. 4.9 - Приклад системи з дублюванням контролерів і джерел живлення

    В цьому випадку один з контролерів призначається основним, а інший - резервним. Основний контролер виставляє і утримує на локальній магістралі низький активний рівень сигналу master до тих пір, поки він функціонує і за наслідками самодіагностики вважає себе справним. Резервний контролер контролює цей сигнал. У разі виявлення високого рівня на лінії master він прочитує поточний стан всіх ліній введення-виведення і приймає управління локальною магістраллю на себе. Основний контролер, що в цей час відмовив, можна замінити без зупинки системи. Також можлива "гаряча" заміна джерела живлення.


Програмування засобів комп‘ютерно-інтегрованих систем управління

5 Програмування засобів комп‘ютерно-інтегрованих систем управління

5.1 Програмні засоби нижнього рівня КІСУ

5.1.1 Види програмного забезпечення

Програмне забезпечення розділяється на системне і прикладне.

Системне програмне забезпечення складають операційні системи контролерів і АРМ оператора.

Операційна система (ОС) – організована сукупність програмних засобів, призначена для керування ресурсами обчислювальної системи. Операційні системи діють як інтерфейс між апаратурою і користувачами ізаймають найважливіше місце в сукупності сучасних системних програмних засобів. Вони є основою організації обчислювального процесу і визначають ефективність як використання апаратних компонентів системи, так і вирішення поставлених задач.

Прикладне програмне забезпечення (ППЗ) підрозділяється на:

  • ППЗ контролерів: непроцедурні технологічні мови, що дозволяють легко реалізовувати логічні операції; конфігуратор і бібліотека програмних модулів (модулі математичних функцій, первинної обробки інформації, регулювання). Особливостями ППЗ контролерів є: простота використання технологічних мов; наявність у бібліотеці модулів сучасних досконалих алгоритмів (алгоритми самонастроювання регуляторів, адаптивного керування, нечіткого регулятора й ін.). Деякі контролери можуть виконувати програми, написані на мовах високого рівня (C, Pascal, VB).
  • ППЗ пультів операторів.

    В ППЗ включаються пакети прикладних програм як загального призначення (статистична обробка інформації, експертна система підтримки прийняття управлінських рішень і т.п.), так і об'єктного (раціональне, а іноді оптимальне керування типовими процесами).

    Програмна система називається відкритою, якщо для неї визначені і описані використовувані формати даних і процедурний інтерфейс, що дозволяє підключити до неї зовнішні, незалежно розроблені компоненти.

    Розробка прикладного програмного забезпечення пультів оператора може здійснюватися двома шляхами: з використанням традиційних мов програмування (c++, Pascal і ін.) чи з використанням існуючих готових інструментальних проблемно-орієнтованих засобів.

    Процес створення ППЗ з нуля з використанням традиційних мов програмування для КІСУ є неприпустимо тривалим і складним. Безумовно, немає нічого кращого якісного, добре відлагодженого ППЗ, написаного висококваліфікованим програмістом спеціально для деякого проекту. Але наступну задачу цей програміст вимушений вирішувати знову практично з нуля. Процес створення ППЗ для складних розподілених систем стає неприпустимо тривалим, а витрати на його розробку дуже високими. Сьогодні, в умовах все більш зростаючої частки ППЗ у витратах на створення кінцевої системи і, відповідно, все більшій інтенсифікації праці програмістів, варіант з безпосереднім програмуванням відносно привабливий лише для простих систем або невеликих фрагментів великої системи, для яких немає стандартних рішень (не написаний, наприклад, відповідний драйвер ) або вони в принципі не влаштовують з тих або інших причин. У будь-якому випадку процес розробки власного ППЗ важливо спростити, скоротити часові і прямі фінансові витрати на розробку ППЗ, мінімізувати витрати праці висококласних програмістів, по можливості привертаючи до розробки фахівців в області процесів, що автоматизуються.

    Таким чином, сама логіка розвитку сучасного бізнесу в частині розробки ППЗ для кінцевих систем управління вимагає використання все більш розвинених інструментальних засобів типу SCADA-систем . Розробка сучасної SCADA-системи вимагає великих вкладень і виконується в тривалі терміни. І саме тому в більшості випадків розробникам керуючого ППЗ, зокрема ППЗ для АСУ ТП, представляється доцільним йти по другому шляху, набуваючи, освоюючи і адаптуючи який-небудь готовий, вже випробуваний універсальний інструментарій.

    5.1.2 Програмування ПЛК

    Однією з важливих особливостей сучасного програмного забезпечення ПЛК є те, що можна використовувати різні технологічні мови програмування. Стандартом МЕК1131-3 визнані 5 мов програмування:

    а) мова крокових діаграм LD;

    б) мова функціональних блокових діаграм FBD;

    в) мова послідовних функціональних схем SFC;

    г) мова структурованого тексту ST;

    д) мова інструкцій IL.

    Перші дві мови LD і FBD відносяться до графічних. У цих мовах графічні символи забезпечують пряму відповідність між графічним представленням рішення задачі і програмою, що розв'язує це завдання.

    LD (Ladder Diagram) використовує стандартизований набір символів для ступінчастого програмування. По суті, ці діаграми є представленням релейної логіки. Люди, що розуміють релейну логіку, легко можуть програмувати на мові крокових діаграм (рис. 5.1).

    Мова LD
    Рис. 5.1

    FBD (Function Block Diagram)- це графічна мова, яка повсюдно використовується в Європі. Елементи цієї мови виглядають як блоки, сполучені проводами в електричний ланцюг, роблячи мову зручною для безлічі прикладних програм, що містять передачу інформації або даних між різними компонентами. Функціональні блоки - це програмні об'єкти, які представляють спеціалізовані функції управління, використовувані в системах, що управляють (рис. 5.2).

    Мова FBD
    Рис. 5.2

    На додаток до графічних мов LD і FBD розроблені елементи мови SFC (Sequential Function Chart) - "кроки", "переходи" і "блоки операцій", які можуть бути використані для організації "операцій", написаних на будь-якій мові, для отримання алгоритмів послідовного управління.

    Мова SFC
    Рис. 5.3

    IL (Instruction List) - це мова низького рівня, що нагадує асемблер (рис. 5.4). Використовується для програмування контролерів з низькою обчислювальною потужністю.Програми IL легко транслюються в машинні коди будь-якого процесора, що дозволяє створювати дуже швидкі програми.

    Мова IL
    Рис. 5.4

    ST (Structured Text) - це мова високого рівня, схожа на Паскаль. Розроблена для структурного програмування. Мова ST надає булеві і арифметичні оператори, а також конструкції структурного програмування, такі, як IF... THEN ELSE, CASE, WHILE DO, а також REPEAT...UNTIL, зрозумілі будь-якому програмісту (рис. 5.5).

    Мова ST
    Рис. 5.5

    Всі мови передбачають механізми інкапсуляції даних і операцій. Наприклад, якщо користувач хоче знову і знову застосовувати одну і ту ж послідовність функцій управління, він може виділити її у функціональний блок, помістити цей функціональний блок в "бібліотеку", а потім встановити копії цього функціонального блоку стільки раз, скільки буде потрібно для програм, що управляють. Простим прикладом такого функціонального блоку є блок усунення "брязкоту" контактів ("Debounce") має один і той же зовнішній інтерфейс, незалежно від мови, використовуваної для внетрішньої реалізації (рис. 5.6). Це сильно спрощує програмування. Опис зовнішнього інтерфейсу блоку (рис. 5.6, а) може бути повністю відокремлений від його внутрішньої реалізації. Як показано на рис. 5.6 b)-е), ця реалізація може бути виконана на будь-якій мові (або навіть на якому-небудь іншому стандартній мові, такій, як СІ або Паскаль).

    Рис. 5.6 - Реалізація функціонального блоку різними мовами

    Кожна з мов має свої особливості і пристосована для розв’язання тих чи інших задач. Напрклад, мова крокових діаграм має переваги при реалізації алгоритму керування, який раніше був реалізований на релейно-контактних схемах. Мова функціональних блоків найбільш зрозуміла для фахівців, які мають великий досвід створення систем з окремих функціональних блоків – таймерів, лічильників, блоків арифметичних операцій і т.д. Якщо у програмі користувача необхідно виконувати велику цількість операцій по обробці інформації, краще використовувати мову структурованого тексту.

    Раніше основним технічним засобом для програмування ПЛК були спеціалізовані пульти керування, Вони використовувались як у вигляді вбудованих в ПЛК блоків, так і у вигляді окремих технічних засобів, які приєднувались до ПЛК в процесі програмування. Ці пульти використовувались також при відлагоджувані програм, виконанні процедур діагностики і тестування ПЛК.

    Сучасні термінали програмування на базі персональних комп’ютерів мають суттєви переваги над пультами програмування. Для програмування контролерів використовується спеціальне програмне забезпечення, основним завданням якогоє створення максимальних зручностей для програмування і відлагоджування програм. Процедури програмування замінюются на більш прості процедури конфігурування, що дає можливість користувачу, не входячи в тонкощі програмування, забезпечувати виконувати досить складних процедур.

    Програмні термінали дають можливість використовувати для різних за алгоритмами задач різні технологічні мови. А вже при записі програми у ПЛК різні фрагменти програми поєднуються в один машинний код.

    Прикладом спеціального програмного забезпечення для програмування ПЛК є система UltraLogik.

    Система UltraLogik призначена для розробки програмного забезпечення збору даних і управління, що виконується на IBMPC-сумісних контроллерах і промислових комп'ютерах з відкритою архітектурою.

    Система програмування UltraLogik розроблена відповідно до стандарту Міжнародної Електротехнічної Комісії (МЕК) IEC 61131 і як основна мова програмування використовує мову функціональних блокових діаграм Function Block Diagram (FBD).

    Система надає користувачеві механізм об'єктного візуального програмування, коли програма збирається з готових функціональних блоків. Окрім цього, UltraLogik дає можливість виконувати програмні модулі, написані на інших мовах програмування, таких як Сі та Асемблер

    UltraLogic має графічний інтерфейс і створена для роботи в ОС Windows 9x.

    Для користувача немає необхідності вивчати побудову конкретного контролера. Контролер в системі представляється як "чорний ящик", пов'язаний з об'єктом управління за допомогою формальних пристроїв аналогового і дискретного введення-виведення. Настроювання системи на різні типи контролерів і модулів введення- виведення проводиться в діалоговому режимі.

    Проекти, створені за допомогою системи UltraLogik, можуть взаємодіяти з SCADA-системами шляхом установки на сервер відповідного OPC драйвера. Після цього всі змінні, які були оголошені в проекті із статусом "мережева", будуть доступні будь-якій OPC-сумісній SCADA-системі верхнього рівня.

    5.1.3 Операційні системи реального часу

    На теперешній час найбільш поширеними ОС є MicrosoftWindows i UNIX. Під їх керуванням працюють більшість серверів і робочих станцій. Але для використання в керуючих обчислювальних пристроях нижніх рівнів на перший план виходять вимоги можливості роботи в режимі реального часу.

    Системою реального часу (СРВ) вважається апаратний-програмний комплекс, що реагує протягом передбаченого часу на непередбачуваний потік зовнішніх подій таким чином, що:

  • система реагує на подію на об'єкті протягом часу, критичного для цієї події;
  • система реагує на декілька подій, що одночасно відбуваються, протягом інтервалів часу, критичних для цих подій.

    • Часова затримка від одержання вхідного сигналу до видачі вихідного повинна бути малою, щоб забезпечити прийнятний час реакції на незаплановані події. Критичність події визначається об'єктом і самою подією Відсутність необхідної реакції протягом передбаченого часу вважається помилкою для операційних СРВ (ОСРВ).

    Розрізняють системи реального часу двох типів - жорсткого реального часу і м'якого реального часу. Системи жорсткого реального часу не допускають затримок реакції ні за яких обставин, оскільки вартість запізнення може опинитися нескінченно велика. До систем жорсткого реального часу відносяться бортові системи управління, системи аварійного захисту, реєстратори аварійних подій. Системи м'якого реального часу характеризуються тим, що затримка реакції не буває критичним чинником, хоч і може збільшувати вартість досягнення результату роботи системи і зменшувати продуктивність системи в цілому.

    Стисло розповімо про технічні критерії вибору ОС для побудови систем реального часу.

    Основними критеріями, які приймаються до уваги при виборі ОСРВ, відносяться:

  • час реакції системи на події, пов'язані з об'єктом;
  • можливість створення бездисковой конфігурації системи;
  • час перезавантаження системи;
  • наявність інструментальних засобів;
  • наявність необхідних драйверів пристроїв;
  • економічні параметри.

    • Відмітимо, що побудова апаратний-програмного комплексу реального часу завжди вимагає конкретних розрахунків параметрів.

    Представлені на ринку програмні засоби можна умовно розділити на операційні системи, спеціально розроблені для роботи в реальному часі, і операційні системи з додатковим програмним кодом, що підтримує роботу в реальному часі.

    Для побудови систем реального часу використовуються мови програмування реального часу (МП РЧ) та операційні системи реального часу (ОС РЧ).

    ОС РЧ - це система, яка обслуговує зовнішні процеси, що розвиваються у пристроях, що працюють в комплекті з ЕОМ, що мають тверді обмеження на час відповіді. Діями ОС РЧ керують переривання від зовнішніх процесів; якщо вони не будуть швидко оброблені (у залежності від процесу протягом мікро-, миллисекунд чи секунд), те хід зовнішнього процесу може спотворитися. Ці системи часто проектуються для окремого застосування, наприклад, для керування конкретним технологічним процесом.

    Для побудови ОС РЧ у сучасному програмуванні використовуються такі базові програмні засоби як МП РЧ, ОС РЧ загального призначення, спеціалізовані і мінімізовані ОС. Сучасні версії процедурно-орієнтованих мов традиційного типу Pascal і C мають можливості побудови системних програм з використанням убудованої чи прикомпонованої мови Ассемблер, що при достатньому досвіді програміста дозволяє одержувати найбільш ефективні програми. З огляду на орієнтацію на використання стандартних протоколів мереж, специфікації яких оформляють мовою C, найчастіше саме його вибирають як базову мову програмування ОС РВ у сполученні з мовою Ассемблера базового процесора системи РВ.

    Основу втілення системи реального часу складає ОС РЧ чи спеціалізовані керуючі програми, об'єднані в спеціалізовану ОС. Використання універсальних ОС РВ у повному обсязі для випадку різних конфігурацій систем керування як на основі багатопроцесорної системи, так і у формі автоматизованого робочого місця (АРМ) з контролерами є недоцільним. Причиною є ієрархічна надмірність універсальних ОС, яка забезпечує можливість підключення засобів налагодження програм і інших засобів полегшення праці програміста. Тому використовуються спеціалізовані ОС РЧ, разраховані на вирішення вузького кола задач.

    Кожна спеціалізована ОС проектується з урахуванням доступних ресурсів і повного обсягу пам'яті, необхідного для виконання оперативних задач.

    Особливі вимоги до ОС РВ керуючих систем:

    а) оперативна взаємодія (обмін) із блоком керування на базі зворотного зв'язку за результатами керування;

    б) підтримка стратегії керування з мінімально можливим простоєм основного устаткування системи керування;

    в) можливість реконфігурації структури і перерозподіл задач між процесорами.

    У режимі оперативної роботи повинні розв’язуватись наступні спеціальні задачі:

    а) видача керуючих сигналів на контролери чутливих елементів і виконавчих пристроїв;

    б) приймання запитів на обслуговування віддалених користувачів.

    в) взаємодія з іншими комп'ютерами мережі, що забезпечують технологічну підготовку й інформування про стан керованого технологічного процесу.

    г) тестування стану обчислювального комплексу і пристроїв системи керування;

    д) реініціалізація ОС при виявленні особливих ситуацій.

    На сьогодні найбільш широко розповсюдженими ОС РЧ є OS9/OS9000, QNX, VxWorks, LinxOS, VRTX, pDOS, RTOS-32. Останнім часом розширюється область застосування як системи реального часу операційних систем Windows NT із промисловою надбудовою, Windows CE.

    5.2 Програмні засоби верхнього рівня КІСУ

    5.2.1 Технологія ОРС

    У системах керування технологічними процесами сьогодні широко застосовуються численні програмні рішення (наприклад, SCADA) самих різних виробників, причому робота цих програмних систем базується на постійному обміні даними з компонентами системи автоматизації (контролерами, модулями ПЗО і т.д.). Можливість такої взаємодії забезпечується виробниками цих програмних рішень шляхом самостійної розробки ними драйверів , що інтегруються у вищезгадані програмні пакети. Такий підхід, як правило, веде до наступних проблем:

    • Збільшення витрат: повинні розроблятися окремі драйвери для кожного підтримуваного пристрою (драйвер повинний враховувати всі особливості конструкції пристрою і роботи його в реальному часі);

    • Обмежена функціональність драйверів: розроблювачем драйверів часто підтримуються не усі функції відповідного пристрою.

    • Обмежені можливості розширення і зміни складу компонентів системи автоматизації: унаслідок модернізації апаратної платформи драйвер або взагалі не може більше використовуватися, або може працювати нестабільно.

    • Конфлікти доступу: різні програми не можуть одночасно здійснювати доступ до тих самих компонентів системи автоматизації, тому що звертання до даних здійснюється через власні драйвери, робота одного з яких у кожен момент часу блокує можливість роботи всіх інших.

    Вирішити ці проблеми можуть виробники апаратних компонентів КІСУ, розробивши власні драйвери, оснастивши їх спеціальними стандартизованими інтерфейсами, щоб програми різних виробників програмного забезпечення могли без проблем їх використовувати.

    Велика кількість програм в області промислової обробки даних реалізуються в даний час на базі персональних комп'ютерів під керуванням операційних системам сімейства Windows (Windows 95/98/NT/2000/XP) фірми Microsoft. Для вирішення комунікаційних проблем фірмою Microsoft була запропонована технологія ОРС, що стала в даний час промисловим стандартом.

    OPC - це абревіатура від Object Linking and Embedding for Process Control, що в буквальному перекладі означає "технологія зв'язування і впровадження об'єктів для систем промислової автоматизації". Дана технологія призначена для забезпечення універсального механізму обміну даними між датчиками, виконавчими механізмами, контролерами, пристроями зв'язку з об'єктом і системами представлення технологічної інформації, оперативного диспетчерського управління, а також системами управління базами даних.

    Через інтерфейси ОРС одні програмні системи можуть читати чи записувати дані в інші програмні системи, обмінюватися подіями, оповіщати одна одну про позаштатні ситуації (тривоги), здійснювати доступ до даних, зареєстрованих в архівах («історичні» дані). Ці програмні системи можуть розташовуватися як на одному комп'ютері, так і бути розподіленими по мережі. При цьому незалежно від фірми-постачальника стандарт ОРС, визнаний і підтриманий усіма ведучими фірмами-виробниками SCADA-систем і устаткування, забезпечить їхнє спільне функціонування. Особливий клас являють собою ОРС-сервери конкретних апаратних пристроїв – вони поставляються багатьма виробниками апаратних засобів.

    OPC-сервер є програмним середовищем, що забезпечує одночасний уніфікований спосіб доступу до даних для різних програмних пакетів, в тому числі для SCADA-систем різних виробників програмного забезпечення.

    ОРС-сервер створює свого роду абстракцію апаратури, дозволяючи будь-якому ОРС-клиенту записувати і зчитувати дані з пристрою. Пристрій, для якого існує ОРС-сервер, може використовуватися разом з будь-якою сучасною SCADA-системою.

    OPC-інтерфейс допускає різні варіанти обміну: отримання сирих даних з фізичних пристроїв, з розподіленої системи управління або з будь-якої прикладної програми (рис. 5.7).

    Рис. 5.7 - Варіанти обміну даними через OPC-інтерфейс

    Іншими словами, дана технологія дозволяє забезпечити єдиний механізм доступу до первинних датчиків і виконавчих механізмів з верхнього програмного рівня SCADA-системи. Таким чином, виробники апаратних засобів, користуючись специфікацією OPC, мають можливість забезпечити явну сумісність своєї продукції верхнього рівня за допомогою реалізації OPC-драйвера, зрозуміло, якщо SCADA-система "OPC-сумісна".

    Тепер у розроблювачів програмного забезпечення відпадає необхідність написання нових драйверів, якщо внаслідок модернізації деякого апаратного компонента змінюється набір функцій доступу до її даних. Користувачі одержують велику свободу вибору при конфігуруванні і підборі апаратних засобів вирішення задач автоматизації.

    5.2.2 SCADA-системи

    У таблиці 5.1 перелічені найбільш популярні SCADA-системи .

    Таблиця 5.1

    Через ті вимоги, які пред'являються до систем SCADA, спектр їх функціональних можливостей визначений і реалізований практично у всіх пакетах. Перерахуємо основні можливості і засоби, властиві всім системам і що розрізняються тільки технічними особливостями реалізації:

  • автоматизована розробка, що дає можливість створення програмного забезпечення системи автоматизації без реального програмування;
  • засоби збору первинної інформації від пристроїв нижнього рівня;
  • засоби управління і реєстрації сигналів про аварійні ситуації;
  • засоби зберігання інформації з можливістю її подальшої обробки (як правило, реалізується через інтерфейси до найбільш популярних баз даних);
  • засоби обробки первинної інформації;
  • засоби візуалізації представлення інформації у вигляді графіків, гістограм і т.п.;

    • Основу більшості SCADA-пакетів складають декілька програмних компонентів (база даних реального часу, введення-виведення, передісторії, аварійних ситуацій) і адміністраторів (доступу, управління, повідомлень).

    Слід зазначити, що технологія проектування систем автоматизації на основі різних SCADA-систем багато в чому схожа і включає наступні етапи.

      1. Розробка архітектури системи автоматизації в цілому. На цьому етапі визначається функціональне призначення кожного вузла системи автоматизації.
      2. Рішення питань, пов'язаних з можливою підтримкою розподіленої архітектури, необхідністю введення вузлів з гарячим резервуванням і т.п.
      3. Створення прикладної системи управління для кожного вузла. На цьому етапі фахівець в області процесів, що автоматизуються, наповнює вузли архітектури алгоритмами, сукупність яких дозволяє вирішувати задачі автоматизації.
      4. Приведення параметрів прикладної системи у відповідність з інформацією, якою обмінюються пристрої нижнього рівня (наприклад, програмовані логічні контролери) із зовнішнім світом (датчики температури, тиску і ін.).
      5. Відлагодження створеної прикладної програми в режимі емуляції (у деяких системах, наприклад IGSS, режим відлагодження практично відсутній) і в реальному режимі.

    SCADA-системи закривають цеховий рівень автоматизації, зв'язаний, перш за все, з отриманням і візуалізацією інформації від програмованих контролерів, розподілених систем управління. Інформація, що поставляється на даний рівень, недоступна на рівні управління виробництвом. Тому важливо відзначити, що деякі фірми розробляють системи управління виробництвом і забезпечують обмін між цими рівнями.

    Одна з основних особливостей сучасного світу систем автоматизації є високий ступінь інтеграції цих систем. У будь-якій з них можуть бути задіяні об'єкти управління, виконавчі механізми, апаратура, що реєструє і обробляє інформацію, робочі місця операторів, сервери баз даних і т.д. Очевидно, що для ефективного функціонування в цьому різнорідному середовищі SCADA-система повинна забезпечувати високий рівень мережевого сервісу. Бажано, щоб вона підтримувала роботу в стандартних мережевих середовищах (наприклад, ETHERNET) з використанням стандартних протоколів (TCP/IP і ін.), а також забезпечувала підтримку найбільш популярних мережевих стандартів з класу промислових інтерфейсів (PROFIBUS, CAN, MODBUS і т.д.) Узагальнена схема подібної системи приведена на рис.5.8.

    Рис. 5.8 - Схема інтеграції SCADA-додатків в комплексні системи управління

    5.2.3 SCADA-система ТРЕЙС МОУД

    Ця система являє собою програмний комплекс фірми Аdаstrа, призначений для розробки, настроювання і запуску в реальному часі автоматизованих систем керування технологічними процесами. Усі програми, що входять у ТРЕЙС МОУД, поділяються на дві групи: інструментальна система розробки АСУ і виконавчі модулі (runtime).

    Інструментальна система містить у собі два редактори: редактор бази каналів і редактор представлення даних. У цих редакторах здійснюється розробка математичної основи АСУТП, графічних екранних фрагментів для візуалізації стану технологічного процесу і керування ім.

    У редакторі бази каналів створюється математична основа системи керування: описуються конфігурації всіх робочих станцій, контролерів і ПЗО, використовуваних у системі керування, настроюються інформаційні потоки між ними. Тут же описуються вхідні і вихідні сигнали і їхній зв'язок із пристроями збору даних і керування. У цьому редакторі задаються періоди опитування або формування сигналів, настроюються закони первинної обробки і керування, технологічні уставки, структура математичної обробки даних; тут установлюється, які дані і при яких умовах зберігати в різних архівах ТРЕЙС МОУД, і настроюється мережний обмін, а також вирішуються деякі інші задачі. Результатом роботи в цьому редакторі є математична й інформаційна структури проекту АСУТП. Ці структури містять у собі набір баз інформаційних каналів і файлів конфігурації для всіх контролерів і операторських станцій (вузлів) проекту, а також файл конфігурації всього проекту.

    У редакторі представлення даних розробляється графічна частина проекту системи керування. При цьому створюється статичний малюнок технологічного об'єкта, а потім поверх нього розміщаються динамічні форми відображення і керування (рис. 5.9). Серед них такі, як поля виведення чисельних значень, графіки, гістограми, поля введення значень, кнопки переходу до інших графічних фрагментів і т.д. Крім стандартних форм відображення (ФВ), ТРЕЙС МОУД дозволяє вставляти в проекти графічні форми представлення даних чи керування, розроблені користувачами (приклад форми видачі технологічній інформації операторові-технологові можна подивитись тут). Усі форми відображення інформації, керування й анімаційні ефекти зв'язуються з інформаційною структурою, розробленою в редакторі бази каналів. Графічні бази вузлів проекту, створені в редакторі представлення даних, зберігаються у спеціальних файлах.

    Рис. 5.9 - Приклад динамічного відображення

    Виконавчі модулі – це програми, під керуванням яких запускається АСУ, створена в інструментальній системі. У группу виконавчих модулів входять наступні програми:

    а) монітори реального часу – МРВ (від російського “мониторы реального времени”);

    б) монітор створення АРМ адміністратора – SUPERVISOR;

    в) монітор глобального архіву – Глобальний реєстратор;

    г) мікромонітор реального часу (МикроМРВ) і мікромонітор із підтримкою обміну по лініях, що комутуються – МикроМРВ Модем плюс.

    Монітори по п.п. а)–г) призначені для організації роботи верхнього й адміністративного рівнів АСУ. МикроМРВ і МикроМРВ Модем+ призначені для роботи в контролерах нижнього рівня систем керування, за умови наявності в них операційної системи MS DOS.

    Монітор реального часу МРВ призначений для запуску на АРМ операторів, що здійснюють з його допомогою супервізорний контроль і керування технологічними процесами. Під керуванням МРВ виконуються наступні задачі:

    – запит даних контролерів нижнього рівня про стан технологічного процесу;

    – передача на нижній рівень команд керування;

    – обмін даними з платами ПЗО;

    – збереження даних в архівах;

    – обмін по мережі з віддаленими МРВ;

    – обмін по лініях, що комутуються, з віддаленими МРВ;

    – передача даних по мережі на верхній рівень АСУ;

    – представлення оператору графічної інформації про стан технологічного процесу;

    – автоматичне і супервізорне керування технологічним процесом;

    – обмін даними з іншими програмами WINDOWS;

    – обмін з базами даних і інші функції.

    Монітор реального часу NetLink МРВ може застосовуватися тільки в складі систем керування, де обмін даними між вузлами системи здійснюється по локальній мережі. Під керуванням NetLink МРВ виконуються такі задачі системи керування:

    – запит даних про стан технологічного процесу у віддалених моніторів ТРЕЙС МОУД по мережі;

    – передача команд керування по мережі на нижній рівень;

    – збереження даних в архівах;

    – передача даних по мережі на вищій рівень АСУ;

    – представлення оператору графічної інформації про стан технологічного процесу;

    – автоматичне і супервізорне керування технологічним процесом;

    – обмін з базами даних.

    Монітор реального часу NetLink Light дозволяє створювати додаткові робочі місця операторів. Він не підтримує функції обробки даних і автоматичного керування. Даний монітор є додатковою графічною консоллю, що може бути підключена з віддаленого комп'ютера до запущеного МРВ. Таким чином, маючи в мережі один монітор реального часу, можна, використовуючи NetLink Light, створити в мережі необхідну кількість робочих місць, цілком рівноправних із МРВ по функціях відображення і керування.

    Монітор SUPERVISOR призначений для створення АРМ адміністратора, він може одержувати дані тільки з архівів. Це можуть бути або локальні архіви МРВ чи NetLink МРВ, або глобальні архіви, що створює Глобальний реєстратор. За допомогою SUPERVISOR неможливо здійснювати оперативне керування процесом. Він реалізує наступні функції:

    а) читання через мережу і відображення в реальному часі значень параметрів технологічного процесу, що заносяться в архіви моніторами реального часу;

    б) перегляд даних з архівів із заданою швидкістю.

    По функціях організації представлення даних SUPERVISOR схожий на NetLink Light. Для нього потрібно тільки створення графічної бази. Істотна відмінність SUPERVISOR полягає в тім, що він одержує від МРВ чи Глобального реєстратора архівні значення каналів, а NetLink Light – поточні дані.

    Глобальний реєстратор (ГР) призначений для ведення глобального архіву по всьому проекту. Він архівує дані, що посилаються йому по мережі моніторами реального часу. Після збереження даних в архіві Глобальний реєстратор може передавати їх для перегляду моніторам SUPERVISOR. Архів Глобального реєстратора реалізує технологію сховища даних. Він фіксує значення технологічних параметрів при їхній зміні. У рамках одного проекту може підтримуватися тільки один такий архів. Для організації дублювання глобального архіву треба запустити в мережі ще один монітор Глобальний реєстратор. При цьому обидва ГР будуть приймати дані, що посилаються для архівування, і зберігати у своїх архівах. Дубльований глобальний реєстратор підтримує функції синхронізації архівів при роботі в реальному часі і при запуску.

    Даний монітор дозволяє вирішувати наступні задачі:

    – прийом через локальну мережу даних, що посилаються для архівування від моніторів реального часу;

    – збереження отриманих даних у загальному архіві проекту;

    – підтримка відновлення архівних даних з резервного Глобального реєстратора;

    – читання з архіву і відображення в реальному часі значень параметрів технологічного процесу;

    – аналіз і обробка даних, збережених в архіві;

    – обмін даними з іншими програмами WINDOWS;

    – обмін з базами даних.

    МикроМРВ призначений для керування задачами збору даних і керування в контролерах нижнього рівня АСУТП. Він може бути використаний у будь-яких IBM-сумісних контролерах. По можливостях математичної обробки, керування, обміну даними з іншими моніторами ТРЕЙС МОУД МикроМРВ ідентичний монітору реального часу. Однак для нього не реалізовані функції графічного виведення інформації. Задачі для МикроМРВ розробляються в редакторі бази каналів.

    При використанні IBM-сумісних контролерів у рамках ТРЕЙС МОУД реалізується єдина лінія програмування задач верхнього і нижнього рівнів систем керування. У контролерах дотепер ще використовуються типи процесорів, що давно вважаються застарілими для застосування в персональних комп'ютерах. Тому існують наступні три модифікації виконавчих модулів МикроМРВ: для процесорів типу I8088; для процесорів типу I80286 і старше без співпроцесора; для процесорів типу I80286 і старше зі співпроцесором.

    Функції монітора МикроМРВ Модем плюс збігаються з МикроМРВ. Єдиною його відмінністю є убудована підтримка обміну даними за допомогою модему по каналах, що комутируються, що дозволяє використовувати МикроМРВ для створення віддалених пунктів збору інформації, що обмінюються даними через телефонну мережу.

    У системі ТРЕЙС МОУД передбачені драйвери. Драйвер потрібен, якщо протокол обміну даними з використовуваним пристроєм не убудований у систему. Основною функцією драйвера є забезпечення зв'язку ТРЕЙС МОУД із зовнішніми пристроями. Це можуть бути пристрою збору, збереження, обробки, передачі даних (контролери, ПЗО, інший комп'ютер і т.д.) чи які-небудь інші пристрої. Драйвер здійснює узгодження форматів даних ТРЕЙС МОУД і апаратури, для зв'язку з якою він розроблений.

    Треба відмітити, що коли монітори Трейс Моуд підключаються до контролерів чи розподілених ПЗО через стандартні інтерфейси OPC, це істотно знижує продуктивність інформаційних каналів у порівнянні з обміном по штатних протоколах Трейс Моуд з PC-сумісними контролерами, програмованими в Трейс Моуд.

    Але якщо вимушено використовуються апаратні засоби, у яких не підтримуються протоколи Трейс Моуд, то часто більш раціональними є використання технології ОРС або розробка спеціалізованих драйверів відповідно до документації на відповідні технічні засоби.

    5.2.4 Приклад побудови КІСУ на базі ТРЕЙС МОУД

    ТРЕЙС МОУД дозволяє створювати багаторівневі, ієрархічно організовані, резервовані АСУТП. Розглянемо трирівневу систему, що включає рівень контроллерів, диспетчерський рівень і адміністративний рівень.

    АСУТП рівня контролерів створюється на основі Мікромонітора реального часу (МИКРО-МРВ). Ця програма розміщується в РС-контролері і здійснює збір даних з об'єкту, програмно-логічне управління технологічними процесами і регулювання параметрів по різних законах, а також ведення локальних архівів. Програма веде постійний контроль працездатності ПЗО, мережевих ліній, і у разі їх виходу з ладу автоматично переходить на резервні засоби. За допомогою МИКРО-МРВ можна створювати дубльовані або потроєні системи з гарячим резервом.

    Основу диспетчерського рівня управління складають Монітори реального часу (МРВ). МРВ ТРЕЙС МОУД - це сервер реального часу, що здійснює прийом даних з контролерів, управління технологічним процесом, перерозподіл даних по локальній мережі, візуалізацію інформації, розрахунок техніко-економічних показників і статистичних функцій, ведення архівів.

    На адміністративному рівні АСУТП використовуються модулі Supervisor. Supervisor надає керівникові інформацію про хід і ретроспективу технологічного процесу, статистичні і техніко-економічні параметри підприємства. Ця інформація може оновлюватися в режимі, близькому до реального часу (затримка 10 - 30 с). Крім того, Supervisor дає можливість проглядати ретроспективу (здійснювати "плейбек") процесу як фільм на відеомагнітофоні. Графічний "плейбек" архіву дає в руки керівника інструмент контролю роботи диспетчерського комплексу і всього підприємства в цілому.

    5.3 Програмні засоби обчислювальних мереж

    5.3.1 Види програмного забезпечення мереж

    Функції верхніх рівнів еталонної моделі OSI виконують мережеві програмні засоби. Від вибору програмного забезпечення залежить дуже багато що: допустимий розмір мережі, зручність використання і контролю мережі, режими доступу до ресурсів , продуктивність мережі в різних режимах і т.д.

    Мережеве програмне забезпечення призначено для організації спільної роботи групи користувачів на різних ПК. Дозволяє організувати загальну файлову структуру, загальні бази даних. Забезпечує можливість передачі повідомлень і роботи над загальними проектами, можливість розділення ресурсів.

    Проксі-сервер (Proxy) - це програма для підключення локальних користувачів до мережі Інтернет через одну зовнішню IP-адресу. Дозволяє централізований управляти Інтернет-підключеннями за допомогою гнучкої системи правил (дозволяє задавати правила роботи Інтернет, фільтрувати непотрібну або небезпечну інформацію, контролювати безпеку роботи в мережі.); гнучкі тарифи (можливість відокремлювати різні види трафіку, наприклад, місцевий і зарубіжний) і вести точний облік трафіку .

    Міжмережевий екран (брандмауер, firewall) - комплекс апаратних і/або програмних засобів, що здійснює контроль і фільтрацію мережевих пакетів, що проходять через нього. Основним завданням міжмережевого екрану є захист комп'ютерних мереж або окремих вузлів від несанкціонованого доступу. Всі з'єднання з мережею проходять через міжмережевий екран, де вони можуть бути проаналізовані і дозволені або знехтувані.

    Спам-фільтр (Spamprotexx, Anti-Spam) - програма для захисту Ваших поштових скриньок від спаму . Результат досягається програмою за рахунок одночасного використання системи оновлюваних в режимі on-line "чорних" списків, використання зразків листів і застосування системи евристичного (інтелектуального смислового) аналізу вхідної кореспонденції.

    Антівіруси - це комп'ютерні програми, спеціально створені для пошуку і знешкодження вірусів, спаму, атак хакерів і троянських програм. Антивірус не допустить їх присутності на комп'ютері завдяки постійному контролю над всіма потенційними джерелами проникнення - електронною поштою, Інтернетом, а також зовнішніми носіями інформації.

    5.3.2 Функції і характеристики мережевих операційних систем ОС)

    Управління каталогами і файлами в мережах полягає в забезпеченні доступу до даних, фізично розташованих в інших вузлах мережі. Управління здійснюється за допомогою спеціальної мережевої файлової системи. Файлова система дозволяє звертатися до файлів шляхом застосування звичних для локальної роботи мовних засобів. При обміні файлами повинен бути забезпечений необхідний рівень конфіденційності обміну (секретності даних).

    Управління ресурсами включає обслуговування запитів на надання ресурсів, доступних по мережі.

    Комунікаційні функції забезпечують адресацію, буферизацію, вибір напряму для руху даних в розгалуженій мережі (маршрутизацію), управління потоками даних і ін.

    Захист від несанкціонованого доступу - важлива функція, сприяюча підтримці цілісності даних і їх конфіденційності. Засоби захисту можуть дозволяти доступ до певних даних тільки з деяких терміналів, в обумовлений час, певне число разів і т.п. У кожного користувача в корпоративній мережі можуть бути свої права доступу з обмеженням сукупності доступних директорій або списку можливих дій, наприклад, може бути заборонена зміна вмісту деяких файлів.

    Відмовостійкість характеризується збереженням працездатності системи при дії дестабілізуючих чинників. Відмовостійкість забезпечується застосуванням для серверів автономних джерел живлення, відображенням або дублюванням інформації в дискових накопичувачах. Під відображенням зазвичай розуміють наявність в системі двох копій даних з їх розташуванням на різних дисках, але підключених до одного контроллера. Дублювання відрізняється тим, що для кожного з дисків з копіями використовуються різні контроллери. Очевидно, що дублювання надійніше. Подальше підвищення відмовостійкості пов'язане з дублюванням серверів, що проте вимагає додаткових витрат на придбання устаткування.

    Управління мережею зв'язане із застосуванням відповідних протоколів управління. Програмне забезпечення управління мережею зазвичай складається з менеджерів і агентів. Менеджером називається програма, що виробляє мережеві команди. Агенти є програмами, розташованими в різних вузлах мережі. Вони виконують команди менеджерів, стежать за станом вузлів, збирають інформацію про параметри їх функціонування, сигналізують про події, що відбуваються, фіксують аномалії, здійснюють захист від вірусів. Агенти з достатнім ступенем інтелектуальності можуть брати участь у відновленні інформації після збоїв, в коректуванні параметрів управління і т.п.

    Програмне забезпечення мережевих ОС розподілене по вузлах мережі. Є ядро ОС, що виконує більшість з охарактеризованих вище функцій, і додаткові програми (служби), орієнтовані на реалізацію протоколів верхніх рівнів, виконання специфічних функцій для комутаційних серверів, організацію розподілених обчислень і т.п. До мережевого програмного забезпечення відносять також драйвери мережевих плат. Для кожного типу ЛВС розроблені різні типи плат і драйверів. Усередині кожного типу ЛВС може бути багато різновидів плат з різними характеристиками інтелектуальності, швидкості, об'єму буферної пам'яті.

    В даний час найбільшого поширення набули три основні мережеві ОС - UNIX, Windows NT і Novell Netware.

    ОС UNIX застосовують переважно в крупних корпоративних мережах, оскільки ця система характеризується високою надійністю, можливістю легкого масштабування мережі. У Unix є ряд команд і програм, що підтримують їх, для роботи в мережі.

    ОС Windows NT включає серверну (Windows NT Server) і клієнтську (Windows NT Workstation) частини і, тим самим, забезпечує роботу в мережах "клієнт/сервер". Windows NT зазвичай застосовують в середніх за масштабом мережах.

    ОС Novell Netware складається з серверної частини і оболонок Shell, що розміщуються в клієнтських вузлах. Надає користувачам можливість спільно використовувати файли, принтери і інше устаткування. Містить службу каталогів, загальну розподілену базу даних користувачів і ресурсів мережі. Цю ОС частіше застосовують в невеликих мережах.

    5.4 Програмні засоби робочих станцій АСУ ТП

    Робоча станція АСУ ТП – це функціонально закінчена система, що включає дисплей, системний блок комп'ютера і повнофункціональну алфавітно-цифрову захищену клавіатуру, які конструктивно об'єднані в компактний блок, призначений для експлуатації у несприятливих умовах (рис. 5.10).

    Рис. 5.10

    Види робочих станцій:

  • Диспетчерська робоча станція - комп'ютер, на якому розташовується програмне забезпечення, що дозволяє черговому диспетчерському персоналу управляти і контролювати роботу об'єктів системи
  • Технологічна робоча станція - комп'ютер, зазвичай розташований на робочих столах керівників і технічних фахівців підприємства, на якому розташовується програмне забезпечення, що дозволяє керівництву підприємства і технічним фахівцям контролювати і аналізувати роботу об'єктів системи
  • Сервер даних системи - комп'ютер, що виконує серверні функції, - тобто що не має оператора, який постійно працює на нім, на якому розташовуються серверне програмне забезпечення, яке підтримує роботу програмного забезпечення на інших комп'ютерах системи і служить для зберігання даних системи

    • До складу програмного забезпечення робочих станцій входять:

  • системний драйвер , який здійснює обмін даними реального часу з розподіленою системою програмованих контроллерів;
  • сервер системи, який проводить обробку даних системи, веде електронний журнал подій системи і містить логіку роботи системи;
  • супервізор системи, який здійснює супервізорне управління і візуалізацію процесів;
  • сервер даних системи, який концентрує дані системи;
  • сервер підтримки видаленого сегменту системи, який забезпечує роботу системи у видалених локальних мережах;
  • модуль диспетчерської робочої станції;
  • модуль технологічної робочої станції.


Комп’ютерно-інтегровані виробництва

6 Комп’ютерно-інтегровані виробництва

6.1 Загальні принципи побудови комп’ютерно-інтегрованого виробництва

Комп'ютерно-інтегроване виробництво (Computer integrated manufactory - CIM) є технологічною системою з складною структурою циркулюючих матеріальних і інформаційних потоків.

Промисловий світ прагне до інформаційної інтеграції. Точна, своєчасна, достовірна інформація на виробництві усе більш визначає продуктивність праці, рівень витрат, якість і конкурентноздатність продукції. Історично процес комп’ютеризації проникав на виробництво одночасно з двох сторін — «зверху» і «знизу». «Зверху» (в офісах) створювалися інформаційні структури, що відповідають за роботу підприємств у цілому. Це автоматизація бухгалтерського обліку, керування фінансами і матеріально-технічним постачанням, організація документообігу й ін. Цей рівень називається плануванням ресурсів підприємства (MRP, manufacturing resource planning).

«Знизу» (у цехах) інформація від різних датчиків насамперед використовувалася для безпосереднього керування виробничим процесом за допомогою різних УСО, програмованих контролерів і промислових комп'ютерів. Це рівень (Control Level), на якому замикаються «найкоротші» контури керування виробництвом. Потік інформації від датчиків також надходить на вхід систем SCADA . На цьому рівні (SCADA level) здійснюється оперативне керування технологічним процесом, приймаються тактичні рішення, насамперед спрямовані на підтримку стабільності процесу.

Далі на шляху інформаційного потоку існувала прірва. Очевидно, що первинна інформація з цехів повинна «добиратися» до верхнього рівня, рівня прийняття стратегічних рішень. Очевидно також, що потік сирих даних, без належної обробки, послужить скоріше «інформаційним шумом» для менеджерів і економістів. Необхідною з’вязуючою ланкою виступає новий клас засобів керування виробництвом — MES (Manufacturing Execution Systems), чи системи виконання виробництва. Упорядкована й оброблена інформація про хід процесу виготовлення продукції, одержувана на етапі збирання й обробки даних, стає доступною верхньому ешелону керування підприємством у реальному часі й у звичній для нього формі.

На початку 90х років відбулася революція в області автоматизації. З'явилися набори програм для створення джерела даних, що надходять у реальному часі, якими можуть користатися всі працівники підприємства: оператори, інженери і керівники середньої і вищої ланки. В даний час окремі програми інтегруються в єдину систему, що поставляє дані, необхідні для підвищення продуктивності праці і рентабельності виробництва. У результаті з'явилася структура керування, що прийнято зображувати у вигляді піраміди (рис. 6.1).

Рис. 6.1
Умовні позначення, що використані на рис. 6.1, наведені в таблиці 6.1

Таблиця 6.1 - Найменування типів автоматизованих систем, використовуваних в КІСУ

Абревіатура

Коротка характеристика

ERP (Enterprise Resource

Planning)

Планування Ресурсів Підприємства. Орієнтовані на бізнес-процеси підприємства. Основні завдання:

• ефективне управління збутом і постачанням;

• контроль за фінансовими і матеріальними потоками;

• планування випуску продукції.

ERP II (Enterprise

Resource & Relationship

Processing)

Управління ресурсами і взаєминами підприємства.

Доповнює ERP з позицій виходу підприємства в зовнішній світ.

MRP II (Material

Requirement Planning)

Планування Потреб в Матеріалах.

Орієнтовані на технологічні підрозділи підприємства. Основні функції: бізнес-планування, планування продажів і операцій

об'ємно-календарне планування, планування потреби в матеріалах, планування потреби у виробничих потужностях.

Крім MRP, включає:

планування потреби у виробничих потужностях (CRP -

Capacity Requirement Planing)

статистичне управління складськими запасами (SIC - Statistical

Inventory Control)

EAM (Enterprise

Asset Management)

Управління Основними фондами Підприємства.

Пропонують найбільш оптимальні і збалансовані рішення в області управління виробничими ресурсами і максимізації експлуатаційної готовності фондів.

MRP (Manufacturing

Requirement

Planning)

Планування Ресурсів Виробництва.

Рішення задач організації виробництва на окремій ділянці (цеху, установці).

У основі . використання BOM (Bill of material): склад виробу, специфікація, перелік складальних вузлів і компонент, рецептура

формула, рецепт, список інгредієнтів і т.д.

IRP (Intelligent Resource

Planning)

Інтелектуальне планування ресурсів.

Є розвитком ERP і MRP II, характеризуються динамічною адаптацією до завдань підприємства, що змінюються, і оперативною взаємодією з постачальниками і споживачами.

MES (Manufacturing

Execution Systems)

Виконавські системи виробництва.

Знаходяться на рівні технологічного процесу, але з технологією напряму не зв'язані. Основні завдання:

• за управління виробничими і людськими ресурсами в рамках

технологічного процесу

• планування і контроль послідовності операцій технологічного процесу

• управління якістю продукції

• зберігання початкових матеріалів і проведеної продукції по технологічних підрозділах

• технічне обслуговування виробничого устаткування

• зв'язок систем ERP і SCADA/DCS

DCS (Distributed Control

Systems)

Розподілені Системи Управління (фірми Fisher-Rosemount

Honeywell, Foxboro, Asea, Brown-Bovery, Bailey Controls, Johnson-

Yokogawa і ін.)

Системи управління розподіленим виробничим середовищем в

масштабах установки або цеху. Стандартна DCS полягає їх от-

ділових вузлів (на основі PLC), об'єднаних в мережу по інтерфейсах. Кожен вузол виконує одну або декілька завдань:

• збір і обробка інформації від набору вимірювальних пристроїв

• управління ділянкою виробничого процесу (з допомогою

пристроїв, що управляють)

• архівація даних

• управління призначеними для користувача інтерфейсами і відображення даних

• розрахункові завдання по оптимізації виробничого процесу

• зв'язок з іншими системами.

SCADA (Supervisory

Control and Data Acquisition)

Диспетчерське (оперативне) Управління і Збір Даних (фірми

Intellution, Wonderware, Allen Bradley, Siemens, Mitsubishi і ін.). Відрізняються від DCS функціональною різнорідністю вузлів, програмною реалізацією функцій контролю і управління, архітектурою (клиент-серверная, багатоланкова), більшою орієнтацією на

зручності оператора.

MMI (Man Machine Interface),

HMI (Human MI)

Людино- Машинний інтерфейс.

Узагальнювальна назва для SCADA і DCS.

Batch Control

Batch Control

Послідовне управління. Концепції і поняття послідовного управління визначені в стандарті S88.01, Models and

Terminology комітету ISA (1995г.). Дозволяють оптимізувати виробничий цикл (необов'язково замкнутий) послідовно

безперервних галузях (в т.ч. нафтопереробною) на основі

математичних моделей і алгоритмів.

PLC (Programmable

Logic Controllers)

Програмовані логічні контроллери.

6.2 Інтеграція АСУ

Центральним поняттям комп’ютерно-інтегрованих АСУ є поняття «інтеграція». Інтеграцію визначають як спосіб організації окремих компонентів в одну систему, що забезпечує узгоджену і цілеспрямовану їх взаємодію, зумовлюючи велику ефективність функціонування усієї системи. Інтеграцію в АСУ можна розглядати в кількох аспектах: функціональному, організаційному, інформаційному, програмному, технічному, економічному.

Функціональна інтеграція забезпечує єдність цілей та узгодження критеріїв і процедур виконання виробничо-господарських та технологічних функцій, спрямованих на досягнення поставленої мети. Основою функціональної інтеграції є оптимізація функціональної структури всієї системи, декомпозиція системи на локальні частини (підсистеми), формалізований опис функцій кожної підсистеми та протоколи взаємодії підсистем.

Організаційна інтеграція полягає в організації раціональної взаємодії персоналу управління на різних рівнях ієрархії КІСУ і різних локальних її підсистем, що зумовлює узгодження дій персоналу в напрямку досягнення поставлених цілей та погодженість управлінських рішень.

Інформаційна інтеграція передбачає єдиний комплексний підхід до створення й ведення інформаційної бази усієї системи та її компонентів на основі одного технологічного процесу збору, зберігання, передачі та обробки інформації, який забезпечує узгоджені інформаційні взаємодії всіх локальних АСУ та підсистем КІСУ.

Програмна інтеграція міститься у використанні узгодженого та взаємопов'язаного комплексу моделей, алгоритмів і програм для забезпечення спільного функціонування всіх компонентів КІСУ.

Технічна інтеграція — це використання єдиного комплексу сумісних обчислювальних засобів, автоматизованих робочих місць спеціалістів та локальних мереж ЕОМ, об'єднаних в одну розподілену обчислювальну систему, яка забезпечує автоматизовану реалізацію всіх компонентів КІСУ.

Економічна інтеграція є узагальнюючим комплексним показником інтеграції системи і полягає в забезпеченні цілеспрямованого та узгодженого функціонування усіх компонентів КІСУ для досягнення найбільшої ефективності функціонування усієї системи.

Стосовно ієрархічно організованої системи управління підприємством необхідна як горизонтальна, так і вертикальна інтеграції. У загальному випадку горизонтальна інтеграція припускає об'єднання АС одного рівня, а вертикальна - різних (суміжних).

Горизонтальна інтеграція припускає об'єднання між собою всіх автономних систем автоматизації технологічних і виробничих процесів, а також адміністративних відділень цехового рівня в єдину інформаційну мережу, що забезпечує необхідний обмін даними в реальному масштабі часу між всіма підрозділами основного і допоміжного виробництва .

Вертикальна інтеграція базується на організації потоків інформації від нижнього рівня (датчиків і контролерів технологічного устаткування) у внутрішні обчислювальні мережі цехів і ділянок, а далі - у обчислювальні мережі АСУП. Дане завдання вирішується шляхом об'єднання промислових і адміністративних мереж. Основна мета вертикальної інтеграції - усунення перепон на шляху інформаційних потоків між рівнями АСУП і АСУТП з метою оперативного обміну даними.

Сучасний етап розробки інформаційних систем в економіці України характеризується створенням АС нового покоління, до яких належать експертні системи, системи підтримки прийняття рішень, інформаційно-пошукові системи, системи зі штучним інтелектом. Основою створення таких систем є децентралізація структури ІАСУ та організація розподільної обробки інформації.

До інформаційних систем нового покоління належать системи підтримки прийняття рішень (СППР) та інформаційні системи, побудовані на штучному інтелекті (інтелектуальні АС).

СППР — це інтерактивна комп'ютерна система, яка призначена для підтримки різних видів діяльності при прийнятті рішень із слабоструктурованих або неструктурованих проблем. Інтерес до СППР, як перспективної галузі використання обчислювальної техніки та інструментарію підвищення ефективності праці в сфері управління економікою, постійно зростає. У багатьох країнах розробка та реалізація СППР перетворилася на дільницю бізнесу, що швидко розвивається.

Штучний інтелект — це штучні системи, створені людиною на базі ЕОМ, що імітують розв'язування людиною складаних творчих завдань. Створенню інтелектуальних інформаційних систем сприяла розробка в теорії штучного інтелекту логіко-лінгвістичних моделей. Ці моделі дають змогу формалізувати конкретні змістовні знання про об'єкти управління та процеси, що відбуваються в них, тобто ввести в ЕОМ логіко-лінгвістичні моделі поряд з математичними. Логіко лінгвістичні моделі — це семантичні мережі, фрейми, продукувальні системи — іноді об'єднуються терміном «програмно-апаратні засоби в системах штучного інтелекту».

Розрізняють три види інтелектуальних АС:

a) інтелектуальні інформаційно-пошукові системи (системи типу «запитання — відповідь»), які в процесі діалогу забезпечують взаємодію кінцевих користувачів — непрограмістів з базами даних та знань професійними мовами користувачів, близьких до природних;

б) розрахунково-логічні системи, які дають змогу кінцевим користувачам, що не є програмістами та спеціалістами в галузі прикладної математики, розв'язувати в режимі діалогу з ЕОМ свої задачі з використанням складаних методів і відповідних прикладних програм;

в)експертні системи, які дають змогу провадити ефективну комп'ютеризацію областей, у яких знання можуть бути подані в експертній описовій формі, але використання математичних моделей утруднене або неможливе.

Інтегрована АСУ підприємством (об'єднанням) — це багаторівнева автоматизована система управління, яка призначена для комплексної автоматизації функцій управління інженерно-технічною, адміністративно-господарською, виробничо-технологічною і соціальною діяльністю промислових підприємств і забезпечує найефективніше розв'язання завдань з планування, випуску, розробки, освоєння, виробництва і реалізації продукції згідно з вимогами повного госпрозрахунку та самофінансування.

До складу інтегрованої АСУ, наприклад науково-виробничим об'єднанням, що тісно взаємодіють, належать локальні АСУ: автоматизовані системи управління об'єднанням (АСУО), підприємствами (АСУП), цехами, дільницями, АСУ технологічними процесами (АСУ ТП), системи автоматизованого проектування конструкторського (САПР-К) і технологічного (САПР-Т) призначення, автоматизовані системи наукових досліджень (АСНД) та інші види АСУ. Можливий варіант взаємозв'язку локальних АСУ в рамках ІАСУ ілюструє рис. 6.2.

Рис. 6.2 – Взаємозв’язки локальних АСУ у складі АСУ науково-виробничого об’єднання

ІАСУ може розглядатися як ієрархічно організований комплекс організаційних методів, технічних, програмних, алгоритмічних та інформаційних засобів, що мають модульну структуру і забезпечують наскрізне узгоджене управління матеріальними та інформаційними потоками об'єкта управління. На промислових підприємствах і об'єднаннях в ІАСУ органічно поєднуються автоматизація розв'язування економіко-організаційних задач управління з автоматизацією управління технологічними процесами та гнучкими автоматизованими виробництвами, проектуванням виробів і технологічних процесів тощо.

Сутність інтеграції в АСУ економічного об'єкта (ЕО) полягає в удосконаленні зв'язків управління процесами проектування й організації виробництва, технологічними процесами та випробуванням виробів.

Розрізняють інтеграцію процесів за рівнями управління (вертикальні зв'язки) та взаємодією об'єктів одного рівня (горизонтальні зв'язки). З просуванням нагору збільшуються нормативи, показники, інтервали планування і т. ін. Маємо неначе ефект часової інтеграції. У разі інтеграції по горизонтальних зв'язках досягається узгодження дій окремих служб (підсистем), діяльності постачальників і споживачів у рамках єдиного плану-графіка постачання. Отут досягається ефект, так би мовити, просторової інтеграції.

Інтеграція полягає в об'єднанні окремих частин, підсистем, систем у рамках одної системи, яка охоплює повніші інформаційні аспекти управління на основі загального програмно-технічного, інформаційного й організаційного забезпечення. Поняття інтеграції можна поширити на однорідні системи (наприклад, лише АСУ ТП, лише АСУО і т. ін.), а можна віднести й до різнорідних систем (наприклад, АСУ ТП і АСУО; САПР і АСУП тощо).

ІАСУ — складна людино-машинна система, у якій поєднуються машинна обробка інформації та автоматизація прийняття рішень з діяльністю людини, яка відіграє роль оператора, керівника, експерта. Роль людини навіть за дуже високого рівня автоматизації управління є провідною, оскільки вона завжди виконуватиме найважливіші функції управління — вибір мети і критеріїв планування й управління, пошук альтернатив у досягненні мети, обґрунтування методів прийняття рішень і т. ін.

6.3 Системи автоматизації виробничих потоків

Організацією і керуванням системою руху матеріальних та пов'язаних з ними інформаційних потоків займається логістика. Задачею логістики є: забезпечити наявність продукту у потрібній кількості і стані, у правильному місці, у правильний час, за правильною ціною.

При керуванні матеріальними потоками в рамках внутрівиробничих логістичних систем використовують два основних способи: що штовхає і що тягне.

Система, що штовхає, являє собою систему організації виробництва, у якій предмети праці, що надходять на виробничу ділянку, безпосередньо цією ділянкою в попередньої технологічної ланки не замовляються. Матеріальний потік "виштовхується" одержувачу по команді, що надходить на передавальне ланку з центральної системи керування виробництвом.

Моделі керування, що штовхають, характерні для традиційних методів організації виробництва. Можливість їхнього застосування для логістичної організації виробництва з'явилася в зв'язку з масовим застосуванням комп'ютерної техніки. Упровадження програмних продуктів дозволило компаніям погоджувати й оперативно коректувати плани і дії всіх підрозділів підприємства: постачальницьких, виробничих і збутових, з урахуванням постійних змін у реальному масштабі часу. Використання програмного забезпечення дозволило істотно скоротити робочий час на прийняття і виконання управлінських рішень.

Системи, що штовхають, здатні ув’язувати складний виробничий механізм у єдине ціле, мають проте природні границі своїх можливостей. Параметри "матеріального потоку, що виштовхується" на ділянку, оптимальні настільки, наскільки керуюча система в стані врахувати й оцінити усі фактори, що впливають на виробничу ситуацію на цій ділянці. Однак чим більше факторів по кожному з численних ділянок підприємства повинна враховувати керуюча система, тим досконаліше і дорожче повинне бути її програмне, інформаційне і технологічне забезпечення.

На практиці застосовуються різні варіанти систем, що штовхають, відомі за назвою "системи MRP". Можливість їхнього впровадження обумовлена початком масового використання обчислювальної техніки. Системи MRP характеризуються високим рівнем автоматизації керування, що дозволяє реалізовувати наступні основні функції:

а) забезпечувати поточне регулювання і контроль виробничих запасів;

б) у реальному масштабі часу погоджувати й оперативно коректувати плани і дії різних служб підприємства - постачальницьких, виробничих, збутових.

Основним недоліком MRP систем, що штовхають, є необхідність створення і підтримки значних буферних запасів між виробничими підрозділами й етапами технологічного циклу.

Система, що тягне, являє собою систему організації виробництва, у якій деталі і напівфабрикати подаються на наступну технологічну операцію з попередньої в міру необхідності.

Тут центральна система керування не втручається в обмін матеріальними потоками між різними ділянками підприємства, не встановлює для них поточних виробничих завдань. Виробнича програма окремої технологічної ланки визначається розміром замовлення наступної ланки. Центральна система керування ставить задачу лише перед кінцевою ланкою виробничого технологічного ланцюга.

Переваги системи, що тягне

відмова від надлишкових запасів, інформація про можливість швидкого придбання матеріалів, або наявність резервних потужностей для швидкого реагування на зміну попиту;

заміна політики продажу зроблених товарів політикою виробництва продаваних товарів;

задача повного завантаження потужностей заміняється мінімізацією термінів проходження продукції по технологічному процесі;

зниження оптимальної партії ресурсів, зниження партії обробки;

виконання замовлень з високою якістю;

скорочення усіх видів простоїв і нераціональних внутрішньозаводських перевезень.

Для того, щоб зрозуміти механізм функціонування системи, що тягне, розглянемо приклад

Нехай підприємство одержало замовлення на виготовлення 10 од. продукції. Це замовлення система керування передає в цех збирання. Цех збирання для виконання замовлення запитує 10 деталей з цеху №1. Передавши зі свого запасу 10 деталей, цех №1 з метою заповнення запасу замовляє в цеху №2 10 заготовок. У свою чергу, цех №2, передавши 10 заготівель, замовляє на складі сировини матеріали для виготовлення переданої кількості також з метою відновлення запасу. Таким чином, матеріальний потік "витягається" кожною наступною ланкою. Причому персонал окремого цеху в стані врахувати набагато більше специфічних факторів, що визначають розмір оптимального замовлення, чим це змогла б зробити центральна система керування.

Але впровадження цієї моделі управління виробництвом може бути дуже ризикованим - потрібні корінні зміни, як у виробництві, так і в управлінні і корпоративній культурі.

Свій внесок у розвиток світовий логістичної системи внесла Японія, що розробила і застосувала вперше у світі прогресивну логістичну концепцію "just in time" - JIT (точно в термін) і внутрівиробничу систему KANBAN (у перекладі з японського - картка), розроблену і реалізовану фірмою "Тойота" (Японія).

Система "KANBAN" не вимагає тотальної комп'ютеризації виробництва, однак вона пердбачає високу дисципліну постачань, а також високу відповідальність персоналу, тому що центральне регулювання внутрівиробничого логістичного процесу обмежено. Система "KANBAN" дозволяє істотно знизити виробничі запаси. Наприклад, запаси деталей у розрахунку на один автомобіль, що випускається, у фірми "Тойота" складає 77 доларів, у той час як на автомобільних фірмах США цей показник дорівнює приблизно 500 діл. Система "KANBAN" дозволяє також прискорити оборотність оборотних коштів, поліпшити якість продукції, що випускається.

Системи типу "KANBAN", усуваючи зайві запаси, можуть ефективно працювати лише при відносно коротких виробничих циклах, точному прогнозуванні попиту і деяких інших виробничо-технологічних умовах. Для виправлення недоліків, властивим обом системам, були початі спроби їхнього об'єднання в єдиному планово-виробничому і диспетчерському комп'ютерному комплексі.

Одним з найбільш удалих прикладів синтезу у виробництві продукції ключових елементів MRP і KANBAN на основі сучасних інформаційно-комп'ютерних технологій з'явилася розроблена на початку 1980-х років логістична система "Optimized Production Tehnology" - ОРТ (оптимизированная виробнича технологія).

Згідно концепції ОРТ, все те, що заважає організованій системі досягти своєї мети, називається обмеження. Будь-яке підприємство розглядається як система ресурсів, зв'язаних між собою процесами, в яких вони використовуються. Всі ресурси працюють на досягнення мети підприємства.

Стосовно управління виробництвом і запасами виділяються три типи обмежень:

  • обмеження внутрішніх ресурсів (потужність устаткування, кваліфікація персоналу і т.п.);
  • обмеження ринку (надмірний ринок);
  • обмеження в методах ведення бізнесу (бізнес процеси і процедури управління).

    Теорія обмежень пропонує п'ять кроків управління системою:

    1. Виявити обмеження системи ("вузьке місце", критичний ресурс);
    2. Визначити способи найбільш ефективного використання вузького місця;
    3. Зробити все можливе для того, щоб "вузьке місце" використовувалося найефективніше і оптимально;
    4. Підвищити пропускну спроможність вузького (т.е. усунути його, наприклад, за рахунок залучення додаткових ресурсів);
    5. Повернутися до кроку першому - тобто не дозволити інерції (старим методам управління, розробленим на другому і третьому кроці) перетворитися на нове обмеження.

    Як показує практика, в компанії, що використовує ОРТ, багато внутрішніх обмежень усуваються в період від одного до шести місяців. При цьому промисловим підприємствам завдяки оптимізації виробничих завдань вдається обійтися без додаткових вкладень в устаткування.

    У системі ОРТ здійснюється автоматизоване оперативно-виробниче планування і диспетчеризація. Комп'ютерний розрахунок виробничих розкладів виконується на зміну, день, тиждень і т.д. Вирішуються також задачі контролю відвантаження запасів готової продукції споживачам, пошуку альтернативних ресурсів, видачі рекомендацій з повноцінних замін у випадку відсутності необхідних матеріальних ресурсів. При формуванні графіка виробництва використовуються наступні критерії ефективності:

  • ступінь задоволення потреби виробництва в ресурсах;
  • ефективність використання ресурсів;
  • засоби, іммобілізовані в незавершеному виробництві;
  • гнучкість.

    • OPT - приватна розробка і її "повна версія" належить консалтинговій компанії, що створила її. Тим не менше, її ключові теоретичні положення можна використовувати для управління будь-яким виробництвом.

    6.4 Електронно-цифрове виробництво

    Технології комп'ютерного моделювання, суміщені з процесом виготовлення, отримали назву електронно-цифрового виробництва (Digital Manufacturing). За допомогою засобів моделювання в реальному масштабі часу фірми-виготівники усувають огріхи в своїх процесах і знаходять більш довершені схеми розміщення устаткування, минувши дорогі рішення в металі і виготовлення дослідних зразків. Таким чином, інженери піддають перевірці новаторські ідеї, визначаючи доцільність реалізації в нових продуктах, і експериментують з новими методами виробництва, не витрачаючи час і засоби на виготовлення фізичних прототипів.

    У основу електронно-цифрового виробництва покладена ідея використання інформаційних технологій для сумісної розробки виробничих планів і устаткування одночасно з вдосконаленням продукту. Описане рішення дозволяє усувати конструктивні недоробки, огріхи виробництва і покращувати неефективні процеси на ранніх стадіях, коли зміни не спричиняють за собою неприпустимих відставань в графіці підготовки виробу до виходу на ринок.

    Загалом цю концепцію не можна вважати абсолютно новою. Раніше аналогічні ідеї були відомі як комплексне проектування і проектування з урахуванням вимог збірки, але широке впровадження цих концепцій починається тільки сьогодні. Фахівці, що спеціалізуються на питаннях управління життєвим циклом продуктів, вважають, що впродовж найближчих років інвестиції в технології електронно-цифрового виробництва щорічно збільшуватимуться більш ніж на 25%.

    Наприклад, за допомогою впровадження електронно-цифрового виробництва і інших інформаційних технологій канадська компанія P&WC скоротила період, що відокремлює початковий задум нового авыацыйного двигуна до його впровадження на ринок, до двох з половиною років. Застосування методів моделювання для виявлення недоліків масового виробництва і оцінки витрат на обслуговування дозволяє компанії економити 500 тис. дол. на кожному новому типі виробу, оскільки тепер можна обходитися без фізичних моделей у натуральну величину. Більш того, близько 70% т.з. інтерференцій - конфліктів між серійно виготовленими деталями - в даний час вирішується на ранніх стадіях проектування.

    Додатково, моделювання допомагає понизити витрати на обслуговування виробу. Якщо раніше для того, щоб визначити, чи будуть робочі по ремонту і обслуговуванню мати вільний доступ до тих або інших вузлів двигуна, доводилося створювати з дерева або пластика дорогі моделі у натуральну величину, то тепер інженери P&WC мають можливість засобами імітаційного моделювання точніше заміряти ергономічні параметри і оцінювати час, необхідний для виконання процедур обслуговування.

    З 2000 р. корпорація General Motors відмовилася від створення фізичних прототипів своїх автомобілів і почала використовувати цифрові моделі. Вже в перший рік вона заощадила 75 млн. дол. Ще однією важливою віхою на шляху цієї компанії до цифрового виробництва з'явилося моделювання ключових виробничих операцій, а також випробування ергономічних характеристик.

    Серед фірм, що виявляють особливу цікавість до ідеї електронний-цифрового виробництва, слід назвати виготівників складних електронних приладів, медичного устаткування, фармацевтичних препаратів і продуктів на базі біотехнологій.

    Підприємства фармацевтичної індустрії застосовують ці технології не стільки у виробництві нових медичних препаратів, скільки в процесі їх розробки. Проте, у міру того як процеси розробки ліків ставатимуть все більш віртуальними, підприємства галузі, швидше за все, стануть приділяти все більше уваги методам електронно-цифрового виробництва, щоб швидше починати випуск лікарських препаратів і скорочувати час циклів виробництва.

    Втім, утілити цей віртуальний світ в реальному виробничому середовищі зовсім не просто. Програмні засоби електронний-цифрового виробництва вельми складні і коштують великих грошей. Крім того, їх використання припускає серйозні зміни бизнес-процесів. Забезпечити спільну роботу виробничих і інженерних груп на ранніх етапах процесу розробки неможливо без радикального перегляду культурних стереотипів, що склалися.

    Ще одна причина, протидіюча вкоріненню нових технологій, полягає в тому, що потоково-масове виробництво - сфера традиційна і тому не дуже сприйнятлива до нових віянь. Багато менеджерів середньої ланки як і раніше скептично відносяться до заяв постачальників засобів цифрового виробництва і представників фірм, що вже реалізували цю ідею. Вони не готові ризикувати своїм майбутнім, надаючи вищестоящим менеджерам право на вкладення в нову справу таких істотних засобів.

    Нарешті, для повної реалізації потенціалу цифрового виробництва керівникам більшості компаній необхідно провести значну підготовчу роботу. Їм потрібно до тонкощів розібратися у всіх процесах, щоб вони могли точно моделювати процедури створення продуктів, а це зовсім несхоже на традиційні підходи до організації виробництва.

    Історично склалося так, що співпраця між інженерними і виробничими департаментами приймає форму багатостадійного процесу. Спочатку інженери за допомогою своїх систем автоматизованого проектування працюють над проектами нового виробу. Потім вони створюють прототип і, так би мовити, передають естафету інженерам по організації виробництва, які за допомогою власних наборів інструментів визначають, чи можна виготовити такий продукт і якою ціною. Далі починається карусель: прототип допрацьовується, знов тестується для з'ясування можливості його промислового виготовлення, знову допрацьовується, знову тестується і т.д.

    Цей ітераційний процес приводить до величезного збільшення циклу, який новий продукт проходить до впровадження на ринок, і до істотного зростання витрат, пов'язаних з тим, що старі прототипи доводиться викидати і виготовляти нові. Якщо ви спробуєте спроектувати виріб без засобів імітаційного моделювання, то напевно допустите пару-трійку помилок або раптом виявите, що якісь деталі не стикуються через те, що були прийняті невірні допуски. Зазвичай такі проблеми утрясаються в ході експериментів в заводських цехах.

    У цифровому світі все відбувається інакше. Взаємодія між групами інженерів і виробничників відбувається безпосередньо на рівні моделей, фізичні прототипи при цьому не застосовуються. Як тільки інженери створюють ескіз виробу, його цифрове уявлення можуть проглядати фахівці з організації виробництва. Вони називають можливі проблемні ділянки, і необхідні зміни вносяться до ескіза ще до створення цифрових прототипів. Аналогічним чином здійснюється тестування на віртуальному конвейєрі, де також фігурує цифрове представлення виробу.

    Використовуючи описані технології, компанії можуть не тільки економити час і гроші. Вони дістають сприятливіші можливості для оптимізації процесу виробництва. При нових засобах моделювання з'являється можливість випробувати різні альтернативні рішення і вибрати оптимальний спосіб виготовлення виробу.

    Програмне забезпечення реалізації концепції цифрового виробництва зв'язане з великими витратами - і у фінансовому плані, і з погляду необхідних змін в бізнесі і процесах. Отже, ці програмні системи повинні бути прив'язані до основної бізнес-стратегії.

    Відчуваючи все більш жорсткий тиск з боку конкурентів у всьому світі, виробники випробовують гостру потребу в нових технологіях і методах роботи, які могли б забезпечити застосування новаторських рішень як у виготовленні продуктів, так і в організації бізнес-процесів.

    Одна з найбільш багатообіцяючих ініціатив в цій сфері - інтеграційна стратегія управління життєвим циклом виробу (Product Lifecycle Management, PLM), що забезпечує безпроблемну доставку даних, що стосуються певного продукту, всім співробітникам, що мають відношення до тієї або іншої стадії його життєвого циклу. Стратегія PLM - логічна попередниця концепції електронно-цифрового виробництва, і за останні пару років ці інфраструктури поступово реалізовувалися у ряді компаній.

    PLM припускає уніфіковане уявлення відомостей про продукти, значно полегшуючи співпрацю і обробку інформації, необхідної для цифрового виробництва. Це важливо, оскільки різні групи фахівців, зокрема, інженери і планувальники асортименту виробів, використовують неоднакові набори даних і різні засоби моделювання, що украй утрудняє побудову інтегрованих моделей.

    Концепція цифрового виробництва, будучи складовою частиною ширшої стратегії PLM, змінює правила гри. З'являється можливість внести до цифрового моделювання компонент реального часу, що дозволяє виготівникам планувати оптимальні заводські потоки, тестувати процеси, відмовлятися від використання прототипів і скорочувати число переробок (відомих як "Scrap and rework" - "викинути і зробити наново"). Проектувальники виробів вже багато років роблять те ж за допомогою систем автоматизованого проектування - створюють цифрові прототипи нових моделей автомобілів або авіаційних двигунів перед тим, як реалізовувати їх в металі або створювати дорогі прототипи, призначені для одноразового використання. Цифрове виробництво - спроба розповсюдити ці принципи на масове виробництво виробів.


ОСНОВИ КОМП'ЮТЕРНО-ІНТЕГРОВАНОГО УПРАВЛІННЯ

Зміст

ВСТУП
1 Поняття комп'ютерно-інтегрованого управління
2 Теоретичні основи комп'ютерно-інтегрованого управління
2.1 Сигнали
2.2 Математичні моделі сигналів
2.2.1 Елементарні сигнали
2.2.2 Cкладні квазідетерміновані сигнали
2.2.3 Випадкові сигнали та їх характеристики
2.3 Загальні поняття теорії інформації
2.3.1 Структура інформаційного каналу
2.3.2 Поняття кількості інформації
2.3.3 Ентропія неперервного сигналу
2.3.4 Методи визначення кількості інформації
2.3.5 Пропускна спроможність каналу передачі
2.4 Фільтрація сигналів
2.5 Квантування сигналів
2.6 Дискретизація сигналів
2.7 Кодування сигналів
2.7.1 Поняття кодування
2.7.2 Системи числення
2.8 Загальна структура комп'ютерно-інтегрованої системи
2.9 Класіфікація і аналіз характеристик комп'ютерно-інтегрованих систем
2.10 Ефективність комп'ютерно-інтегрованих систем
3 Побудова ієрархічно-розподілених АСУ
3.1 Загальні відомості
3.2 Вступ у технологію розподілених інформаційних мереж
3.2.1 Визначення розподіленої інформаційної системи
3.2.2 Технології оброблення інформації в розподілених системах
3.2.3 Еталонна модель взаємодії відкритих систем
3.3 Основні компоненти розподілених інформаційних систем
3.3.1 Устаткування розподілених інформаційних систем
3.3.2 Типи і характеристики передавальних середовищ
3.3.3 Методи передачі даних на фізичному рівні
3.4 Інформаційні мережі
3.4.1 Типи інформаційних мереж
3.4.2 Технічна організація мереж
3.4.3 Технологія клієнт-сервер
3.4.4 Розгалужені мережеві топології
3.5 Інтерфейси і протоколи
3.5.1 Загальна характеристика інтерфейсів та протоколів нижнього рівня
3.5.2 Інтерфейс RS485
3.5.3 HART-протокол
3.6 Мережі та вузли нижніх рівнів АСУ ТП
3.6.1 Локальна мережа Ethernet
3.6.2 Локальна мережа Token Ring
3.6.3 Локальні радіомережі
3.6.4 Польові шини
3.6.5 Вибір типу мережі
3.6.6 Вузли нижніх рівнів АСУ ТП
3.7 Мережі та вузли верхніх рівнів АСУ ТП
3.8 Корпоративні обчислювальні мережі, Інтранет
3.8.1 Глобальні мережі. Призначення і послуги глобальних мереж
3.8.2 Технології транспортування даних у глобальних мережах
3.8.3 Мережа Інтернет
3.8.4 Intranet
3.8.5 Використання Інтернет у КІСУ
3.9 Традиційна диспетчеризація і системи SCADA
4 Принципи функціонування комп’ютерно-інтегрованих систем управління (КІСУ)
4.1 Функції та режими роботи КІСУ
4.2 Функція збирання та первинної обробки інформації
4.2.1 Загальні відомості
4.2.2 Загальний алгоритм функціонування контролера
4.2.3 Алгоритм запису у внутрімашинні масиви даних PLC уведених значень вхідних дискретних сигналів
4.2.4 Алгоритми контролю вірогідності введених аналогових сигналів
4.2.5 Алгоритм нормалізації і фільтрації введеного аналогового сигналу
4.3 Обчислення невимірюваних величин та узагальнених показників процесу
4.4 Вироблення керуючих впливів
4.5 Діагностика стану комплексу технічних засобів КІСУ
4.6 Методи підвищення надійності КІСУ
5 Програмування засобів комп‘ютерно-інтегрованих систем управління
5.1 Програмні засоби нижнього рівня КІСУ
5.1.1 Види програмного забезпечення
5.1.2 Програмування ПЛК
5.1.3 Операційні системи реального часу
5.2 Програмні засоби верхнього рівня КІСУ
5.2.1 Технологія ОРС
5.2.2 SCADA-система ТРЕЙС МОУД
5.3 Програмні засоби обчислювальних мереж
5.3.1 Види програмного забезпечення мереж
5.3.2 Функції і характеристики мережевих операційних систем
5.4 Програмні засоби робочих станцій АСУ ТП
6 Комп’ютерно-інтегровані виробництва
6.1 Загальні принципи побудови комп’ютерно-інтегрованого виробництва
6.2 Інтеграція АСУ
6.3 Системи автоматизації виробничих потоків
6.4 Електронно-цифрове виробництво
7 Література
8 Методичні вказівки до практичних занять

◄ Назад Зміст Уперед ►


ВСТУП

Ефективне управління сучасним підприємством неможливе без застосування нових інформаційних технологій. Формування автоматизованої системи управління на базі сучасних технологій може забезпечити взаємозв'язок інформаційних потоків, засобів обробки даних, передачі та зберігання інформації і менеджерів, що ухвалюють управлінські рішення.

Інтеграція операцій управління в єдине ціле здійснюється комп'ютеризованими інформаційними системами. Комп'ютерно-інтегроване управління і виробництво використовують розподіл інформаційних потоків так, що підприємство стає сукупністю взаємодіючих і керованих гнучких систем.

Інтерактивний навчальний посібник призначений для використання студентами спеціальності 7.092501 під час вивчення курсу "Основи комп'ютерно-інтегрованого управління" і має за мету дати їм основи знань, що необхідні для вирішення виробничих завдань, пов'язаних з проектуванням і обслуговуванням сучасних автоматизованих систем керування. Користуючись посібником, студент має одержати інформацію :

1) про теоретичні основи комп'ютерно-інтегрованого управління;

2) про побудову комп'ютерно-інтегрованих систем управління;

3) про технологію розподілених інформаційних мереж;

4) про принципи функціонування комп'ютерно-інтегрованих систем управління (КІСУ);

5) про програмування засобів комп'ютерно-інтегрованих систем управління;

6) про сучасні комп'ютерно-інтегровані виробництва.

Опанувавши курс, студенти будуть знати принципи побудови, властивості, характеристики сучасних автоматизованих систем керування, вміти вибирати засоби та методи комп'ютеризації управління, мережевого зв'язку, будувати технічну структуру комп'ютерно-інтегрованих систем управління.

Для ряду використовуваних термінів дається їх розшифрування за допомогою гіперпосилань. При наведені курсору на таке слово або словосполучення випадає віконце, що містить текст розшифрування. Після того, як текст прочитаний, віконце можна закрити, для чого треба навести курсор спочатку на віконце, потім за його межі. Ця технологія запозичена з сайту http://www.bosrup.com. Для того, щоб вона працювала, треба відключити функцію блокування спливаючих вікон у браузері.

В кінці розділів інтерактивного посібника є гіперпосилання у вигляді наступного рисунку:

З його допомогою відбувається перехід до програми тестування для контролю засвоєння поточного розділу. Кожен тест містить від 10 до 12 питань. На кожне питання даються 4-6 варіантів відповіді. Необхідно вибрати варіант і клікнути мишею кнопку "ДАЛІ". Тестування може бути перервано будь який момент за допомогою кнопки "СТОП".

Інтерактивний посібник потребує операційної системи Windows 98/ME/NT/2000/XP/2003/Vista і браузера Internet Explorer версії 4 і вище. Для перегляду методичних вказівок до практичних занять на комп'ютері має бути встановлена програма Acrobat Reader. Якщо нема, Ви можете встановити її за допомогою цього посилання.

При подготовці інтерактивного посібника використовувались, в основному, матеріали з Інтернету.


Література

7 ЛІТЕРАТУРА

7.1 Основна

  1. ДСТУ 2226-93. Автоматизовані системи. Терміни та визначення
  2. Основи цифрових систем: Підручник / За ред. М.П.Благодарного, В.С.Харченка. - Харків: Нац. аерокосмічний ун-т, 2002. - 672 с.
  3. Кравчук С.О., Шонін В.О. Основи комп'ютерної техніки. - К.: ІВЦ "Видавництво Політехніка", 2005. - 344 с.
  4. Горнев Ф.Ф., Емельянов В.В., Овсянников М.В. Оперативное управление в ГПС. М.: Машиностроение, 1990. 256 с.
  5. Энгельке У.Д. Как интегрировать САПР и АСТПП / Под ред. Д.А.Корягина. - М.: Машиностроение, 1990. - 320 с.
  6. Згуровский М.З. Интегрированные системы оптимального управления и проектирования / Згуровский М.З. - Киев : Выща школа, 1990. - 350 с.

7.2 Додаткова

  1. Бонгард М.М. Проблемы узнавания. - М., Наука, 1967 - 320 с.
  2. Бондарев В.Н., Трёстер Г., Чернега В.С. Цифровая обработка сигналов: методы и средства: Уч. пособие для вузов. - Х.: Конус, 2001. - 398 с.
  3. Горский Ю.М. Информационные аспекты управления и моделирования. - М., Наука, 1978 - 223 с.
  4. Гуржій А.М. та ін. Контроль і керування корпоративними комп'ютерними мережами: інструментальні засоби та технології. - Харків: , 2003. - 664 с.
  5. Кирсанов А.Ю. Методика экспериментального исследования динамики работы системы дистанционного управления экспериментом через информационные сети общего пользования // Электронное приборостроение. Научно-практический сборник. Выпуск 3(44). - Казань. 2005 г. - С. 42-49.
  6. Лапа В.Г. Математические основы кибернетики. - К.: Вища школа, 1971. - 420 с.
  7. Проектування інформаційних систем: Посібник / За ред. В.С.Пономаренка. - К.: Академія, 2002. - 486 с.
  8. Чернега В.С., Василенко В.А., Бондарев В.Н. Расчет и проектирование технических средств обмена и передачи информации. - М.: Высш. шк., 1990. - 224 с.
  9. Шеннон К. Работы по теории информации и кибернетика. - М., Иностранная литература, 1963 - 829 с.


Основи комп'ютерно-інтегрованого управління

УДК 004.9:681.51(075)
ББК 32.965

Манко Г.І.

Основи комп'ютерно-інтегрованого управління: Інтерактивний навчальний посібник. - Дніпропетровськ: УДХТУ, 2008

Подані теоретичні основи комп'ютерно-інтегрованого управління: характеристики і методи обробки сигналів, класіфікація і аналіз характеристик комп'ютерно-інтегрованих систем. Розглянуті методи побудови ієрархічно-розподілених АСУ. Викладені принципи функціонування комп’ютерно-інтегрованих систем управління. Описані програмні засоби комп’ютерно-інтегрованих систем. Наведені підходи до створення комп’ютерно-інтегрованих виробництв.

Для студентів спеціальності 7.092501 "Автоматизоване управління технологічними процесами"

© Манко Г.І., 2008


Тестовий контроль

Інформаційна ентропія це:
математична міра невизначеності знань про який-небудь об'єкт;
математична міра зменшення невизначеності знань про який-небудь об'єкт;
функція стану термодинамічної системи;
кількість інформації у повідомленні.


Тестовий контроль до розділу 3

Мережа для приладів, використовуваних в автоматичному керуванні технологічним процесом і розміщених в умовах промислового виробництва, називається:
корпоративна мережа;
цехова мережа;
заводська мережа;
польова мережа;
мережа АСУ ТП;
глобальна мережа;


Тестовий контроль до розділу 4

1 До задач функції збирання та первинної обробки інформації НЕ відноситься:
введення аналогових сигналів від датчиків і первинних перетворювачів;
введення дискретних сигналів реле і датчиків стану основного устаткування;
контроль вірогідності введених аналогових та дискретних сигналів;
нормалізація і фільтрація значень введених аналогових сигналів;
обчислення невимірюваних величин та узагальнених показників процесу;
контроль значень введених і розрахованих параметрів та показників на технологічні й аварійні допуски.


Тестовий контроль до розділу 5

1 Програмна система називається відкритою:
при наявності у бібліотеці модулів сучасних досконалих алгоритмів;
при можливості виконувати програми, написані на мовах високого рівня ;
при використанні непроцедурних технологічних мов, що дозволяють легко реалізовувати логічні операції;
якщо для неї визначені і описані використовувані формати даних і процедурний інтерфейс;
якщо вона розроблена з використанням існуючих готових інструментальних проблемно-орієнтованих засобів;
якщо вона розроблена з використанням інструментальних засобів типу SCADA-систем.


Тестовий контроль до розділу 5

1 Рішенням задач організації виробництва на окремій ділянці (цеху, установці) займається система:
ERP;
MRP;
EAM;
MES;
DCS;
SCADA.